Please select Into the mobile phone version | Continue to access the computer ver.
iPhone Disconnects... Arrgghh!!!!
687 6 2017-7-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
TroutboyNZ
Second Officer
Flight distance : 1477720 ft
New Zealand
Offline

I ditched android (S7) and went to an iPhone 7, soley for the purposes of flying the Mavic as Android had a few disconnects for me, so yesterday, first flight of the day along the coast with the iPhone 7, I got around 6 disconnects in an area where I have NEVER had any before, phone was in airplane mode using the standard left-side lightning port. When I got home and reviewed the 2.7k flight, I did see a RC plance hooning below the Mavic, could this have caused the disconnects?

I presume looking at the notifications and what the screen said, they were video downlink disconnects, not RC disconnects, the screen went gray then black and  said something like "disconnected - initiate RTH Yes / No"?  On the first disconnect, I just pushed the RTH button on the controller and it did a perfect RTH, suggesting I still had an RC link? I could also get the app up again just by clicking the iPhone home button and then the Go4 app again - connection would pop right back up.

Here is the notification list of the "downlink data loss" I guess I need to find out if this is video only or total connection loss to the RC?

http://app.airdata.com/main?share=WavoRe

So I then came in and swapped a battery and flew the same route again, with NO disconnects at all, nothing changed? There is not many houses in the area, I did see on the footage, the RC plane again about 20m below me, but no disconnects this time. I had clear air, hills to the left approx 100m in height but not in line of flight. It was windy, approx 20-22kmh winds at 75m. Here is that 2nd trouble free flight:

http://app.airdata.com/main?share=pZGcPM

I don't think the Mavic initiated any RTH on it's own once, again, suggesting they were video downlink issue, not RC issue? As then the Mavic would have initiated it's own RTH on total disconnect? I', running all the latest firmware and app. I tried a Apple standard lightning cable on the 3rd flight connected to the bottom USB and all fine again, like the 2nd flight.

Any insight appreciated as to the first flight issues, looking at the signal map tab, they were pretty major and sudden signal errors out of the blue? Andrew

2017-7-8
Use props
Jenee 2
Captain
Flight distance : 7852129 ft
Australia
Offline

If you look at your sensors, there was definitely some interference. Hard to say whether it was external or some app on your phone running in the background.  Airplane mode does not necessarily stop all apps in the background and one of them may have caused the problem. Having said that, it could also have been an external influence. If it were me, I would find another place to fly.
When I was using my android phone, I had some very high sensor errors with disconnects and could not find any way to fix it. I changed to an ipad mini 4 and removed all unnecessary apps. It does have wifi and 4g but no messaging, phone or anything else running. Now I would be lucky if I had one sensor error more than 1 or 2.
2017-7-8
Use props
TroutboyNZ
Second Officer
Flight distance : 1477720 ft
New Zealand
Offline

Thanks for the reply, I'm leaning to some one-off interference as well - those notifications in the sensor tab are sudden and huge. Forgot to mention there were also numerous 4WD's in the area along the coast, no doubt talking on their CB radio's, is this also a known source of signal disruption? I have probably flown here at least a dozen times and this was the first issue, was a weekend and normally I fly here mid week. Cheers
2017-7-8
Use props
Danjahmouse
lvl.2
Flight distance : 163474 ft
New Zealand
Offline

Which port are you using? I got the same problems when i was using the side port, now i use the bottom one and havent had any issues since. Also sometimes the latest phones arent always the best option, i have a Samsung S5 and although it was great every now and then it would crash SO i went and bought another phone but this time i thought id try a less expensive Phone, The Oppo S9, best choice i made not one app crash at all
2017-7-10
Use props
Jahislove
lvl.1
France
Offline

exactly the same problem here :
mavic 01.03.1000
RC 01.03.1000
app 4.1.9

when connected with RC cable on side port :
-iphone 7 plus  ios 10.3.3 : disconnect and screen went grey . it happen in flight and even at home with the RC and mavic side by side . i need to  unplug/plug cable to solve issue.
-ipad air 2 ios 10.3.3 : no problem

the solution i have found is to not use the RC cable and side port . instead , i use the bottom usb port with the apple cable
2017-9-12
Use props
DocAraxá
First Officer
Flight distance : 202283 ft
Brazil
Offline

You should verify the cable!
2017-9-12
Use props
ImHereToCrash
Captain
Flight distance : 5014068 ft
  • >>>
United States
Offline

cable quality is likely cause here, i agree.   however the micro usb port on the side of the RC does also have fairly poor quality of output i have found myself, slower and laggier with processing i think, now when i fly im flying with cable plugged into buttom full size port that has helped out alot with keeping a solid connection.   i noticed sometimes when i fly my mavic really far and my signal starts to chop in and out i get aircraft disconnected on my ipad screen, look at mavic controller screen and i still have connection....hope it gets cleared up soon..  
2017-9-12
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules