Please select Into the mobile phone version | Continue to access the computer ver.
Camera
520 7 2017-7-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
robertatsaenth
lvl.1
Australia
Offline

Hi guys,
I have a Phantom 3 pro and purchased a new 4K camera back in November 2016 to suit as a spare in case the original got damaged.
I purchased it from an "official DJI seller" on Aliexpress and after some delays I received it late December 2016. as it was a spare I was in no hurry to receive it.
in June my Phatom 3 pro camera started to malfunction (picture was flickering and freezing whilst in flight)so I exchanged it with the new one. Once all was connected and fitted to the Phantom I turned it on but it did not respond when the drone was powered up. My on screen display showed "no camera connected" I checked the connections all were fine. I tried a second time but still no response from the camera. I removed the new camera from the drone replaced it with the original and it connected and operated as it did normally but still with the flickering problem. My question is this do I have to do anything else with the new camera prior to fitting it to the drone in order for it to work?
2017-7-9
Use props
Geebax
Captain
Australia
Offline

Flickering or freezing of the image while in flight are not necessarily camera faults, usually those things occur due to the return video transmission path. Very likely the firmware versions of the 'new' camera and the aircraft will be different, this could easily cause non-functioning of the system.
2017-7-9
Use props
robertatsaenth
lvl.1
Australia
Offline

Geebax Posted at 2017-7-9 20:40
Flickering or freezing of the image while in flight are not necessarily camera faults, usually those things occur due to the return video transmission path. Very likely the firmware versions of the 'new' camera and the aircraft will be different, this could easily cause non-functioning of the system.

The flickering and freezing also happens on the playback of the video
2017-7-9
Use props
Geebax
Captain
Australia
Offline

robertatsaenth Posted at 2017-7-9 22:08
The flickering and freezing also happens on the playback of the video

Playing back the video from where? Are you talking about on your phone/tablet, or from the SD card in the aircraft?
2017-7-9
Use props
robertatsaenth
lvl.1
Australia
Offline

Geebax Posted at 2017-7-9 22:29
Playing back the video from where? Are you talking about on your phone/tablet, or from the SD card in the aircraft?

from the SD card
2017-7-9
Use props
Geebax
Captain
Australia
Offline



When playing back video from the Phantom cameras you have to get a few things correct for best performance. First, do not play back ferom the card itself, always copy it to the main drive of your computer first. Then you need to have a capable computer, not all computers can handle the higher resolution files. If you could post a short piece showing the problem to Dropbox, I could take a look at it and give an opinion.
2017-7-10
Use props
robertatsaenth
lvl.1
Australia
Offline

Geebax Posted at 2017-7-10 02:38
When playing back video from the Phantom cameras you have to get a few things correct for best performance. First, do not play back ferom the card itself, always copy it to the main drive of your computer first. Then you need to have a capable computer, not all computers can handle the higher resolution files. If you could post a short piece showing the problem to Dropbox, I could take a look at it and give an opinion.

I do playback from my PC once I have Removed it from the card. I have always done this and have had no problems. Only recently has the original camera been an issue. As the playback is the same as my view whilst in flight I can only assume there is a problem with the camera. My problem now is the new camera does not even show as connected on the screen nor does it go through the normal start up procedure as the old camera has always done. My question is, does the new camera require more than just to be connected as the old one for it to work or is it a dud as well?
2017-7-10
Use props
Geebax
Captain
Australia
Offline

robertatsaenth Posted at 2017-7-10 22:17
I do playback from my PC once I have Removed it from the card. I have always done this and have had no problems. Only recently has the original camera been an issue. As the playback is the same as my view whilst in flight I can only assume there is a problem with the camera. My problem now is the new camera does not even show as connected on the screen nor does it go through the normal start up procedure as the old camera has always done. My question is, does the new camera require more than just to be connected as the old one for it to work or is it a dud as well?

I don't think anyone can answer that question, there are too many variables. But one thing is probably true, you would more than likely have updated the firmware in the aircraft in that time, but that in the camera woulds have remained the same, not being connected. So you should perform a firmware update to see if it gets the camera working. However, DJI do not issue camera updates everytime they do a firmware upgrade, so that might be difficult to arrange.
2017-7-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules