Please select Into the mobile phone version | Continue to access the computer ver.
[Solved] Assistant 2 - "Frame Alignment Error" VPS calibrate
2024 14 2017-7-10
Uploading and Loding Picture ...(0/1)
o(^-^)o
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

Hi team. I thought I'd licked this issue, but now find I'm being burnt by it consistently again... I'm missing something and looking for a permanent solution.

When I try to do a VPS calibration for either my P4 or P4P using Assistant 2, it displays "Frame Alignment Error" and won't continue to the calibration screen. Instead it says "Reboot the craft", which I do, but to no effect - the message won't go away.

I have had this error with each Assistant 2 release since at least v1.1.0, and is the same with v1.1.2-2. I have in the past had success with going back to v1.1.0 and installing that with driver signature enforcement disabled (so that an unsigned USB driver included in that release is successfully installed), but with no other change to my knowledge I now see the error returned - even with V1.1.0.

Any ideas? Has anyone else managed to find a solution for this?

I run an i7 laptop with a 13" screen and Windows 10. It has a connected 2nd monitor, but I don't use that after prior experience with issues there.
2017-7-10
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

OK, so I read that Assistant 2 v1.0.9 was still available on the P4 download page. I thought "Great!' but when I went there DJI have obviously updated all download links across models to download v1.1.2-2>
Arrrgghhh!

Can anyone provide me a link back to v1.0.9 for Windows, so I can see if I can do a successful VPS calibration using that?
2017-7-11
Use props
SomeoneElsesDro
Second Officer
Flight distance : 419669 ft
United Kingdom
Offline

Punchbuggy Posted at 2017-7-11 14:15
OK, so I read that Assistant 2 v1.0.9 was still available on the P4 download page. I thought "Great!' but when I went there DJI have obviously updated all download links across models to download v1.1.2-2>
Arrrgghhh!

Don't know if you sorted this but I seem to have a copy of 1.0.9 in my backups. Let me know and I'll stick it in dropbox or something
2017-7-14
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

SomeoneElsesDro Posted at 2017-7-14 13:55
Don't know if you sorted this but I seem to have a copy of 1.0.9 in my backups. Let me know and I'll stick it in dropbox or something

Thanks SED - No, I haven't sorted it. I'd appreciate if you could move it to Dropbox for me. Cheers.
2017-7-15
Use props
E.finlay
lvl.2
Flight distance : 1826247 ft
United States
Offline

Had the same thing today.  I tried to use my second big screen and got the frame notice.  Same thing on the laptop so I switched back to my other laptop and it workrd fine.  Ghosts ?
2017-7-16
Use props
SomeoneElsesDro
Second Officer
Flight distance : 419669 ft
United Kingdom
Offline

Here you go mate. I would also be looking to try a few different machines! https://www.dropbox.com/sh/thh6e ... bqWU6MeUdvsC5a?dl=0
2017-7-16
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

SomeoneElsesDro Posted at 2017-7-16 13:12
Here you go mate. I would also be looking to try a few different machines! https://www.dropbox.com/sh/thh6eam6z9x9akv/AAAfXFVT53vbqWU6MeUdvsC5a?dl=0

Thanks SED - I appreciate that. I'll download when I'm home tonight and give it a go with the P4.
And otherwise a good point - I think the last time the VPS calibration worked on my laptop was with my P4P. I recall I had an error then too, but clicking Next still worked.
2017-7-16
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

OK. Solved this.

Going back to Assistant 2 v1.0.9 (thanks SED) didn't help - slightly different error amounting to the same thing - "frame alignment error".

Thought I'd try the latest again - v.1.1.2-2. Uninstalled .09, restarted laptop with driver signature enforcement off (Shift-Restart - Troubleshooting settings), ran the .2-2 executable in Admin mode, and when it opened up the DOS CMD box to install the various drivers I paused the script and received a "no signature - do you want to install?" for one of the drivers - I'm sure the timing of pausing it was coincidental.

So there IS at least one unsigned driver in the latest version of the installation still - you'd think DJI would have sorted this by now.

Ran Assistant 2 .2-2 and once the craft was recognised, entered "Calibration". The "frame error" still appears, but this time it didn't ask me perpetually to reboot the craft and the button to Calibrate could be selected. Yay! VPS calibration successfully performed on both my P4 and P4P.

[edit - days later] So tried to do a VPS calibration ofter another firmware refresh of my P4, and error still there (as above) but this time I can't start calibration again. Huh? Back to yh start! Nothing had changed on my laptop since my last success, so what changed? Aha! Rebooted with driver signature enforcement off and restarted Assistant 2 in Admin mode. Success. Sadly that means that each time I want Assistant 2 to work properly I have to restart Windows with driver enforcement off. Sigh.
2017-7-19
Use props
Duchunter
Second Officer
United States
Offline

Ok so I shut off the driver enforcement and still nothing. The controller shows up in my "connected devises" but assistant 2 doesnt see it and DUMLdore doesnt see it. I can take the same cable and hook up to my p4 and it pops right up but nothing on either controller. I dont know what else to do.
2017-7-23
Use props
Duchunter
Second Officer
United States
Offline

Maybe im hooking it up wrong. I do just go from the mico usb on the controller to the usb on the pc correct?
2017-7-23
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

Duchunter Posted at 2017-7-23 17:32
Maybe im hooking it up wrong. I do just go from the mico usb on the controller to the usb on the pc correct?

I would have thought so, but I never update my RC that way - only the craft. I only update my RC using GO on the phone/tablet using WiFi.
2017-7-23
Use props
Duchunter
Second Officer
United States
Offline

Punchbuggy Posted at 2017-7-23 19:47
I would have thought so, but I never update my RC that way - only the craft. I only update my RC using GO on the phone/tablet using WiFi.

Yeah thats how I did it. I just wanted to backup my rc firmware so I share it for rolling it back but apparently its not necessary.
2017-7-24
Use props
Osee
lvl.3
Flight distance : 530755 ft
United States
Offline

I spent hours trying all the fixes in this forum - i tried two different windows 10 machines and then booted to a win 8.1 and nothing worked - finally i installed win 7 on one of the hard drives ... shazam !
2017-8-24
Use props
Osee
lvl.3
Flight distance : 530755 ft
United States
Offline

I spent hours trying all the fixes in this forum - i tried two different windows 10 machines and then booted to a win 8.1 and nothing worked - finally i installed win 7 on one of the hard drives ... shazam !
2017-8-24
Use props
Fried Toast
lvl.1
Flight distance : 2913802 ft
  • >>>
Japan
Offline

So the "Solved" solution to this is to install Windows 7? It's July 2019 and I'm having this same issue with my P4A+. Sorry DJI, but I'm not installing Win7 just because your DJI Assistant 2 doesn't play well with Windows 10.

7-10 04:00
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules