Please select Into the mobile phone version | Continue to access the computer ver.
S900 with A2 Motors Beeping
3554 7 2014-10-14
Uploading and Loding Picture ...(0/1)
o(^-^)o
david31337
New

United Kingdom
Offline

Hello, having some trouble with my A2 on the s900.

Once I power on with a 4s Lipo I get what sound like warning beeps from all motors with flashes from their LED's (never stops). On my other Heli's this usually means they can't find the flight controller.
I've triple checked my A2 connections from the centre board, the yellow is going into the first 4 pins of the A2 and into the corresponding pins on the board. They are the furthest away pins in both cases.
Using D-BUS on an X8R, everything looks configured in the Assistant, calibrated IMU and my Sticks to near 0 except throttle. I can get ful range on the Taranis, motor test doesn't spin up the motors, so it's like they aren't seeing the A2. Tried replacement cables from board to A2. Only one way to plug each motor into board.




http://www.multirotorforums.com/showthread.php?22738-A2-and-Motors-Beeping-on-S900
WP_20141014_16_46_01_Pro.jpg
WP_20141014_16_45_17_Pro.jpg
2014-10-14
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

we need to see the wiring on the frame side?
2014-10-15
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
United States
Offline

Please power the S900 with the recommend power supply of 6S.  I have viewed your posts on MRF and that is also the conclusion there as well.  You can power the A2 with USB but not the entire craft with 4S.
2014-10-15
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

Oh never saw that he was using 4s.. Correct these ESC have a 6s requirement.
2014-10-16
Use props
DJI-nick
lvl.1

China
Offline

yeah, tahoe and blade is right~
2014-10-21
Use props
sandberg1976
lvl.1

Sweden
Offline

True, the system has protection alert and give you alert on low voltage.. (22V) should be used as 6s.. And when voltage goes too low the system gives this alert..
2014-11-29
Use props
fansed722954
lvl.2
Flight distance : 34892 ft
United States
Offline

I had an exact same problem with my P.O.S S800 and to say DJI WAS UNHELPFUL IS AN UNDEDSTATEMENT! So here's the problem and it's rediculous..  Your using the wrong battery . The A2 flight controller and the S Class multirotors only run off 6s batteries. I had a 14.8v 10,000mah  4s lipo and had the same issue. Purely by accident, my battery was running low, much like my patience so I grabbed my 22.2v 10,000mah 6s lipo, exact same mAh but 6s and vwallah, it powered up .
2019-1-20
Use props
fansed722954
lvl.2
Flight distance : 34892 ft
United States
Offline

I had an exact same problem with my P.O.S S800 and to say DJI WAS UNHELPFUL IS AN UNDEDSTATEMENT! So here's the problem and it's rediculous..  Your using the wrong battery . The A2 flight controller and the S Class multirotors only run off 6s batteries. I had a 14.8v 10,000mah  4s lipo and had the same issue. Purely by accident, my battery was running low, much like my patience so I grabbed my 22.2v 10,000mah 6s lipo, exact same mAh but 6s and vwallah, it powered up .
2019-1-20
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules