Please select Into the mobile phone version | Continue to access the computer ver.
Procedure: Set 2.4GHz with RC and OTG cable
11399 28 2017-7-12
Uploading and Loding Picture ...(0/1)
o(^-^)o
LeChuck71
Second Officer
Flight distance : 43031 ft
Germany
Offline

Hello,
enclosed a procedure how to set the RC connection to 2.4GHz with OTG connection between smartphone and RC.
I did not work out this procdeure all credits go to goalgetter98 in a german forum.
I am just writing here because I think it's inportant information

Lets get started

Spark, RC and GO app should be at its latest state and kind of "normal" working

1. Switch on Spark and RC
2. Wait until Spark and RC connected -> led turns green on RC
3. Connect smart phone to RC via Wifi
4. Start GO 4 app and wait until "Go Fly"
5. Enter Spark on app
6. Switch to 2.4 GHz and select a propper channel
7. Pop up appears to confirm switch and asks for Wifi restart

Now "speed" is key. You must disconnect the wifi before the restart is finished!
The creator of this procedure says wifi off should be within 5 seconds.
Timeline:
Tap "OK" -> Press Home Button -> swipe screen top to bottom (to get your quick selection in Adnroid) -> switch Wifi off
If you can finish this in the same time it took you to read the line above  you shoud be fine.

Let's try it...

8. Tap "OK"
9. Switch Wifi off, as descripted above!
10. Take a deep breath, now you can relax ;)

11. Go 4 app should now state "disconnected"
12. Tap "DJI" upper left corner to go back to the start screen
13. Insert OTG cable -> wait for "connect"
14. Tap "Go fly" and enjoy 2.4GHz ;)

Remark:
It might help to turn off cellular data and bluetooth as well just to improve overall range and stability of the connection

Verified equipment:
Samsung Galaxy S6 Edge+ Android 7, Spark with RC current firmware, Mavic OTG cable









2017-7-12
Use props
Matioupi
First Officer
Flight distance : 922569 ft
France
Offline

Does it stick after system power off/power on ?
2017-7-13
Use props
LeChuck71
Second Officer
Flight distance : 43031 ft
Germany
Offline

Unfortunately it does not.
But if you did it a couple of times its quite easy and quick  ;)

2017-7-13
Use props
nils.heidorn
lvl.4
Flight distance : 183533 ft
Germany
Offline

Hi ! I have one addtion, you shouln not just witch of WiFi but also cellular data (if you have that) or just go for flight mode.
If you have a firewall installed you also just block DJI GO as an alternative after changing wifi freq.

Nils
2017-7-14
Use props
LeChuck71
Second Officer
Flight distance : 43031 ft
Germany
Offline

Hi Nils,

the procedure is just about the frequency change and as far as I have noticed its just a matter of cutting the Wifi connection at the correct moment.
Cellular data or Bluetooth have no impact on that - but maybe have one on overall range performance.

But I will add your note as a remark that those items can have an impact on range performance

Cheers
2017-7-14
Use props
haloXG_Sr
lvl.4
Flight distance : 505505 ft
Czechia
Offline

For some reason I have 2.4GHz connection 'as default' when I use OTG cable and 5.8GHz when using wifi between phone and RC.
2017-7-14
Use props
Jeff7577
First Officer
Flight distance : 1916821 ft
United States
Offline

If you are using a USB cable it takes the place of the wifi connection between phone and controller. Changing this has no effect on the controller to spark connection.
2017-7-15
Use props
Lucas775
Captain
Flight distance : 11546526 ft
  • >>>
United States
Offline

That is a lot of step to connect the cable.  Hopefully an easier and faster way will include in an update.
2017-7-15
Use props
wricks
lvl.2
Flight distance : 39780 ft
United States
Offline

Subscribed for updates.
2017-7-19
Use props
taimingkoh
lvl.2
Singapore
Offline


Subscribed for updates.
2017-7-24
Use props
lyndon_spark
lvl.2
United States
Offline

Thanks for the tip!
2017-7-24
Use props
vcamargo
lvl.1
Flight distance : 20043 ft
United States
Offline

to speed up switch wifi off, better use Airplane Mode
2017-8-2
Use props
ecf_08
lvl.2
United States
Offline

vcamargo Posted at 2017-8-2 06:08
to speed up switch wifi off, better use Airplane Mode

For me, I dont have to do anything with frequency. It seems to me its just sequence. I tried many times and it seems to work with this sequence.

1) Power On Spark
2) Power On RC
3) Connect OTG to Smartphone(already in airplane mode) first then to RC
4) Start DJI Go App 4  (sometimes a message appears asking to use USB by default by this App. Say yes)
5) Go Fly Appears !
2017-8-6
Use props
alan1206
lvl.2
Flight distance : 55935 ft
Hong Kong
Offline

latest version won't let you change frequency. on my GO App with otg. it show 5.8GHz
2017-8-16
Use props
Spaners
lvl.3
Flight distance : 1542 ft
United Kingdom
Offline

Just tried this out
Nexus 7 (2nd gen) 6.0.1
worked perfectly
Firmware on AC and FC is latest version
Spark purchased 31/7/17
2017-8-17
Use props
TyronP
First Officer
Flight distance : 41860 ft
United States
Offline

alan1206 Posted at 2017-8-16 08:18
latest version won't let you change frequency. on my GO App with otg. it show 5.8GHz

Same here. Weird thing is I was flying with OTG and it was 2.4ghz. Changed battery and it changed to 5.8ghz.
2017-8-22
Use props
Bupitz
lvl.2
Flight distance : 269304 ft
France
Offline

Considering that the Spark battery only last for 10-12 minutes, it's annoying to do this everytime. I don't understand why DJI doesn't listen and put this option with the next update. A lot of battery consumed also on the Spark, on the RC and also on the smartphone by doing such workarounds
2017-8-23
Use props
ANHTUANNN503
lvl.2
Flight distance : 17986 ft
Netherlands
Offline

I just wanted to fly for a bit and the damn Spark loses connection after only going about 80meters high. What is the whole purpose of changing the frequency or not even giving the option to change it ourselves.
2017-8-23
Use props
HugoH
lvl.3
Flight distance : 816470 ft
Ireland
Offline

Subscribing this thread for updates
2017-10-3
Use props
Radu Patriciu T
lvl.1
Flight distance : 4997 ft
Romania
Offline

Thanks for tip
2018-1-10
Use props
S.J
Captain
Flight distance : 243041 ft
Kuwait
Offline

ANHTUANNN503 Posted at 2017-8-23 10:36
I just wanted to fly for a bit and the damn Spark loses connection after only going about 80meters high. What is the whole purpose of changing the frequency or not even giving the option to change it ourselves.

Like i told earlier ,you need 5.8Ghz to be displayed on your mobile device and not 2.4Ghz.
2018-1-10
Use props
S.J
Captain
Flight distance : 243041 ft
Kuwait
Offline

haloXG_Sr Posted at 2017-7-14 01:37
For some reason I have 2.4GHz connection 'as default' when I use OTG cable and 5.8GHz when using wifi between phone and RC.

this is correct.  This is required for Andorid versions.
2018-1-10
Use props
LeChuck71
Second Officer
Flight distance : 43031 ft
Offline

From what I know the problem is the follwoing (please correct if wrong)

Connection (all for Android - prefered in bold)

  • Phone -> 2.4GHz -> RC -> 5.8GHZ -> Spark
  • Phone -> 5.8GHz -> RC -> 2.4GHZ -> Spark
  • Phone -> OTG -> RC -> 5.8GHZ -> Spark
  • Phone -> OTG -> RC -> 2.4GHZ -> Spark

Prefered connection should be the 2.4 GHz from RC to Spark due to the better "penetration" of a lower frequency wave. Problem is that Android phones have big problems (RC does not show up in Wifi) connecting to the RC via the 5.8 GHz band - an electronis / Android engineer can explain the problem in the CE region better.

I fly with option #4 and have no problmes so far (App Version 4.1.15)

Cheers
2018-1-10
Use props
GPHENOM
lvl.2
Flight distance : 1237 ft
Germany
Offline

So do I understand correctly that for a 2,4 GHz connection between RC and drone I need a 5,8 GHz displayed on screen when I connect the phone via otg?
2018-1-11
Use props
kev001
lvl.2
Flight distance : 251775 ft
United Kingdom
Offline

I dont understand why it works fine with IOS and not android?
2018-1-11
Use props
LeChuck71
Second Officer
Flight distance : 43031 ft
Offline

GPHENOM Posted at 2018-1-11 03:36
So do I understand correctly that for a 2,4 GHz connection between RC and drone I need a 5,8 GHz displayed on screen when I connect the phone via otg?

Almost,

the connection should Display 2.4GHz AND there should be an "HD" option in the vertical list indicating the OTG connection. There are numerous threads showing the correct "view" ;)

2018-1-12
Use props
djiuser_bACScak0j6oc
lvl.1

Offline

Bupitz Posted at 2017-8-23 05:02
Considering that the Spark battery only last for 10-12 minutes, it's annoying to do this everytime. I don't understand why DJI doesn't listen and put this option with the next update. A lot of battery consumed also on the Spark, on the RC and also on the smartphone by doing such workarounds

Today I set my spark as follows spark on remote on green light, entered app after connection to remote then phone  via otg cable set compass having checked for updates wi fi to at auto on 5.9 g took off in a field with no obstacles clear view and got a weak wifi to drone  signal at 100 feet out, this is the second time this has happened now spark owners should not have to fumble round with settings that have worked over 62 flights so why is this happening and Why is DJI doing NADA about this issue the drone has been re set to factory I find it hard to believe that so may people have reported this issue with no avail

Is my remote faulty as this is the wifi hub

Is the spark faulty

Phone used Samsung S8
2018-9-23
Use props
wino_lino
lvl.1
United Kingdom
Offline

Jeff7577 Posted at 2017-7-15 14:59
If you are using a USB cable it takes the place of the wifi connection between phone and controller. Changing this has no effect on the controller to spark connection.

Sorry for the noob question but does the RC conntect to the Spark by Wi-fi then?
I've been using the cable that came with the controller to conntect my phone to the controller (airplance mode / wifi off) and everything links up nicely but get poor range, around 50m.
2018-9-24
Use props
E Britt
lvl.1
United States
Offline

Im getting rid of mine , dji built the biggest piece of ... possible. I hate this little mother fucker!!
4-21 14:18
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules