Please select Into the mobile phone version | Continue to access the computer ver.
Magic Pro phone loses signal after 1 minute of flight
215 11 2017-7-17 04:18:58
fans24ed4c19
Beginner
United States
Offline

Ever since the most recent update, my Mavic loses signal to my phone after about 1 minute of flight time. The screen no longer transmits an image, says it is disconnected from the drone, and shows no GPS signal. The drone stays in flight and I am able to fly it back. The remote also shows that I have GPS signal, but the phone says disconnected.

Any ideas on how to fix this?
2017-7-17 04:18:58
Use props
Angelo26
Intern Pilot
Flight distance : 240601
Austria
Offline

That´s "normal" with the crappy DJI GO4-software (at least on androids, but balso on iPhones). Just had a flight for testing a complete fresh install of DJI GO4 prior my vacation (want everything to work fine). As usual at first startup (all:smartphone+RC+MP): NO video transmission, second startup: pixelated video feed with lag, 3rd startup: fine for 4-5 minutes of flight, then video-feed starts to lag, after 10 mins of flight videolag is approx. 30-40 seconds ................
2017-7-17 05:19:55
Use props
Griffith
Intern Pilot
Flight distance : 15282
United States
Offline

The screen no longer transmits an image, says it is disconnected from the drone, and shows no GPS signal. The drone stays in flight and I am able to fly it back. The remote also shows that I have GPS signal, but the phone says disconnected.

This is a curious combination of  information.  The  disconnected from the drone, issue would be referring to the RC, since the phone does not connect directly the the Mavic (unless you're in  WIFI mode). Maybe this is an ambiguous message.
If the APP is still functioning (as you seem to indicate) but shows no GPS data and no image, then it's probably not a phone/app issue.  All together it sounds like your RC lost connectivity and was unable to pass telemetry and video downlink to the APP.  This could be due to interference, improper antenna orientation, poor transmission from Mavic or poor receiver in the RC.

I am able to fly it back. The remote also shows that I have GPS signal, but the phone says disconnected.

This, however, sounds like the app has disconnected from the RC and the RC is still connected to the drone.   While, I've never experenced an app disconnect (7 months flying with 2 different android phones), I'm (thinking out loud here) under the impression that the app would revert to the initial "Connect" screen, but maybe it just freezes where it was :-)  I'm sure someone who's experienced this can enlighten me.

2017-7-17 05:55:46
Use props
MARSAN
Intern Pilot
Flight distance : 294735
Belgium
Offline

Angelo26 Posted at 2017-7-17 05:19
That´s "normal" with the crappy DJI GO4-software (at least on androids, but balso on iPhones). Just had a flight for testing a complete fresh install of DJI GO4 prior my vacation (want everything to work fine). As usual at first startup (all:smartphone+RC+MP): NO video transmission, second startup: pixelated video feed with lag, 3rd startup: fine for 4-5 minutes of flight, then video-feed starts to lag, after 10 mins of flight videolag is approx. 30-40 seconds ................

Why do you blame the DJI GO 4 app?
Version 4.1.3 (Android) of DJI GO 4 works very well on my Samsung Galaxy S8.
You may want to try a different phone.
2017-7-17 06:04:52
Use props
Griffith
Intern Pilot
Flight distance : 15282
United States
Offline

MARSAN Posted at 2017-7-17 06:04
Why do you blame the DJI GO 4 app?
Version 4.1.3 (Android) of DJI GO 4 works very well on my Samsung Galaxy S8.
You may want to try a different phone.

As I mentioned earlier, I've been flying the Mavic for almost 8 months, with 2 different androids (S5 and S8), with multiple GO 4 versions (4.0 to current)  with NO app disconnects.  My opinion of all the reported android problems, is that they evolve from all other crap apps that are loaded. (Google Play does a very poor job, IMO, of app screening).
2017-7-17 06:08:19
Use props
MARSAN
Intern Pilot
Flight distance : 294735
Belgium
Offline

Griffith Posted at 2017-7-17 06:08
As I mentioned earlier, I've been flying the Mavic for almost 8 months, with 2 different androids (S5 and S8), with multiple GO 4 versions (4.0 to current)  with NO app disconnects.  My opinion of all the reported android problems, is that they evolve from all other crap apps that are loaded. (Google Play does a very poor job, IMO, of app screening).

I agree with you, and on top of that we don't know whether the people who have a problem with DJI GO 4 on their Android phones have not rooted their devices.
2017-7-17 08:47:11
Use props
JBK
Beginner
United States
Offline

MARSAN Posted at 2017-7-17 08:47
I agree with you, and on top of that we don't know whether the people who have a problem with DJI GO 4 on their Android phones have not rooted their devices.

I have the same problem of the app showing disconnected but the link between the controller and the Mavic is working correctly. I have had this happen when just starting up after the controller & Mavic are on and connected. I have also had it happen while flying. When it happens during starting up the only solution I have found is to restart the phone/tablet. When it has happened during flight I still have control and the disconnect message sometimes goes away on it's own. I have tried using an iPhone 7 with the short USB cable that plugs into the side of the controller and with an iPad Mini 4 using an USB cable to the connector on the center bottom of the controller. I have current firmware in controller/Mavic, latest iOS software in phone/tablet, and current version of DJI Go 4.1.3. I have tried reinstalling the DJI app and the problem is still there. I spent a long time in a chat session with DJI and they didn't provide any help. Any suggestion for solution would be appreciated.
2017-7-17 11:17:52
Use props
JBK
Beginner
United States
Offline

JBK Posted at 2017-7-17 11:17
I have the same problem of the app showing disconnected but the link between the controller and the Mavic is working correctly. I have had this happen when just starting up after the controller & Mavic are on and connected. I have also had it happen while flying. When it happens during starting up the only solution I have found is to restart the phone/tablet. When it has happened during flight I still have control and the disconnect message sometimes goes away on it's own. I have tried using an iPhone 7 with the short USB cable that plugs into the side of the controller and with an iPad Mini 4 using an USB cable to the connector on the center bottom of the controller. I have current firmware in controller/Mavic, latest iOS software in phone/tablet, and current version of DJI Go 4.1.3. I have tried reinstalling the DJI app and the problem is still there. I spent a long time in a chat session with DJI and they didn't provide any help. Any suggestion for solution would be appreciated.

Are you supposed to turn off the cell and WiFi in the phone/tablet when using it with controller? I have wondered if that may be causing interference with the interface.
2017-7-17 11:20:40
Use props
MARSAN
Intern Pilot
Flight distance : 294735
Belgium
Offline

JBK Posted at 2017-7-17 11:17
I have the same problem of the app showing disconnected but the link between the controller and the Mavic is working correctly. I have had this happen when just starting up after the controller & Mavic are on and connected. I have also had it happen while flying. When it happens during starting up the only solution I have found is to restart the phone/tablet. When it has happened during flight I still have control and the disconnect message sometimes goes away on it's own. I have tried using an iPhone 7 with the short USB cable that plugs into the side of the controller and with an iPad Mini 4 using an USB cable to the connector on the center bottom of the controller. I have current firmware in controller/Mavic, latest iOS software in phone/tablet, and current version of DJI Go 4.1.3. I have tried reinstalling the DJI app and the problem is still there. I spent a long time in a chat session with DJI and they didn't provide any help. Any suggestion for solution would be appreciated.

May I suggest that you start a new thread, otherwise no one will see your question in this discussion here.
2017-7-17 11:47:13
Use props
DJI Diana
Administrator
Japan
Offline

What phone are you using? Have you tried other mobile devices? If yes, how is it going?
2017-7-18 02:16:12
Use props
DJI Diana
Administrator
Japan
Offline

JBK Posted at 2017-7-17 11:17
I have the same problem of the app showing disconnected but the link between the controller and the Mavic is working correctly. I have had this happen when just starting up after the controller & Mavic are on and connected. I have also had it happen while flying. When it happens during starting up the only solution I have found is to restart the phone/tablet. When it has happened during flight I still have control and the disconnect message sometimes goes away on it's own. I have tried using an iPhone 7 with the short USB cable that plugs into the side of the controller and with an iPad Mini 4 using an USB cable to the connector on the center bottom of the controller. I have current firmware in controller/Mavic, latest iOS software in phone/tablet, and current version of DJI Go 4.1.3. I have tried reinstalling the DJI app and the problem is still there. I spent a long time in a chat session with DJI and they didn't provide any help. Any suggestion for solution would be appreciated.

Have you tried to run the APP when your phone is in Airplane mode?
2017-7-18 02:17:01
Use props
fans24ed4c19
Beginner
United States
Offline

Thank you to everyone that replied. To answer some of your questions...

After writing the post, I flew the drone off my back porch for several minutes with no issues. All of my previous flights that encountered the disconnect from my phone occurred over water; however, I have flew it over water off of a boat multiple times without an issue prior to the update.

Now, I'm concerned there may be an interference on the boat since I was able to fly it at home.

I'm using an iPhone 7. I have not tried another phone because my wife's is older and I wasn't sure it could run the app efficiently.

Is anyone else experiencing issues flying off a boat over water since the latest update?

2017-7-18 10:00:19
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next