Please select Into the mobile phone version | Continue to access the computer ver.
X5S video stuttering badly [FIXED]
404 22 2017-8-3 08:40:41
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

Hello, I am really new to the video world so I beg you pardon for bringing up what is for sure a very basic issue to which i can't find an answer.
I recorded the video below on my X5S with the following settings: PAL 25fps and shutter 1/60s, stock SD card that comes with the inspire 2, but the video looks very choppy.
Every video tutorial states that recording should be done at 1/50s or 1/60s shutter speed to introduce cinematic motion blur but as you can see from the video something went the wrong way.
Besides constant micro stuttering there is also the occasional macro stuttering.
I'm lost and I could not find the answer by just googling, any hint would be appreciated.

2017-8-3 08:40:41
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

I forgot to say that i get this issue when I change the yaw. I haven't tried just rotating the camera but never the less this is frustrating, what am I doing wrong?
2017-8-3 09:15:32
Use props
DJI Mindy
Administrator
Japan
Offline

Elettrone, please do more test: reset camera setting firstly, and then take a short video in Anto mode in daylight.
The post the original footage to Dropbox or Google Driver and post the link here, we will help to analyze. Thanks for your time.
2017-8-3 22:30:54
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

DJI Mindy Posted at 2017-8-3 22:30
Elettrone, please do more test: reset camera setting firstly, and then take a short video in Anto mode in daylight.
The post the original footage to Dropbox or Google Driver and post the link here, we will help to analyze. Thanks for your time.

The video posted is a partially graded D-Log footage, i haven't changed much of the camera settings.
Here is the original file: https://www.dropbox.com/s/jgyovnv20rq9lrb/DJI_0010.MOV?dl=0

If you mean full auto mode I can do that but the shutter speed won't be fixed at 1/50th, anyway here's the footage:

https://www.dropbox.com/s/6ysygv ... ftRotation.MP4?dl=0
https://www.dropbox.com/s/mvemcm ... alRotation.MP4?dl=0
https://www.dropbox.com/s/58qeny ... ftRotation.MOV?dl=0
https://www.dropbox.com/s/jchx4j ... alRotation.MOV?dl=0

I reset the X5S as you suggested, please let me know what you think.



2017-8-4 07:13:39
Use props
WayneMann
lvl.2
United States
Offline

You are panning way too fast for 25P and the shutter speed should be at 1/50.  1/60 of a second shutter speed with the same pan speed will make the video stutter even worse.  If you need to pan that fast then you will have to shoot at 60P with a shutter speed of 1/120 of a second.


Wayne
2017-8-4 18:59:33
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

The first video is 25fps 1/50th, hell I even tried 25fps-1/25th to add more motion blur but didn't help one bit. anyway i tried even 60fps-1/120 and 120fps-1/240th, the video becomes smooth but wobbles UPDATE(20:17 GMT+1) but now that I think of it I might have tried that hi-fps on my P4P rather than my Inspire(I've been shooting with both).
Anyway today I found this: Panning best practices by Red Digital Cinema

Tomorrow I'll be shooting more tests following these guidelines with the inspire 2 and see the results.



2017-8-5 06:24:22
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

Today i shoot this panning way slower than the rule of thumb and hi-fps still the video is jittering randomly.
I carefully observed the gimbal rotation and to the eye looks very smooth so I guess something is going wrong hardware or software side between the camera body and the aircraft.
Waiting for any input before requesting RMA.

https://www.dropbox.com/s/yncji8g9kkio1lr/DJI_0004_NTSC_120fps_1on240shutter.MP4?dl=0

I would like to add that I could see the video jittering in real time on my iPad while recording...if that means something.
2017-8-6 03:23:30
Use props
fans4f8954b4
lvl.4
Flight distance : 5479440
France
Offline

Electrons I have the exactly the same problem, from day one, tried all settings, and nothing help me to solve it.
2017-8-6 13:57:33
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

fans4f8954b4 Posted at 2017-8-6 13:57
Electrons I have the exactly the same problem, from day one, tried all settings, and nothing help me to solve it.

It's a professional level drone, these issues shouldn't happen, if I don't get an official answer soon I'll apply for RMA.
2017-8-6 23:35:49
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

Omg how long do I have to wait to get someone to pick up my case -_-" not an official word on the subject.
2017-8-7 13:12:32
Use props
DJI Mindy
Administrator
China
Offline

Elettrone78 Posted at 2017-8-7 13:12
Omg how long do I have to wait to get someone to pick up my case -_-" not an official word on the subject.

Elettrone, the videos have been forwarded to our R&D engineers for further analysis, I will come back to you once I hear from them, your patience will be appreciated.
2017-8-8 01:57:56
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

Yes I will wait as long as someone is actively looking into my case, thank you.
2017-8-8 03:31:35
Use props
fans4f8954b4
lvl.4
Flight distance : 5479440
Israel
Offline

Wait for dji's answer as well.
2017-8-8 04:37:25
Use props
WayneMann
lvl.2
United States
Offline

You need to try and play these videos on a different, preferably faster computer.  If it is randomly stuttering it is most likely due to the computer not being able to keep up.  Go the section of the video that stutters and stop the video for a few seconds and let the computer catch up, then when you hit play again the video will play smooth for a few seconds or so and then probably start stuttering again.  

Wayne
2017-8-8 10:59:05
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

WayneMann Posted at 2017-8-8 10:59
You need to try and play these videos on a different, preferably faster computer.  If it is randomly stuttering it is most likely due to the computer not being able to keep up.  Go the section of the video that stutters and stop the video for a few seconds and let the computer catch up, then when you hit play again the video will play smooth for a few seconds or so and then probably start stuttering again.  

Wayne
Look it's not computational power, but now that you mention it I noticed something, I'll report back when I have a better understanding of what's happening.
2017-8-11 22:48:34
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

OK this is what I found out:

- The original 120fps video on Windows Media Player or VLC stutters even on a Core i7@3,4Ghz but not on Plex video suite. Plex will playback the video smoothly even on a crappy Pentium client(tested).
- I reset Handbrake video encoder settings to handle automatically h264 profiles and configuration, I only set the quality output and the trascoding accuracy(speed) and magically all the transcoded videos run smoothly on any player.

My conclusions:

- The Inspire 2 has no defect or issues whatsoever
- For some reason that goes beyond my knowledge the default windows player doesn't like the original footage but the fact that Plex works like a charm makes me think that the issue is not on the computational side, even a low end pc will run the files smoothly.
- It looks like I had some "weird" settings in Handbrake even tho i transcoded files coming from my Canon EOS 1DxII with no issues of the sort, resetting them fixed the thing.
- 25/30fps is not enough to perform a smooth panning that runs equal or more than one full screen frame in less than 7 seconds.

Now if I really were to complain on something I could argue that there's a some aliasing on straight lines in the indoor video.
I hope that my experience helps someone else, thanks for the participation.
2017-8-12 01:56:29
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

fans4f8954b4 Posted at 2017-8-8 04:37
Wait for dji's answer as well.

Let me know if this is of any help.
2017-8-13 04:05:42
Use props
fans4f8954b4
lvl.4
Flight distance : 5479440
France
Offline

Elettrone78 Posted at 2017-8-13 04:05
Let me know if you this is of any help.

I'm working on Mac, a powerful one, was trying all fps settings nothing help. Now I'm videoing with no panning,  just  forward. Very disappointed !!
2017-8-13 21:06:46
Use props
JBSonic
lvl.4
Flight distance : 29639
United Kingdom
Offline

Buy's a professional grade drone and does not know how to playback high bitrate h.264 files? Come on.
Also, keep in mind that if you record in h.265 it will be much harder for your PC to play back the video too.

Also, test the video in a NLE or other professional video production software. You trying to play this back in Windows Media Player makes me laugh
2017-8-14 06:04:14
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

JBSonic Posted at 2017-8-14 06:04
Buy's a professional grade drone and does not know how to playback high bitrate h.264 files? Come on.
Also, keep in mind that if you record in h.265 it will be much harder for your PC to play back the video too.

WMP is the standard platform that 90% of my customers use toplay back, need I to say more?The post processing is done in Premiere or DaVinci...
I made video with my Canon EOS 1DXII before buying a drone and never had one issue.
Not once, have a nice day.
2017-8-14 14:00:58
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

fans4f8954b4 Posted at 2017-8-13 21:06
I'm working on Mac, a powerful one, was trying all fps settings nothing help. Now I'm videoing with no panning,  just  forward. Very disappointed !!

Have you tried running the files with Plex?
Transcoding with default h264 settings, even auto settings?
2017-8-14 14:06:43
Use props
DJI_camera
lvl.1
Canada
Offline

Dear Elettrone78,
I have analyzed your videos seriously. I found the main cause the of none-smooth came from the uneven movement of flight or gimbal.

So  if you want to get the video which is more smooth, I have two suggestion:
1. make the gimbal or flight to move as even as possible;
2. if you want  to get the cinematic motion blur, you can refer this page:http://beyondthetime.net/cinematic-motion-blur-180-rule/

Hope these info can resolve your issue. If you have any doubt, please contact with our guys, will try our best to give more info to you .Thanks for your support of our product.
2017-8-14 23:37:30
Use props
Elettrone78
lvl.2
Flight distance : 2786
Italy
Offline

DJI_camera Posted at 2017-8-14 23:37
Dear Elettrone78,
I have analyzed your videos seriously. I found the main cause the of none-smooth came from the uneven movement of flight or gimbal.

Obviously you haven't.
If you did watch the last video you wouldn't say such things.
Anyway I fixed the issue on my own, thanks for nothing.
2017-8-16 23:08:29
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next