Please select Into the mobile phone version | Continue to access the computer ver.
Unable to connect Mobile to RC
463 2 2017-8-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
Firecat83
lvl.2
Flight distance : 89974 ft
United States
Offline

I am using a Samsung TAB 4, OS Ver 5.1.1.  I have tried to update firmware, on RC and unable to do that.  RC does not See Phantom 4 either.  Phantom 4 has a green LED, tried to bind controller to Phantom 4 but they do not talk.  I used Assistant 2 to try and access the RC, but the only option is to set firmware to Default.  I have tried to do this, but it times out.  I have a red led on RC, 2 Solid red arms, and 2 quick yellow flashing on other 2 arms.  I am totally frustrated.  HELP!!!!!!
2017-8-9
Use props
Aardvark
Captain
Flight distance : 384432 ft
  • >>>
United Kingdom
Offline

The two front LEDs are always red, the navigation lights. The two rear flashing yellow just means that it has no control signal to controller (no surprise there). The red LED on controller usually turns green when comms established with the aircraft.

You could perhaps try a controller reset & re-link with aircraft.

This works for P3 & P4 controller, but I don't know if it's valid for the P4P controller. But worth a try:-

* Turn on the controller, the aircraft should be off.
* Press C1, C2 (The two buttons on back of RC), and shutter (top right button nearest antenna) on the controller and hold for about 2 seconds or so until it beeps (D-DDD), then turn the controller off.
* Turn on both the aircraft and the controller and link the remote if needed.

This can be done manually (without using DJI Go):-

* Turn on both the aircraft and the controller.
* Press C1, C2, and the record button (top left button) on the controller, then the controller will beep 'D-DD'.
*Let go all fingers, then press the wheel on the right side of the controller (It's a 'click wheel', similar to a mouse wheel) and then the first light of the controller will become blue and it will constantly beep DDDD.
* Use a pen to click the linking button on the aircraft and hold for 3-5 seconds, and then take the pen off the aircraft and wait, it will link soon.
2017-8-9
Use props
DJI Susan
Administrator

Offline

I would recommend you to link RC without DJI GO: Hold C1, C2, and the record button at the same time and then press wheel on the right side for 2 seconds. Last, click the linking button for 2 seconds, you will see the LED light changes to show whether linking RC successful or not.
After that, you can contact with DJI GO of mobile to check the performance.
2017-8-9
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules