Please select Into the mobile phone version | Continue to access the computer ver.
RC is charging phone, not connecting
125 2 2017-8-13 06:51:38

Hey everyone, would really appreciate some help here No matter what I do, the DJI GO 4 app does not connect to the drone. Instead, the RC only charges my iPhone 7 (or any of the phones I tried with multiple different cables, which I will explain below).
First, the micro USB-Lighting does not work with my phone or any other I tried. I was then instructed to disconnect the side micro USB and connect the drone using the USB port on the bottom of my RC, and I did so using a USB-Lighting cable. It did not work, instead my RC started to charge the phone and all others I tried. After a couple of hours trying to establish a connection, I decided to try to connect sing different Lighting cables, always keeping the side micro USB port free on the RC (I’m aware the bottom USB won’t work if there is a micro USB connected). I did so with 3 different phones and 4 different Lighting cables, some Apple original, some not, a total of 12 combinations.

None of them worked, I kept having a “disconnected” message on the DJI GO app and the RC started charging the phones all the times (and kept charging until I disconnected the cable). Also, I already tried to delete and reinstall the app, which I did on all 3 phones, without success. Finally, I decided to downgrade both my RC and my Mavic firmware to version 0.8, and later restore both to factory settings. After that, finally I was able to fly for two days, and just left all these problems behind.

Today, however, I tried to fly my Mavic using my iPad. I installed the DJI GO 4 app on my iPad Air, and not only it did not work but also it simply stopped working back on my iPhone 7. Whenever I start the RC, start the Mavic and connect the USB cable to my iPhone 7, it just displays “disconnected” on the app and I can’t fly (and the RC starts charging my phone). Again, I ran the test with 3 different phones, different cables and nothing. Then, I tried to upgrade to 0.9 (both RC and drone), and nothing. Downgraded both to 0.8, nothing. Finally I tried to restore everything to factory settings, but now I got an error message (did so using 2 different computers also, using the Assistant).

Finally, I had next to me a friend using an Android phone (6.0), and asked to try to connect my Mavic to her phone. Installed the DJI GO 4, plugged the phone on the bottom USB cable and to my surprise it worked. I was able to finally access my Mavic, but again coming back to any of my 3 iPhones or my iPad it just doesn't work.

Bottom line: I cannot connect any iPhone to the RC, and the RC is charing all the iPhones I try to use it with, and this is the case for 4 different cables (even though they do transfer data as I can use all of them to sync my phones to a notebook.)

Any thoughts? Thanks!

2017-8-13 06:51:38
Use props
Andy in SW Fla
United States

I've been working this same issue for months. Please share if you find a solution. WiFi mode works if you want to fly within a stones throw.
2017-8-13 08:11:01
Use props
DJI Thor

Could you please provide us with a video which shows that you have used both the side port and the bottom port to connect your iPhone?
If you can not connect iOS devices, I suggest sending the controller in, we'll help to check and handle it. Please fill in some info on our online repair link of our official web and then send it back. Here is the link:
We will do our best to help this out. Thank you.
2017-8-14 00:07:56
Use props
You need to log in before you can reply Login | Register now

Credit Rules


DJI RecommendsPrevious /1 Next