Please select Into the mobile phone version | Continue to access the computer ver.
Crash app DJI Go Android during Quick shot
101 9 2017-9-14 03:41:28
Pirikitto
Hobbyist
Flight distance : 6571
Italy
Offline

Hi, I have a LG G2 with Android Kitkat 4.4, it works fine except the quick shot when i dump the dronie for example spark performs the motion but the app crash always, this is the error

=====        Device Info        ===== manufactureGE product:tigers_open_com model:LG-D802 version:KOT49I android version:4.4.2 sdk version:19 =====        App Info        ===== versionCode:1025605 versionName:4.1.8 =====        Crash        ===== java.lang.NoSuchMethodError: android.media.MediaCodecInfo$CodecCapabilities.getEncoderCapabilities         at dji.midware.media.e.a(SourceFile:229)         at dji.midware.media.record.l.e(SourceFile:388)         at dji.midware.media.record.e$c.run(SourceFile:116)         Suppressed: java.lang.Throwable: HERE SDK Version: 3.4.0.165                 at com.nokia.maps.MapsEngine$l.uncaughtException(SourceFile:369)                 at com.amap.api.col.ex.uncaughtException(SourceFile:146)                 at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:693)                 at java.lang.ThreadGroup.uncaughtException(ThreadGroup.java:690)
Thanks
2017-9-14 03:41:28
Use props
S-e-ven
Student Pilot
Flight distance : 115340
Thailand
Offline

I cannot say, it is the LG G2, but I do not use my LG G4 any longer and almost all my probs with lag, video, ....., are just gone.
2017-9-14 03:50:08
Use props
Pirikitto
Hobbyist
Flight distance : 6571
Italy
Offline

the smartphone is old without doubt but I did not notice big problems in the general use apart the quickshot, I noticed that it does not even use the cpu at max so I do not think it's okay to change it
2017-9-14 04:37:32
Use props
DJI Thor
Administrator
China
Offline

Do you have another mobile device to try with? Coz LG G2 is not on the support list, so it is hard to find what had happened, or it could be the device compatibility issue. Please try if other devices will also have the same issue. Thank you. 移动设备列表.jpg
2017-9-14 04:44:10
Use props
El Diablo
Hobbyist
Germany
Offline

Pirikitto Posted at 2017-9-14 04:37
the smartphone is old without doubt but I did not notice big problems in the general use apart the quickshot, I noticed that it does not even use the cpu at max so I do not think it's okay to change it

I don't want to sound like a gig but check the list supported devices for the Spark. If an older device is not optimized to run the app it might cause some issues... In general I believe Android devices aren't so stable as iOS. Initially was flying my Mavic (and now the Spark) with my Galaxy Note 4 and it was quite worse than my iPhone 7 plus.
2017-9-14 05:10:16
Use props
Charles Adams
Intern Pilot
Flight distance : 61878
United States
Offline

I bought a cheap Wal Mart phone that I did not activate, just for the purpose of using it with my drones.  And it works, but I found similar behavior to what you are reporting.  The quickshots will not function correctly when using this phone.  I have surmised that this is because it is an unsupported phone and it does not contain enough horsepower to run the app effectively.

It sounds like this is what you are experiencing.
2017-9-14 09:06:20
Use props
WickedWingman
Hobbyist
United States
Offline

i just flew with my phone connected to my rc instead of my tablet like i usually do.  it crashed trying to set the window for a quickshot.  it's a relatively new phone - motorola droid turbo 2.  plenty of horsepower there.  luckily it wasn't in motion when it crashed, so it just hovered while i rebooted the app.  flew it for 2 more batteries without issue.
2017-9-14 09:56:22
Use props
Pirikitto
Hobbyist
Flight distance : 6571
Italy
Offline

Charles Adams Posted at 2017-9-14 09:06
I bought a cheap Wal Mart phone that I did not activate, just for the purpose of using it with my drones.  And it works, but I found similar behavior to what you are reporting.  The quickshots will not function correctly when using this phone.  I have surmised that this is because it is an unsupported phone and it does not contain enough horsepower to run the app effectively.

It sounds like this is what you are experiencing.

the smartphone is definitely old but in my opinion the cpu and ram are good for running the DJI Go 4 app! From the error it would seem a codec problem
however, I understand very well that you can not have complete compatibility with old phones, I will try to update the software and finally change the smartphone

Thanks
2017-9-14 10:31:09
Use props
Pirikitto
Hobbyist
Flight distance : 6571
Italy
Offline

WickedWingman Posted at 2017-9-14 09:56
i just flew with my phone connected to my rc instead of my tablet like i usually do.  it crashed trying to set the window for a quickshot.  it's a relatively new phone - motorola droid turbo 2.  plenty of horsepower there.  luckily it wasn't in motion when it crashed, so it just hovered while i rebooted the app.  flew it for 2 more batteries without issue.

I can launch the quickshot function and I also have the movie in sd, the problem is that after I launch the app crash and I need to relaunch it
2017-9-14 10:33:35
Use props
Charles Adams
Intern Pilot
Flight distance : 61878
United States
Offline

Pirikitto Posted at 2017-9-14 10:33
I can launch the quickshot function and I also have the movie in sd, the problem is that after I launch the app crash and I need to relaunch it

Yes, it's a bit different from my behavior, but I think it's roots are still the same...  a device which doesn't quite have the necessary power to drive the performance the app needs.

I've had my app on my "weak phone" crash too, which is quite disconcerting.

I think the solution to the issue you are reporting is (unfortunately  to invest in a more powerful device.
2017-9-14 10:36:07
Use props
You need to log in before you can reply Login | Register now

Credit Rules

Close

DJI RecommendsPrevious /1 Next