Please select Into the mobile phone version | Continue to access the computer ver.
OTG cable not working
996 24 2017-9-15 06:25:35
Uploading and Loding Picture ...(0/1)
o(^-^)o
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Hello.
First of all I'm sorry for my english. I bought my DJI Spark Combo few days ago and I have few issues with distance range. I live in Europe. In 5.8 GHz mode I can fly max 50m from me. I use OnePlus X with doesn't have 5.8 GHz WiFi or something like that, so if I change mode to 2.4 GHz I don't see wifi from RC on my phone. I saw many videos how can I connect RC to phone using OTG cable and I can do this and it's working pretty good, but in 9/10 cases OTG connection won't work. It's connecting, and I can fly, but every few seconds it's disconnecting and connecting again "lost signal, aircraft disconnected, .., ready to fly" over and over again. To deal with it I must power off everything, power on again, change mode to 2.4 GHz, turn off my wifi, connect via cable and.. sometimes it will work, but usualy don't.

I have off bluetooth, internet connection from sim card and everything. Also I tested it with airplane mode, it doesn't matter. I refreshing software with DJI Assisant and factory reset to default settings. I tested two different OTG cables. It's frustrating. Any ideas?
2017-9-15 06:25:35
Use props
premium
lvl.1
Flight distance : 701
Indonesia
Offline

here is the sequences , if you're using OTG . ( i copied this from someone else )

1) switch on remote (nothing plugged in)
2) switch on spark
3) Wait for green light on controller
4) switch on ipad/iphone
5)open up DJI Go4 App you will have a grey screen.
6) plug in lightning cable to ipad/iphone
7) plug in usb end og lightning into the otg cable
8) plug otg cable into remote
9) pad/controller will rumble to mark connection
10) You'll get the "This accessory may be etc, etc" HIT dismiss
11) Camera view pops up.
2017-9-15 06:53:08
Use props
premium
lvl.1
Flight distance : 701
Indonesia
Offline

regarding 50m distance, try flying your spark at open space where there is no (almost) zero interference such telephone pole ,power pole etc
2017-9-15 06:58:01
Use props
Wachtberger
First Officer
Flight distance : 24610
Germany
Offline

The error messages that you are getting have nothing to do with the OTG cable. They relate to connection problems between the RC and the Spark.
Are your Spark, all batteries and the RC on the latest firmware version?
2017-9-15 07:02:38
Use props
Charles Adams
Second Officer
Flight distance : 74109
United States
Offline

premium Posted at 2017-9-15 06:53
here is the sequences , if you're using OTG . ( i copied this from someone else )

1) switch on remote (nothing plugged in)

My order is slightly different, but I've done this startup and it works for me as well.  The most important steps I have found are that plugging OTG into RC comes AFTER plugging usb into personal device.

Something else to add:  I have found that the cables aren't as rugged as I would hope, so I've had connection issues that turn out to be cable related.  My early OTG cable kind of fell apart on the inside.  What I'm recommending is that if you continue to have connection issues that you change out cables and try.  I now carry two otg cables and three usb cables.
2017-9-15 07:04:16
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

I do everything as in the instruction above, I try to first plug cable into RC, second into phone and vice versa. Sometimes it's working, but usualy not. I live in small village on a new housing estate, there are only 2 wifi connections and there is no inerference (only green dashes).

I bought it few days ago, so I must update firmware, because I can't fly without do that. But on latest app on android I have a problems with updating RC, so I've installed 4.1.5 version, and then RC was updated correctly. And this problem with Spark only exist when I try to use OTG cable, when I connect via wifi on 5.8 GHz I don't have any problems (without distance).
2017-9-15 07:15:00
Use props
Charles Adams
Second Officer
Flight distance : 74109
United States
Offline

Myszku Posted at 2017-9-15 07:15
I do everything as in the instruction above, I try to first plug cable into RC, second into phone and vice versa. Sometimes it's working, but usualy not. I live in small village on a new housing estate, there are only 2 wifi connections and there is no inerference (only green dashes).

I bought it few days ago, so I must update firmware, because I can't fly without do that. But on latest app on android I have a problems with updating RC, so I've installed 4.1.5 version, and then RC was updated correctly. And this problem with Spark only exist when I try to use OTG cable, when I connect via wifi on 5.8 GHz I don't have any problems (without distance).

I think that Wachtberger is right and that what you are seeing is not related to the OTG cables.  But focusing on the order, you mentioned that you plug into RC first.  That's not how I do it.  I plug into RC last.  I have experienced problems when I connect to RC first and then the phone.  I have very few problems if I go phone first and then the RC.
2017-9-15 07:21:57
Use props
Wachtberger
First Officer
Flight distance : 24610
Germany
Offline

I can confirm, plugging in the RC first normally does not work. RC has to be fully started with red LED permanent light. Then plug in cable into your Android phone and then into the RC. DJI Go will normally be launched automatically then and state "RC connected".
But I have to repeat, the error messages that you have quoted are purely related to the connection between your RC and the Spark, not to the connection between your phone and the RC, thus cannot be related to the OTG cable.
2017-9-15 07:35:11
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Wachtberger Posted at 2017-9-15 07:35
I can confirm, plugging in the RC first normally does not work. RC has to be fully started with red LED permanent light. Then plug in cable into your Android phone and then into the RC. DJI Go will normally be launched automatically then and state "RC connected".
But I have to repeat, the error messages that you have quoted are purely related to the connection between your RC and the Spark, not to the connection between your phone and the RC, thus cannot be related to the OTG cable.

I tried it and it's still not working. I've recorded screen from my phone what is happening when I change mode to 2.4 GHz using wifi connection and then connecting via OTG cable.
I do everything in this way:
1. power on RC
2. power on Spark
3. connect to RC wifi using phone
4. tap "Go fly" in app
5. change mode to 2.4 Ghz
6. disable wifi
7. connect cable to phone, than to RC (I've tired phone-RC, RC-phone, it doesn't matter)
and that's it, after that my Spark working with RC (I can control it), but it's still reconnecting and the picture from the camera disappears. Sometimes throws me out from app to home screen.

There is a video:
And I'm sorry for quality.
I've started recording after connection to RC wifi network.
2017-9-15 11:07:06
Use props
Jr 5542
lvl.3
United States
Offline

You have to plug the OTG last or it won't connect and everytime you switch battery you have to follow the same sequence again.
2017-9-15 11:25:56
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Jr 5542 Posted at 2017-9-15 11:25
You have to plug the OTG last or it won't connect and everytime you switch battery you have to follow the same sequence again.

I do it. After changing mode to 2.4 GHz I turn off wifi network (screen is gray) and than I plug the OTG cable to phone and to RC.
2017-9-15 11:30:29
Use props
Virgil Quick
lvl.3
Flight distance : 50865
United States
Offline

Are you using a cable adaptor along with the cable?
2017-9-15 11:43:30
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Virgil Quick Posted at 2017-9-15 11:43
Are you using a cable adaptor along with the cable?

I'm have 2 different OTG, a long time ago I bought this adaptor: https://www.gearbest.com/usb-flash-drives/pp_241630.html is quite cheap, but with pendrive, mouse in phone it's working. When I used it for my Spark it didn't work (like on video), so I bought this: https://www.hama.com/c1078426/ha ... -socket-black-015-m and is the same. I connect them to usb cable included with the Spark also I tired to connect via my phone usb cable, but nothing has changed.
2017-9-15 11:50:25
Use props
Wachtberger
First Officer
Flight distance : 24610
Germany
Offline

Myszku Posted at 2017-9-15 11:07
I tried it and it's still not working. I've recorded screen from my phone what is happening when I change mode to 2.4 GHz using wifi connection and then connecting via OTG cable.
I do everything in this way:
1. power on RC

Ahh you see, now we get to your real problem that you had unfortunately forgotten to mention! You want to switch to 2,4 Ghz in order to get rid of the well known connection problems on 5.8 Ghz band and this is why you use the OTG cable. I probably can provide you the solution, although it is just a little (but not too much) cumbersome.
Try the following sequence of actions:
1. Do not switch on your Spark to start with.
2. Switch on your RC and connect your mobile via WiFi with the RC.
3. Once connection is established switch on your Spark.
4. When all are connected to each other go into "Go Fly" and then the settings menu. There you switch to 2.4 Ghz band.
5. Right afterwards you disconnect the WiFi connection between your mobile and RC and you connect the mobile via OTG to the RC.
Now the 2.4Ghz connection that you have chosen for the RC and Spark connection should remain and not switch back to 5.8 Ghz until the next flight.
I sincerely hope that the above is understandable and I have not mixed up the steps either from my memory.
Good luck and please report.
2017-9-15 12:15:54
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Wachtberger Posted at 2017-9-15 12:15
Ahh you see, now we get to your real problem that you had unfortunately forgotten to mention! You want to switch to 2,4 Ghz in order to get rid of the well known connection problems on 5.8 Ghz band and this is why you use the OTG cable. I probably can provide you the solution, although it is just a little (but not too much) cumbersome.
Try the following sequence of actions:
1. Do not switch on your Spark to start with.

I don't know.. as soon as I read your post I did it and it still doesn't work.
I power on RC and connected to it via wifi on the phone. I waited few seconds for the connection to stabilize. Then I power on Spark, the led on RC is now green. I clicked "Go Fly" and changed mode to 2.4 GHz, the screen was gray, so I plug cable into phone and then to RC. It's the same, I can click now "Go Fly" but it still reconnecting to aircraft. Maybe this OTG cable doesn't work properly..
I did it twice. Once with disabling wifi after change to 2.4 GHz, and second time without disabling it (anyway, I don't have connection with RC via wifi after mode changed).
2017-9-15 12:35:01
Use props
Wachtberger
First Officer
Flight distance : 24610
Germany
Offline

Myszku Posted at 2017-9-15 12:35
I don't know.. as soon as I read your post I did it and it still doesn't work.
I power on RC and connected to it via wifi on the phone. I waited few seconds for the connection to stabilize. Then I power on Spark, the led on RC is now green. I clicked "Go Fly" and changed mode to 2.4 GHz, the screen was gray, so I plug cable into phone and then to RC. It's the same, I can click now "Go Fly" but it still reconnecting to aircraft. Maybe this OTG cable doesn't work properly..
I did it twice. Once with disabling wifi after change to 2.4 GHz, and second time without disabling it (anyway, I don't have connection with RC via wifi after mode changed).

I share your frustration. Are you using a real OTG cable or just a micro USB cable? They are not the same, only look the same! If it is a real OTG cable, it might be disfunctional or not suitable. Try to use another one is the only thing that I could still recommend. I myself am using the original OTG Adapter from DJI in combination with a normal Micro USB cable and it works perfectly. Sorry that I could not help you more.
2017-9-15 12:58:55
Use props
Aki5
lvl.1
United Kingdom
Offline

Hello,

I had the same issue too. I contacted DJI they recommended using DJI GO 4 version 4.1.5 (latest one is 4.1.8) which works better with 2.4Ghz I ask her isn't the new version suppose to correct these errors and better then the old version? she couldn't give me straight answer (not surprised).

Anyway the way I do it is

1. Power up the spark
2. Power up the controller
3. Power up the DJI GO 4 ver. 4.1.5
4. Change WiFi to 2.4 by clicking on the desired channel then ok (No need to click apply unless you change wifi name and pw)
5. Make a cup of tea and wait...

6. Once changed to 2.4ghz the connect the OTG cable - Phone first then controller  (I'm using Samsung s7 edge otg suppiled with the phone)

BEWARNED you must disconnect before changing wifi back to 2.4 or to 5.8 otherwise you'll have to reset you spark (hold power for 9s)

I changed the wifi to 2.4 then to 5.8 then to 2.4 worked great until I changed back to 5.8. then had to power off controller, power off spark, close app (even from the background)

Then repeated steps. It works.

I hope that helps
2017-9-15 13:47:37
Use props
Wachtberger
First Officer
Flight distance : 24610
Germany
Offline

Aki5 Posted at 2017-9-15 13:47
Hello,

I had the same issue too. I contacted DJI they recommended using DJI GO 4 version 4.1.5 (latest one is 4.1.8) which works better with 2.4Ghz I ask her isn't the new version suppose to correct these errors and better then the old version? she couldn't give me straight answer (not surprised).

Thanks a lot for this! So App 4.1.8 has more bugs than known before... Anyway, I am sure it will very soon be replaced after all these RC firmware update problems that must be becoming a nightmare for DJI support staff... (and for us others in this forum )
2017-9-15 14:50:02
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Aki5 Posted at 2017-9-15 13:47
Hello,

I had the same issue too. I contacted DJI they recommended using DJI GO 4 version 4.1.5 (latest one is 4.1.8) which works better with 2.4Ghz I ask her isn't the new version suppose to correct these errors and better then the old version? she couldn't give me straight answer (not surprised).

Thank you!
Now it's working very well!
2017-9-15 22:33:49
Use props
Aki5
lvl.1
United Kingdom
Offline

No problems guys, I'm happy to help.
2017-9-17 12:34:55
Use props
S-e-ven
First Officer
Flight distance : 324856
Thailand
Offline

After all this, how much battery is gone before take off?
Just asking, b/c I have not changed from 5.8 to 2.4 before flight, yet.
2017-9-17 16:35:27
Use props
Akeeal_Spark
lvl.1
United Kingdom
Offline

Good question, shouldn't take more then 10 seconds... I think once you've done your preflight checks your battery already dropped... Well what I do is make sure compass and imu are calibrated when I'm at home. When I'm further away I make sure the home point is set correctly, and double check compass and imu is good if not then recalibrate (don't want a fly away). Then I fly!!
2017-9-24 15:12:40
Use props
Myszku
lvl.1
Flight distance : 8804
Poland
Offline

Aki5 Posted at 2017-9-17 12:34
No problems guys, I'm happy to help.

I've tried your instruction few times and on 4.1.5 i I must say it works better, but not great.
I have used so far OnePlus X smartphone to fly, but still I have an older version OnePlus One. I tested it and on any version of the app I have no connection problem, now I use 4.1.8. Maybe OnePlus X is not compatible or my device has some factory defect. Anyway, thank you again
2017-9-25 01:13:55
Use props
Akeeal_Spark
lvl.1
United Kingdom
Offline

Its not your phone mate. Its the app. There is a modded version of the app you can try at your own risk. I'm trying it now doesn't seem much difference accept CE is now FCC mode meaing more power to the RC and spark. I never lost signal... OMG the SPEED is unbelivable! 50mph! I've only done on a open field where there was no one around. It's scary, not going to use it until I've got more confidence and stick normal mode for now
2017-9-27 06:18:04
Use props
fansb45d515e
lvl.1
Flight distance : 32407
United States
Offline

I saw similar issue today on my Samsung S7. The real time image keep showing a lot lag and very easy see no signal.

Finally I found out the root cause about the issue. This is caused by my S7 battery too low, around 40% to 60% will start to consume too much power from RC. This cause real time video transmit become abnormal.

When I charge my S7 to 85% then try again, everything become normal. Hope this can help.
2017-12-6 19:14:06
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules