Please select Into the mobile phone version | Continue to access the computer ver.
Disconnect
530 11 2017-9-23
Uploading and Loding Picture ...(0/1)
o(^-^)o
Central Maine D
lvl.3
Flight distance : 966808 ft
United States
Offline

I sent my P3P towards my brother's place yesterday.  I've flown to there many times taking pictures and videos.  It's a mile as the crow flies.  Yesterday's sortie I got to ~200 feet from his place and lost video, then aircraft disconnect message.  Had it return to home, on the way it reconnected.  This morning sent it up, flew ~3/4 miles and lost video then disconnected again.  Both flights I was at 400 foot altitude.  I've flown 3 miles out without video problems or disconnects.  I'm unsure why all of a sudden having communications issues.  

2017-9-23
Use props
DJI-Mark
First Officer

United States
Offline

Have you tried any firmware updates? Do you have the Assistant 2 Software on your computer? You can personal message me if you like.
2017-9-23
Use props
Central Maine D
lvl.3
Flight distance : 966808 ft
United States
Offline

All firmware is up to date.  I don't know what Assistant 2 software is, googling it now.
2017-9-23
Use props
MJLSTUDIOS
First Officer
Flight distance : 1540131 ft
  • >>>
United States
Offline

Have you uploaded any apps to the mobile device between the good flights and the bad flights. I had to remove all the apps on my Samsung Tab S2 except for the Go app and the Go 4 app. to fly my P3P and P4P without any disconnections.
2017-9-23
Use props
Central Maine D
lvl.3
Flight distance : 966808 ft
United States
Offline

I have an iPad Mini 2, it is only used for the DJI Go or DJI Ground Station apps.  I make sure that both apps aren't running at the same time.  iPad, controller and aircraft batteries fully charged.  
2017-9-23
Use props
DJI Susan
Administrator

Offline

Which type of mobile device do you use? Please try to adjust the antenna to see whether it helps.

2017-9-24
Use props
RicardoGray
Captain
Flight distance : 4356421 ft
United States
Offline

Central Maine D Posted at 2017-9-23 09:07
I have an iPad Mini 2, it is only used for the DJI Go or DJI Ground Station apps.  I make sure that both apps aren't running at the same time.  iPad, controller and aircraft batteries fully charged.

Forgive me if I missed it, but I don't think you answered the question if you just recently upgraded your firmware or app? Obviously if this is somewhere you have flown many times and didn't do anything like upgrading, there is reason for your concerns. You say it loses signal and initiates the RTH right, and you are 400' altitude? Have you tried going a different direction with the same issue or is it always toward your brother's place? How old your aircraft? I have heard that over time the wires can get stretched inside of the antenna and break, from the constant flipping of them from straight out to 90 degrees. I don't have the stock antenna anymore, but like I said it seems I read that somewhere. Try another place altogether maybe to see if you shortened range follows wherever you try to fly. If you can provide some more info, it might give all of us a little more to work with. Just trying to help.
2017-9-25
Use props
Central Maine D
lvl.3
Flight distance : 966808 ft
United States
Offline

Another cloudless, almost windless morning, sent fully charged P3P up to 400 feet, followed same path taking timed snapshots every 3 seconds like previous flight.  About same distance out, aircraft disconnected and I initiated the return to home.  I have two controllers.  The one I've been experiencing problems with is a GL3008 that has the Itelite ITE-DBS02 rectangular antenna replacement.  After the failure I linked my other controller, a GL300C with aluminum on cardboard 9dbi reflectors added to the stock antenna.  The GL300C flew 13,000 feet round trip with only a brief disconnect at it's furthest distance.  I have already e-mailed Itelite about the problem.    I've flown further with the ITE-DBS02 / GL3008, it's only recently that I'm having these problems.     

2017-9-25
Use props
RicardoGray
Captain
Flight distance : 4356421 ft
United States
Offline

Central Maine D Posted at 2017-9-25 11:47
Another cloudless, almost windless morning, sent fully charged P3P up to 400 feet, followed same path taking timed snapshots every 3 seconds like previous flight.  About same distance out, aircraft disconnected and I initiated the return to home.  I have two controllers.  The one I've been experiencing problems with is a GL3008 that has the Itelite ITE-DBS02 rectangular antenna replacement.  After the failure I linked my other controller, a GL300C with aluminum on cardboard 9dbi reflectors added to the stock antenna.  The GL300C flew 13,000 feet round trip with only a brief disconnect at it's furthest distance.  I have already e-mailed Itelite about the problem.    I've flown further with the ITE-DBS02 / GL3008, it's only recently that I'm having these problems.

I also use the Itelite setup and it has done a very good job for me. That is strange for sure. I would be interested to hear what they have to tell you. I have no idea what is inside of the antenna panel, but sure hope I don't experience the same issue. Sounds like you are on to something though. Keep us informed please and good luck.
2017-9-26
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

Are the RC FW versions the same on both controllers?  I'm not sure if the different controllers use different FW ...

That kind of problem can be hard to track down.  Are your cables all nice and tight?  Could be the ufl cable end has come loose from the transmitter.  Could be a kinked or bad ufl cable.  Could be a bad sma cable to the antenna.  I'd be surprised if it was the antenna.  You might consider checking the cables by swapping the antenna ports on the ITELITE.  If it behaves differently, it would have to be the antenna.  If it behaves the same, it would have to be the cables or transmitter.
2017-9-26
Use props
SjCutting
lvl.4
United States
Offline

When my Phantom 4 started disconnecting and returning to home I did two things. Not sure which fixed it, but it worked and that's all that matters. I have never updated the aircraft, and have no plans too at this point in time. Things I did: Put in a new memory card and formatted it, and started putting the antennas straight out from the unit, not up like I had always done before. I have flown many times since implementing these  two changes with no loss of signal.
2017-9-26
Use props
DJI-Mark
First Officer

United States
Offline

Central Maine D Posted at 2017-9-23 08:21
All firmware is up to date.  I don't know what Assistant 2 software is, googling it now.

I am sorry the Phantom 3 Pro would not be compatible with the Assistant 2 software. Any updates would be through the Go app.
2017-9-26
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules