Please select Into the mobile phone version | Continue to access the computer ver.
Battery Light question
2174 11 2017-12-21
Uploading and Loding Picture ...(0/1)
o(^-^)o
Stan Cook
lvl.2
United States
Offline

While charging my batteries on my Spark I have one battery that won't charge.  When I click the battery check button I get the #1 light steady green and the #2 light blinking green. When placed in the charger it does that for a few seconds and quits.  Same in the spark.  When I try to start the spark it will start but does nothing.  Anyone got any idea of what is going on.?
2017-12-21
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
Australia
Offline

That seems like normal behaviour for the battery, when you press the battery once to check capacity it will show solid lights and flashing lights and then it will go off in a few seconds
Can you turn the battery on while it's in the spark, will the AC start up ?

One reason why you may not be able to charge the battery in the Spark is that the usb port may not have enough power to charge it, I think you need 3 amps at least, but you may already have other batteries charging properly through the usb
Have you checked all the cable connections into the charging transformer ?

What is your charging set up, are you using the DJI Battery charger hub ?
2017-12-21
Use props
MKPSG12
Second Officer
Flight distance : 304032 ft
United Kingdom
Offline

I have been charging my batteries in the hub that comes with the Fly More Combo but last night i tried charging an 80%ish battery in the Spark via the USB cable directly into a socket. It takes WAY longer. Probably took around 30-40mins to get from 80% to 100% where as the hub will do that in around 15 minutes
2017-12-21
Use props
Stan Cook
lvl.2
United States
Offline

lannes Posted at 2017-12-21 23:34
That seems like normal behaviour for the battery, when you press the battery once to check capacity it will show solid lights and flashing lights and then it will go off in a few seconds
Can you turn the battery on while it's in the spark, will the AC start up ?

The batter is locked with that light config.  I charged all the batteries using the hub and the other two charge just fine.  I install the battery in the Spark and push the button twice like normal.  The Spark lights off just like normal except the #1 is steady and #2 blinks and continues that way.  The LEDs on the Spark are blinking like normal.  Even the camera can take a picture.  The Spark however just sits there blinking it's LED and the batter continues to display the lights as above.  I even tried connecting to the Asst online but it does not recognize the Spark in that condition.  
2017-12-22
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
Australia
Offline

When the Spark is on and connected to the app, does the battery page show any voltage differences etc.
2017-12-22
Use props
Stan Cook
lvl.2
United States
Offline

lannes Posted at 2017-12-22 00:18
When the Spark is on and connected to the app, does the battery page show any voltage differences etc.

Good Question.  I have not checked that yet but what would the tell me as to why I get that light set up?
2017-12-22
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
Australia
Offline

Stan Cook Posted at 2017-12-22 00:30
Good Question.  I have not checked that yet but what would the tell me as to why I get that light set up?

It would tell you the reason why the battery is not charging properly, too big a voltage difference between  the cells signifies a battery failure, the spark doesn't fly when the battery has too big a voltage difference
2017-12-22
Use props
DJI Elektra
Administrator
China
Offline

Stan Cook Posted at 2017-12-22 00:07
The batter is locked with that light config.  I charged all the batteries using the hub and the other two charge just fine.  I install the battery in the Spark and push the button twice like normal.  The Spark lights off just like normal except the #1 is steady and #2 blinks and continues that way.  The LEDs on the Spark are blinking like normal.  Even the camera can take a picture.  The Spark however just sits there blinking it's LED and the batter continues to display the lights as above.  I even tried connecting to the Asst online but it does not recognize the Spark in that condition.

Hi, Stan. Please install the malfunction battery on spark. Then please connect your spark with app and see the message in it? You can enter the aircraft battery and see the difference between battery cells. It is abnormal if it over 0.1.  
2017-12-22
Use props
Stan Cook
lvl.2
United States
Offline

DJI Elektra Posted at 2017-12-22 02:25
Hi, Stan. Please install the malfunction battery on spark. Then please connect your spark with app and see the message in it? You can enter the aircraft battery and see the difference between battery cells. It is abnormal if it over 0.1.

Thank you for the info.  I will try that later today when I get home.  I sent an email to DJI support but as usual just a "cookie cutter" answer with no help.  I can't believe the techs there can't tell me what that code means.  Too bad that DJI has great products and maybe the worst customer support that I have ever seen.
2017-12-22
Use props
Stan Cook
lvl.2
United States
Offline

Okay, everyone, the problem has been solved.   I wish I could tell you how.  It's magic.  I installed the battery again to test the battery voltage as DJI Electra suggested.  I pressed the button twice and the Spark started up.  I opened the app and it told me I needed to download and install the update again.  I tried to do that and it just clicked off and opened the view in the Go 4.  I went to the battery page and saw that the battery was looking very normal.  I looked at the back of the battery and it was only showing now one green steady light and the battery level showed 15%.  I turned off the whole system and put the battery back in the charging block and it charged normally.  That's all I can tell you.  I don't know what one thing fixed it and I never did hear from DJI again.  Thanks to everybody for helping.
2017-12-22
Use props
lannes
Captain
Flight distance : 4465 ft
  • >>>
Australia
Offline

Stan Cook Posted at 2017-12-22 16:48
Okay, everyone, the problem has been solved.   I wish I could tell you how.  It's magic.  I installed the battery again to test the battery voltage as DJI Electra suggested.  I pressed the button twice and the Spark started up.  I opened the app and it told me I needed to download and install the update again.  I tried to do that and it just clicked off and opened the view in the Go 4.  I went to the battery page and saw that the battery was looking very normal.  I looked at the back of the battery and it was only showing now one green steady light and the battery level showed 15%.  I turned off the whole system and put the battery back in the charging block and it charged normally.  That's all I can tell you.  I don't know what one thing fixed it and I never did hear from DJI again.  Thanks to everybody for helping.

Great, all the battery needed was a firmware upgrade, which you probably didn't do when you upgraded the AC firmware.

It's not a bad idea to use DJI Assistant 2 on the PC to do firmware upgrades, this application would have identified the battery needed a firmware upgrade
2017-12-22
Use props
DJI Elektra
Administrator
China
Offline

Stan Cook Posted at 2017-12-22 16:48
Okay, everyone, the problem has been solved.   I wish I could tell you how.  It's magic.  I installed the battery again to test the battery voltage as DJI Electra suggested.  I pressed the button twice and the Spark started up.  I opened the app and it told me I needed to download and install the update again.  I tried to do that and it just clicked off and opened the view in the Go 4.  I went to the battery page and saw that the battery was looking very normal.  I looked at the back of the battery and it was only showing now one green steady light and the battery level showed 15%.  I turned off the whole system and put the battery back in the charging block and it charged normally.  That's all I can tell you.  I don't know what one thing fixed it and I never did hear from DJI again.  Thanks to everybody for helping.

Glad it was solved. And have fun with your spark in the new year.
2017-12-25
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules