Please select Into the mobile phone version | Continue to access the computer ver.
IOS 11.2.1 issues?
1022 17 2018-1-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
frankencopter
lvl.3
Flight distance : 176936 ft
United States
Offline

I am a Phantom 3 Pro owner and use the latest DJI GO app for the Phantom series.  Just wondering if anyone besides me is experiencing issues with the app since updating to iOS 11.2.1.   The week of December 22nd, 2017, I was on iOS 11.1.x and GO was working perfectly on about 4 different devices.  I routinely use an iPad Pro 10.5” device but also have a larger iPad Pro, an iPhone 7 and an iPhone 6+.  With the exception of the CPU overload message on the iPhone 6+, all were working well with the latest GO app on iOS 11.1.x.   Shortly after updating to iOS 11.2.1, I decided to take my P3P out for a fly.  I was receiving great telemetry, but I am unable to send commands to the aircraft, change camera settings, do an auto launch or software land, return to home.  the only thing that seemed to work was the camera button.   I tried the other devices and experienced same issue.  I charged up an old iPhone 5 running iOS 10.33, loaded the latest DJI go app on it and it worked perfectly.   I also have to report that Litchi experienced the same issues, no doubt because it uses the latest API.     So, if you have a “spare” apple device to try out, update it to iOS 11.2.1 and see if you have the same issues.  If so, don’t update your main device until a patch!   Buy the way, once you update to iOS 11.2.1, you can’t roll back, even to 11.1.x

On this same note, I am able to launch my aircraft using the remote controller, I do get video and telemetry just fine. But, while I mostly fly by hand, once in a while I want to program a mission or reset the camera settings.  Was not even able to recalibrate the gimbal using the Go app.

2018-1-8
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

Hi. I'm using iOS 11.2.1 on my iPhone 7, and GO 4.1.20 and Litchi 2.0.0 both work fine. Have you tried deleting GO 4 and re-installing? Is the lightening cable looking OK?
2018-1-8
Use props
FatherXmas
Captain
Flight distance : 4058619 ft
  • >>>
United States
Offline

Punchbuggy Posted at 2018-1-8 13:28
Hi. I'm using iOS 11.2.1 on my iPhone 7, and GO 4.1.20 and Litchi 2.0.0 both work fine. Have you tried deleting GO 4 and re-installing? Is the lightening cable looking OK?

Go 4 is a different app, the P3 series uses Go. It's still a good suggestion, though. Uninstall and re-install the Go app to see if that fixes it.

If it weren't so dang cold, I'd grab the rescue squad's P3S and test it for you.
2018-1-8
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

FatherXmas Posted at 2018-1-8 16:46
Go 4 is a different app, the P3 series uses Go. It's still a good suggestion, though. Uninstall and re-install the Go app to see if that fixes it.

If it weren't so dang cold, I'd grab the rescue squad's P3S and test it for you.

Yeah, thanks. I must have been getting a little slap-happy and missed the obvious. :-)

But as you say, suggestions are still valid. I run both GO and Litchi on my iPhone, and there's been a couple of times I've accepted a Litchi upgrade and then GO refused to stay operational. After re-installing GO it comes good. I suspect common code libraries at different levels being installed.
2018-1-8
Use props
DJI Susan
Administrator

Offline

Hello Frank, may I know which version of your DJI GO? Does the issue appear in every flight? Is there any chance to record a short video for better assistance? Thanks so much!
2018-1-9
Use props
frankencopter
lvl.3
Flight distance : 176936 ft
United States
Offline

FatherXmas Posted at 2018-1-8 16:46
Go 4 is a different app, the P3 series uses Go. It's still a good suggestion, though. Uninstall and re-install the Go app to see if that fixes it.

If it weren't so dang cold, I'd grab the rescue squad's P3S and test it for you.

Did the reinstall on 3 different devices.  All failed except the device with ios 10.33  went out and bought a new inexpensive Galaxy tab A 7  and it works fine.  Will use that until a fix.
2018-1-9
Use props
FatherXmas
Captain
Flight distance : 4058619 ft
  • >>>
United States
Offline

frankencopter Posted at 2018-1-9 19:13
Did the reinstall on 3 different devices.  All failed except the device with ios 10.33  went out and bought anew inexpensive Galaxy tab A 7  and it works fine  will use that until a fix.

Glad to hear you got in the air.
2018-1-9
Use props
matti
lvl.2
Flight distance : 92349 ft

Finland
Offline

I get similar new intermittent errors with P3P, P3X_FW_V01.11.0020, DJI GO v3.1.23, iPad Pro 9.7", iOS 11.2.1:

SD card format fails, GUI camera button does not work (RC button works), Sensors and Main Controller settings blank (RTH altitude, max flight altitude). The RC and AC work and fly but the tablet sometimes seems to partially lose connection to them.

With an iPhone 6 (iOS 11.2.1) old iPad mini 1 (iOS 9.3.5) all those are OK.

I have tried to delete/reinstall DJI GO and got a new Transcend Class 10 U1 16 GB SD card but those intermittent errors persist.

I thought I got the iPad Pro 9.7" to work with this workflow (previously I have never had to think about this):

Connect tablet to the RC.
DJI GO app ON, enter Camera view.
RC ON.
AC ON.

But even then when switching to Litchi or back to DJI GO from Litchi, the DJI GO is often "disconnected".

I noticed that I might bypass these intermittent issues with DJI GO and Litchi by disconnecting/reconnecting the Lightning cable.

So is this a problem with iOS 11.2.1 or the current version of DJI GO?

p.s. FWIW, currently there are Apple-acknowledged problems syncing Photos from iTunes to some iPads running iOS 11.2.
2018-1-10
Use props
frankencopter
lvl.3
Flight distance : 176936 ft
United States
Offline

matti Posted at 2018-1-10 09:38
I get similar new intermittent errors with P3P, P3X_FW_V01.11.0020, DJI GO v3.1.23, iPad Pro 9.7", iOS 11.2.1:

SD card format fails, GUI camera button does not work (RC button works), Sensors and Main Controller settings blank (RTH altitude, max flight altitude). The RC and AC work and fly but the tablet sometimes seems to partially lose connection to them.

I am sorry that you are having issues, but I am also so happy you reported it!  I thought it was only me.  I’ve been catching heck on the Phantom Pilots forum because they have been recommending that folks install 11.2.1 to “fix” similar issues.  My problems did not start until I moved to 11.2.1.  Yesterday I did an update to 11.2.2 and still experience the issues.   All my iOS devices that are 11.1 or lower do not have this issue.     The only other think it might be, but I really doubt it, is that about 2 months ago I replaced the ESC controller board.  It’s a newer version of the original that drives the old style 900KV motors (Part 33, not Part 96).   But, all the firmware flashes took just fine and it works fine with lower iOS versions.
2018-1-10
Use props
Punchbuggy
Captain
Flight distance : 395551 ft
Australia
Offline

matti Posted at 2018-1-10 09:38
I get similar new intermittent errors with P3P, P3X_FW_V01.11.0020, DJI GO v3.1.23, iPad Pro 9.7", iOS 11.2.1:

SD card format fails, GUI camera button does not work (RC button works), Sensors and Main Controller settings blank (RTH altitude, max flight altitude). The RC and AC work and fly but the tablet sometimes seems to partially lose connection to them.

When you say that you're switching from GO to Litchi and back, are you running GO and Litchi at the same time?
2018-1-10
Use props
Manny-pr
Second Officer
Flight distance : 10933205 ft
  • >>>
United States
Offline

matti Posted at 2018-1-10 09:38
I get similar new intermittent errors with P3P, P3X_FW_V01.11.0020, DJI GO v3.1.23, iPad Pro 9.7", iOS 11.2.1:

SD card format fails, GUI camera button does not work (RC button works), Sensors and Main Controller settings blank (RTH altitude, max flight altitude). The RC and AC work and fly but the tablet sometimes seems to partially lose connection to them.

You are not alone. This happens to me only with iOS device. I have a new cable and new iPAD. I need to test again with the iOS 11.2.2
2018-1-11
Use props
matti
lvl.2
Flight distance : 92349 ft

Finland
Offline

Punchbuggy Posted at 2018-1-10 17:08
When you say that you're switching from GO to Litchi and back, are you running GO and Litchi at the same time?

As a habit I never use DJI GO and Litchi at the same time. I quit and wipe off (iOS) the other before starting the other. I don't know if this is necessary but I want to play it safe.

I prefer to check everything and set exposure via DJI GO's zebra stripes. Then quit DJI GO and start a Litchi mission. Then maybe switch back to DJI GO to take some free-hand video or images with the remaining battery near homepoint.

Before iOS 11.2 everything worked OK for two years. But now suddenly in the tablet I get random disconnects, blank basic MC and sensor settings, SD card formatting timeouts. Disconnecting/reconnecting the USB cable seems to cure them for a while (tried another cable and SD card). But these errors are new -- last summer everything worked OK. Now I must pay attention in which order I power things on to get things going -- never before was this a problem.

I suspect either some iOS or DJI GO update or maybe a messaging glitch between them has caused this.
2018-1-11
Use props
zhangqing
lvl.4
Flight distance : 5959009 ft
  • >>>
China
Offline

haha   ,I think you're right.........
2018-1-12
Use props
Dockater
First Officer
Flight distance : 139649 ft
Germany
Offline

The current iOS is 11.2.2

I have read somewhere that Apple had a serious problem with 11.2.1 update. I have had no problems since. When you update the last part of the update is a reboot of the OS which amongst other things resets all registers. For the same reasons a reboot may be necessary after you update or delete and reinstall software like the DJI app.
2018-1-12
Use props
frankencopter
lvl.3
Flight distance : 176936 ft
United States
Offline

Dockater Posted at 2018-1-12 07:53
The current iOS is 11.2.2

I have read somewhere that Apple had a serious problem with 11.2.1 update. I have had no problems since. When you update the last part of the update is a reboot of the OS which amongst other things resets all registers. For the same reasons a reboot may be necessary after you update or delete and reinstall software like the DJI app.

I appreciate your reply, really!  I wish it were that easy.  It only seems to affect some users and that is what is the frustrating part.   Seems like for every one person that is affected, there are 10 that are not and because of that, neither Apple or DJI will take notice.   I have tried four different Apple devices and they all exhibit the same thing.   My P3P  has the older Part 33 ESC controller and perhaps that is part of the issue, I don't know.  Doesn't seem to be an aircraft issue however, only a GO issue with the latest ios update.   Interestingly, I have switched to a new low cost Samsung Galaxy Tab A7 device and am using the android versions of the software, both GO and Litchi and aside from some lag (as the Tab A7 is a little light on horsepower), the symptoms have vanished.  This leads me to believe that it is exclusively an ios/GO issue related to the update.  Perhaps there is some security setting in the background that will fix but I'm not wasting my time at this point.  Spent countless hours on the the phone and online chat with both Apple and DJI, switched out cables, reloaded software, rebooted  systems, reflashed  ROM.   Just resigning myself to using an android device I guess.   
2018-1-14
Use props
Dockater
First Officer
Flight distance : 139649 ft
Germany
Offline

frankencopter Posted at 2018-1-14 08:53
I appreciate your reply, really!  I wish it were that easy.  It only seems to affect some users and that is what is the frustrating part.   Seems like for every one person that is affected, there are 10 that are not and because of that, neither Apple or DJI will take notice.   I have tried four different Apple devices and they all exhibit the same thing.   My P3P  has the older Part 33 ESC controller and perhaps that is part of the issue, I don't know.  Doesn't seem to be an aircraft issue however, only a GO issue with the latest ios update.   Interestingly, I have switched to a new low cost Samsung Galaxy Tab A7 device and am using the android versions of the software, both GO and Litchi and aside from some lag (as the Tab A7 is a little light on horsepower), the symptoms have vanished.  This leads me to believe that it is exclusively an ios/GO issue related to the update.  Perhaps there is some security setting in the background that will fix but I'm not wasting my time at this point.  Spent countless hours on the the phone and online chat with both Apple and DJI, switched out cables, reloaded software, rebooted  systems, reflashed  ROM.   Just resigning myself to using an android device I guess.

I am sorry that is so, sometimes the simple things are what is not being done. In your case it seems not. I have no more solutions, except perseverance.
2018-1-14
Use props
frankencopter
lvl.3
Flight distance : 176936 ft
United States
Offline

Dockater Posted at 2018-1-14 15:17
I am sorry that is so, sometimes the simple things are what is not being done. In your case it seems not. I have no more solutions, except perseverance.

I have lots of perseverance LOL!  In the mean time, I've been up and running using a cheap Galaxy Tab A7.  It's working.  It's hilarious the flak I've taken on another group for using a Galaxy Tab.  Everything from "That's a low power piece of junk" to "It doesn't have enough processor power".    Well, it works, that's all I can say heh heh.   I get a little lag but as I'm not an FPV flier, it doesn't matter.  All I want is a stable mission and a safe return of my aircraft!   I was told the new version of Litchi would also not work with the Tab, but I did a mission yesterday just fine.   I do still prefer iOS and my new iPad Pro, but I like flying a whole lot better!
2018-1-15
Use props
matti
lvl.2
Flight distance : 92349 ft

Finland
Offline

matti Posted at 2018-1-10 09:38
I get similar new intermittent errors with P3P, P3X_FW_V01.11.0020, DJI GO v3.1.23, iPad Pro 9.7", iOS 11.2.1:

SD card format fails, GUI camera button does not work (RC button works), Sensors and Main Controller settings blank (RTH altitude, max flight altitude). The RC and AC work and fly but the tablet sometimes seems to partially lose connection to them.

Those intermittent SD card formatting failures, blank Main Controller and Sensors settings, connection problems etc seem to have been cured with iOS 11.2.5 and DJI GO 3.1.27. The old SD card seems to work OK.
2018-2-6
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules