Please select Into the mobile phone version | Continue to access the computer ver.
I cant find Wi-fi when i switch to 2,4 GHZ - DJI SPARK
3156 31 2018-1-28
Uploading and Loding Picture ...(0/1)
o(^-^)o
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

Hello,
I have a problem with connection on DJI SPARK.  When i  try to switch from 5.8 to 2.4GHZ the connection has droped and disconected. My phone Huawei P10 cant find a wi-fi signal. I tryed all buttons and settings but no result. I resset the wi-fi on spark and RC but no...

I also have a tablet Lenovo Yoga Tab 3 and there is no problem to change from 5,2 to 2,4 and its very fast. But i cant bring that 10 inches tablet to fly with.
Please help me !

2018-1-28
Use props
S-e-ven
Captain
Flight distance : 5922034 ft
  • >>>
United States
Offline

Your huawei p10 assumingly is not be able to connect to the RC wifi in 5.8 GHz, as long you are in Europe (CE)
2018-1-28
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

S-e-ven Posted at 2018-1-28 06:39
Your huawei p10 assumingly is not be able to connect to the RC wifi in 5.8 GHz, as long you are in Europe (CE)

Then what phone should i use ?
2018-1-28
Use props
dj_dread
First Officer
Flight distance : 648399 ft
Romania
Offline

some iOS  
   
2018-1-28
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

S-e-ven Posted at 2018-1-28 06:39
Your huawei p10 assumingly is not be able to connect to the RC wifi in 5.8 GHz, as long you are in Europe (CE)

Then why i have no problem with the lenovo yoga tab 3?
2018-1-28
Use props
S-e-ven
Captain
Flight distance : 5922034 ft
  • >>>
Thailand
Offline

Is the lenovo a europe or a world  or a asian model? (wild guess, but maybe thats the reason?)
Still on Lollipop?
It is android, in this 5.8 failure here.
The iOS devices are scanning the 5.8 band in CE area and if they find some: Ok, if there is a wifi, I can use it
The anroids assuming "I am, in CE country, there can't be a wifi in 5.8, so why bother"
2018-1-28
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

S-e-ven Posted at 2018-1-28 08:23
Is the lenovo a europe or a world  or a asian model? (wild guess, but maybe thats the reason?)
Still on Lollipop?
It is android, in this 5.8 failure here.

The tablet is Marshmallow
The Huawei is Nougat

I didnt  have any problems before the last last update.

If you are right for the iOS and Android then why on the tablet runs very fast.
2018-1-28
Use props
Kirby1810
lvl.1
Germany
Offline

I have a simmilar problem. When you look in my Post.
I'm always in 5.8Ghz and when i try to switch to 2.4Ghz the RC doesn't even create a Network for my Phone.
So yeah :/
2018-1-28
Use props
Lis Morris
lvl.2
United Kingdom
Offline

Copy and pasting the reply I made in another thread:
This has happened because the remote control uses two wifi signals: one connects to the drone, and one to the phone. One is always 2.4, while the other is 5.8. If you set it to use 2.4Ghz, it'll try to connect to your phone using 5.8Ghz. Unfortunately, in the EU many phones cannot actually receive that band, so your wifi drops and your phone can no longer connect. As you have discovered, one solution is to use OTG  (DJi does not officially support OTG, blah, blah, blah...), or alternatively, you can reset your Spark and remote control so that they use 2.4 Ghz to connect to your phone again. To do this:

Switch on the Spark. Press the power button down for nine seconds. You will hear a total of six beeps: beep....beepbeep...beepbeepbeep. This will reset the Spark to its factory settings.
Switch on the remote. Press the power button down for nine seconds. Again, you will hear a total of six beeps.

Now switch them both off.
Switch on the remote control.
Switch on the Spark, and press the power button for three seconds until you hear one beep.
Press the function, custom (not the camera button!) and pause buttons all at once to re-pair the Spark and the remote. When the LED on the controller goes green, it has connected.

Your remote controller's wifi should now be reset to its default settings and you should be able to connect. I did exactly the same thing to my Spark when I was messing about with it once

Hope this works for you. It took me a few attempts to get it right.
2018-1-28
Use props
Kirby1810
lvl.1
Germany
Offline

Lis Morris Posted at 2018-1-28 12:38
Copy and pasting the reply I made in another thread:
This has happened because the remote control uses two wifi signals: one connects to the drone, and one to the phone. One is always 2.4, while the other is 5.8. If you set it to use 2.4Ghz, it'll try to connect to your phone using 5.8Ghz. Unfortunately, in the EU many phones cannot actually receive that band, so your wifi drops and your phone can no longer connect. As you have discovered, one solution is to use OTG  (DJi does not officially support OTG, blah, blah, blah...), or alternatively, you can reset your Spark and remote control so that they use 2.4 Ghz to connect to your phone again. To do this:

So, normal: RC to Drone 5.8Ghz and Phone to RC 2.4Ghz
And if i trie to switch it goes: RC to Drone 2.4GHz and Phone to RC 5.8Ghz.
But my phone isn't supported 5.8Ghz because EU and so.
Is that right?

Then, is there a way to solve that issue?
2018-1-28
Use props
eYeSkYeYe
First Officer

Croatia
Offline

Kirby1810 Posted at 2018-1-28 12:48
So, normal: RC to Drone 5.8Ghz and Phone to RC 2.4Ghz
And if i trie to switch it goes: RC to Drone 2.4GHz and Phone to RC 5.8Ghz.
But my phone isn't supported 5.8Ghz because EU and so.

There is no "clean" way to workaround it unless DJI fixes known issue with frequency bands in Europe.
Some people have worked out following solutions:

1. Using OTG as link between Android device and RC (might void the warranty, you need GO App 4.1.15 as newer ones have that broken too.)
2. Root your Android device (might void your device warranty!!!) and gain ability to enable 5.8GHz channels that are basically illegal in Europe for outdoor use.
2018-1-28
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

eYeSkYeYe Posted at 2018-1-28 13:07
There is no "clean" way to workaround it unless DJI fixes known issue with frequency bands in Europe.
Some people have worked out following solutions:

I didnt have any problems before the last last update. Since then i have that problem.
Is it DJI fault ?
2018-1-28
Use props
DJI Elektra
DJI team
Hong Kong
Offline

CrazyNoob Posted at 2018-1-28 23:29
I didnt have any problems before the last last update. Since then i have that problem.
Is it DJI fault ?

Sir, please tell me the version of your app and the current firmware of your drone. Did you try to reinstall the app in your Huawei P10? What is the version of its Android system? Please save all the files and install it again.
2018-2-2
Use props
DJI Elektra
DJI team
Hong Kong
Offline

Kirby1810 Posted at 2018-1-28 12:48
So, normal: RC to Drone 5.8Ghz and Phone to RC 2.4Ghz
And if i trie to switch it goes: RC to Drone 2.4GHz and Phone to RC 5.8Ghz.
But my phone isn't supported 5.8Ghz because EU and so.

Sir, please update the news in your own thread: https://forum.dji.com/thread-131927-1-1.html Thanks for your support.
2018-2-2
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

DJI Elektra Posted at 2018-2-2 02:29
Sir, please update the news in your own thread: https://forum.dji.com/thread-131927-1-1.html. Thanks for your support.

Im sorry but i think there is no help for me. It cant be fixed. RC and Drone are latest firmwares and the Android is 7.0. I tryed everything.. downgrade, upgrade. It only works on 10 inch tablet witch is not acceptable for me. There is a big issue.  And the DJI dont care about it. Thats all. Im very unhappy with that drone.
2018-2-4
Use props
choban
lvl.4
Flight distance : 30784 ft
Germany
Offline

CrazyNoob Posted at 2018-2-4 05:38
Im sorry but i think there is no help for me. It cant be fixed. RC and Drone are latest firmwares and the Android is 7.0. I tryed everything.. downgrade, upgrade. It only works on 10 inch tablet witch is not acceptable for me. There is a big issue.  And the DJI dont care about it. Thats all. Im very unhappy with that drone.

It can be fixed. As others already mentioned, you cannot use 5.8 GHz connection between your phone and the remote in Europe (in most cases). Just revert it back to 5.8 GHz and it will work with your phone.

I would suggest that you connect your tablet to the remote and Spark and then change the frequency back to 5.8 GHz (Spark to RC) and your phone will be able to connect without any issues.
2018-2-4
Use props
dj_dread
First Officer
Flight distance : 648399 ft
Romania
Offline

use your Yoga to connect to the WiFi. then switch it back to 5.8. then you will be able linking your phone to the WiFi
2018-2-4
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

Maybe i dont understand. At the moment i can fly at 5,8ghz with no problem but on 5,8ghz there is small range and i cant make cinematography videos.  I want to fly on 2,4ghz. What you suggest me is to fly on 5.8ghz witch i dont want. I want to fly on 2,4ghz but i can only with my tablet...
2018-2-4
Use props
dj_dread
First Officer
Flight distance : 648399 ft
Romania
Offline

the other option is to change your phone
2018-2-4
Use props
choban
lvl.4
Flight distance : 30784 ft
Germany
Offline

Install 4.1.15 version of DJI Go 4 app and use it with OTG cable. Or wait until they release a new version with OTG support fixed...
2018-2-4
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

dj_dread Posted at 2018-2-4 11:19
the other option is to change your phone

I have brand new Huawei P10.
Any suggestions ?
2018-2-4
Use props
DJI Elektra
DJI team
Hong Kong
Offline

CrazyNoob Posted at 2018-2-4 23:15
I have brand new Huawei P10.
Any suggestions ?

Please shoot a video about this situation. I would help you forward it. Thanks for your support.
2018-2-8
Use props
Arcicorsa
lvl.4
Flight distance : 235892 ft
Czechia
Offline

CrazyNoob Posted at 2018-2-4 23:15
I have brand new Huawei P10.
Any suggestions ?

Your problem is here https://forum.dji.com/thread-120954-1-1.html ... Dji have wrong up CE WiFi integration .. They use the wrong table of channels in the EU .. You can also vote here: https://forum.dji.com/thread-121396-1-1.html
2018-2-8
Use props
Lis Morris
lvl.2
United Kingdom
Offline

CrazyNoob Posted at 2018-2-4 23:15
I have brand new Huawei P10.
Any suggestions ?

Crazynoob, can I suggest that you check out http://sparkpilots.zone/?

There are some inventive but untested ideas for solving the EU range issue there that might interest you. I don't want to mention them here since they are not even remotely condoned by DJI.
2018-2-12
Use props
DJI Elektra
DJI team
Hong Kong
Offline

CrazyNoob Posted at 2018-2-4 10:59
Maybe i dont understand. At the moment i can fly at 5,8ghz with no problem but on 5,8ghz there is small range and i cant make cinematography videos.  I want to fly on 2,4ghz. What you suggest me is to fly on 5.8ghz witch i dont want. I want to fly on 2,4ghz but i can only with my tablet...

Please follow the advice in 16#. As another Android device can search the wifi, there is nothing wrong with your RC. I would recommend you enter the setting and choose the 5.8 G. Thanks for your support.
2018-2-12
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

DJI Elektra Posted at 2018-2-12 02:53
Please follow the advice in 16#. As another Android device can search the wifi, there is nothing wrong with your RC. I would recommend you enter the setting and choose the 5.8 G. Thanks for your support.

Actualy it is wrong !  Huawei P10 is a 2017 phone which cant find Wi-fi signal. The problem is in DJI not in me !
I have that problem since few updates of the app. Before that i didnt have any problem.
2018-2-12
Use props
Locationscout_Bavaria
Second Officer
Flight distance : 62201 ft
Germany
Offline

CrazyNoob Posted at 2018-2-4 23:15
I have brand new Huawei P10.
Any suggestions ?

OTG link RC with Huawei and app version 4.15. Period. I have Huawei P8 lite and with OTG I have zero issues, flying line of sight in medium urban areas.
2018-2-12
Use props
Vyborny83
lvl.4
Flight distance : 166014 ft
Czechia
Offline

CrazyNoob Posted at 2018-2-12 09:12
Actualy it is wrong !  Huawei P10 is a 2017 phone which cant find Wi-fi signal. The problem is in DJI not in me !
I have that problem since few updates of the app. Before that i didnt have any problem.

The problem you are having right now is caused by the fact that since the DJI GO 4 4.1.15 they implemented automatic or manual WiFi channel switching. Until then, the Spark everytime reset when you powered him off and on and chose the default 5,8GHz link between the Spark and the RC. Thus you were able to connect to RC via 2,4GHz with your phone.

Since this update you can manually choose the band and if you chose 2,4GHz between the Spark and the RC, you need a phone capable of 5,8GHz (which your huawei cannot use) to see the RC again. And the spark remembers that choice so even turning him on/off won't help.

You have two options now, either find a device capable of 5,8GHz wifi connection and choose either automatic or 5,8GHz between the Spark and the RC (so you can use the 2,4GHz to connect your Huawei to the RC again), or you have to reset the WiFi on the Spark and RC which will restore the defaults as well.

This is why I still use the DJI GO 4 4.1.14. This version allows me to use the OTG cable when I need it so I can switch the Spark to 2,4GHz and get a range boost and at the same time, everytime I turn the Spark off it resets to default 5,8GHz band so when I power it on, I can connect without the cable again.

This problem is caused by the fact that 5,8GHz band is forbidden in Europe (CE regulations) and only FCC compliant devices (ment for the US) can use it. Just like your Lenovo tablet (also Apple devices see that band). No android phone ment for the EU can use that band (in here the allowed frequencies end up at 5,7GHz if I remember it right).
2018-2-12
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

Thanks a lot guys. You help me a lot. I read somewhere that DJI will allow the using an OTG cable in near future. Also i reseve email from DJI that they work on that problem:

This Problem is a known issue.  Most Android devices could not receive 2.4Ghz after the Exchange of the wifi frequency.  With IOS device it does not have such Problem.
The technicians are Aware of such Problem and they are working hard to solve this issue.  We are very sorry for the Problems and inconveniences caused by our products.



I will try with 4.1.14 version Thanks again.
2018-2-13
Use props
Arcicorsa
lvl.4
Flight distance : 235892 ft
Czechia
Offline

CrazyNoob Posted at 2018-2-13 00:53
Thanks a lot guys. You help me a lot. I read somewhere that DJI will allow the using an OTG cable in near future. Also i reseve email from DJI that they work on that problem:

This Problem is a known issue.  Most Android devices could not receive 2.4Ghz after the Exchange of the wifi frequency.  With IOS device it does not have such Problem.

Nice joke email from Dji
2018-2-13
Use props
CrazyNoob
lvl.2
Flight distance : 107031 ft
Bulgaria
Offline

Arcicorsa Posted at 2018-2-13 02:34
Nice joke email from Dji

Maeby they really working on it. I want to working on it haha
2018-2-13
Use props
Arcicorsa
lvl.4
Flight distance : 235892 ft
Czechia
Offline

CrazyNoob Posted at 2018-2-13 03:24
Maeby they really working on it. I want to working on it haha

I'm sorry, but that's what Dji has been saying since launching Spark ... Now they've done nothing for the users who have this problem, I even shot them and sent them a video and nothing. .. Dji never solve this problem because it is not in their interest (declining Mavic sales, etc.) .. Only way for me is hacked app ..
2018-2-13
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules