Please select Into the mobile phone version | Continue to access the computer ver.
Osmo Not WORKING
1528 16 2018-2-2
Uploading and Loding Picture ...(0/1)
o(^-^)o
Nithin Vijay
lvl.2

India
Offline

When I Try To Switch On My OSMO after unlocking all parts


it just blinks both lights and then the red light comes and it beeps and it turns off

no movement to the camera or gimbal or the fan

what would be the problem ???

someone please help
2018-2-2
Use props
ZarbeL
New

Réunion
Offline

same here!
2018-2-2
Use props
Nithin Vijay
lvl.2

India
Offline


when did it start ?
2018-2-2
Use props
ZarbeL
New

Réunion
Offline


it looks like black screen of the death...
2018-2-2
Use props
Nithin Vijay
lvl.2

India
Offline

ZarbeL Posted at 2018-2-2 06:40
it looks like black screen of the death...

if you get any solution please do post here i will do the same if i get

Mods or Admins Please HELP
2018-2-2
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Hi Nithin, could you please help to verify the right indicator keeps solid red or flashing red? Was the battery out of power?
2018-2-3
Use props
Nithin Vijay
lvl.2

India
Offline

DJI Mindy Posted at 2018-2-3 00:31
Hi Nithin, could you please help to verify the right indicator keeps solid red or flashing red? Was the battery out of power?

When i turns the osmo on the Green light and the Red light are stable

the camera dosent move at all.

i tried it and charged the battery again for few minutes and re checked

osmo switched on perfectly ! but after switching it off and keeping it aside when i tried to switch it on

the same error happened again !

2018-2-6
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Nithin Vijay Posted at 2018-2-6 18:51
When i turns the osmo on the Green light and the Red light are stable

the camera dosent move at all.

If the right indicator is solid red, please try to wipe the copper sheet inside the battery compartment with 95% alcohol and cotton swab. Let the alcohol air dry. If it does not work, wipe the battery contact with alcohol and cotton swab.
If the issue persists, we would appreciate if you could take a short video for further analysis.
2018-2-7
Use props
Nithin Vijay
lvl.2

India
Offline

DJI Mindy Posted at 2018-2-7 01:59
If the right indicator is solid red, please try to wipe the copper sheet inside the battery compartment with 95% alcohol and cotton swab. Let the alcohol air dry. If it does not work, wipe the battery contact with alcohol and cotton swab.
If the issue persists, we would appreciate if you could take a short video for further analysis.

Sure, Thank you

will try this method

i have already taken a video and tried to upload it but wasn't able to upload.

2018-2-7
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Nithin Vijay Posted at 2018-2-7 10:26
Sure, Thank you

will try this method

Please upload it to YouTube and then lost the link to us, thank you.
2018-2-8
Use props
Darrenddmp
lvl.2
Flight distance : 10007 ft
Jamaica
Offline

Re insert the SD card. Worked for me
2018-2-9
Use props
anhtt.vj
lvl.1
Flight distance : 276 ft

Vietnam
Offline

DJI Mindy Posted at 2018-2-8 07:40
Please upload it to YouTube and then lost the link to us, thank you.

i'm so sorry but i can't make new thread.
here is my problem with my osmo: https:/ /youtu.be/y84HUziAroo
please help!
thanks you so much
2-4 08:59
Use props
Rangeet Ballav Uprety
New

Nepal
Offline

My osmo too doesn't work. Motors don't take response. In app it says please unlock the gimble.
3-3 09:43
Use props
rwthomas
lvl.1
Canada
Offline

I have a similar problem, except the red light is not coming on.
3-3 10:31
Use props
rwthomas
lvl.1
Canada
Offline

I have a similar problem, except the red light is not coming on. The main power light is green, and the second green light to the left is also on, and there is a slow beeping. Gimbal is not activated, and it is unlocked. It feels like something needs to be reset, but what?
3-3 10:32
Use props
Rangeet Ballav Uprety
New

Nepal
Offline

rwthomas Posted at 3-3 10:32
I have a similar problem, except the red light is not coming on. The main power light is green, and the second green light to the left is also on, and there is a slow beeping. Gimbal is not activated, and it is unlocked. It feels like something needs to be reset, but what?

Me too having same problem. There is no response of gimble stabilizing motor. Is it because of the firmware update?
3-3 10:56
Use props
rwthomas
lvl.1
Canada
Offline

rwthomas Posted at 3-3 10:32
I have a similar problem, except the red light is not coming on. The main power light is green, and the second green light to the left is also on, and there is a slow beeping. Gimbal is not activated, and it is unlocked. It feels like something needs to be reset, but what?

Further to this problem, I am getting two alternating messages on my screen, while the beeping continues.

1] Click here to reactivate Gimbal,

and when I click that, I get

2] Gimbal is locked, manually unlock by hand.

The Gimbal is most definitely not locked.
3-3 11:33
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules