Please select Into the mobile phone version | Continue to access the computer ver.
Olimpus 1.8 25mm lens not auto focusing
277 7 2018-2-24
Uploading and Loding Picture ...(0/1)
o(^-^)o
Andy Gibson
lvl.2
Flight distance : 6174564 ft
Australia
Offline

Im having the an issue with Inspire 2 using my 25mm lens, it will not autofocus, and comes up with an error Lens not connected??
2018-2-24
Use props
fansb1f12597
lvl.3
Flight distance : 423973 ft
United States
Offline

It's the latest firmware causing the issue. I rolled back to the previous version and the lense works.
2018-2-24
Use props
Andy Gibson
lvl.2
Flight distance : 6174564 ft
Australia
Offline

fansb1f12597 Posted at 2018-2-24 07:18
It's the latest firmware causing the issue. I rolled back to the previous version and the lense works.

Thanks for your reply, I'm not going to rollback the firmware, will need to hold off until DJI fix the issue. Im shooting a polo event this week and it would have been great to use my 25mm... too bad!
2018-2-24
Use props
allanart
First Officer
Flight distance : 471254 ft
United Kingdom
Offline

I very much doubt its anything to do with firmware, its more likely to be (a) the lens is not properly locked in place or (b) one or more of the spring loaded connector pins is stuck (down) and not making proper contact. Remove the lens, check the connector pins and replace. Very low temperature is also a factor and can cause the spring loaded pins to stick..
Hope this helps.
Allan
2018-2-25
Use props
fansb1f12597
lvl.3
Flight distance : 423973 ft
United States
Offline

I'm not really worried about what other people think it is. I've got an Inspire 2,Inspire 1 pro, Phantom 4 pro, and a Mavic. I've spent 33 years diagnosing technical issues in my career in systems that have life or death in the balance. I'm showing how I got this lense to work after it was working then stopped after the latest firmware update in the Inspire 2. It never stopped working on the Inspire 1 Pro. I stated how I tested and got it to work on two aircraft. Guessing from there is guessing. I'll leave the comments to you and get back to flying. But if anyone wants their 25mm to work, roll back the firmware. Try it.
2018-2-25
Use props
Image Factory
lvl.2
Flight distance : 6174564 ft
Australia
Offline

allanart Posted at 2018-2-25 01:49
I very much doubt its anything to do with firmware, its more likely to be (a) the lens is not properly locked in place or (b) one or more of the spring loaded connector pins is stuck (down) and not making proper contact. Remove the lens, check the connector pins and replace. Very low temperature is also a factor and can cause the spring loaded pins to stick..
Hope this helps.
Allan

Thanks for your reply Allan, have tried these suggestions still no luck??
2018-2-25
Use props
DJI Elektra
Administrator
China
Offline

Image Factory Posted at 2018-2-25 18:36
Thanks for your reply Allan, have tried these suggestions still no luck??

Hi, there. Did you have other lens for test? Please keep us updated, if the problem remains.
2018-2-25
Use props
allanart
First Officer
Flight distance : 471254 ft
United Kingdom
Offline

Image Factory Posted at 2018-2-25 18:36
Thanks for your reply Allan, have tried these suggestions still no luck??

Sorry to hear that. But for what its worth, I am using the same lens (and three others) with the latest firmware (01.01.0300) without any problem.

Regards
Allan
2018-2-26
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules