Please select Into the mobile phone version | Continue to access the computer ver.
Downward sensor error
2993 14 2018-4-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
MFPullen
Second Officer
Flight distance : 4735121 ft
  • >>>
United States
Offline

I have experienced this downward sensor error on my 4 month old Mavic Platinum.  I have checked my sensors for gunk in them.  Nothing there but I cleaned them off any way. I have upgraded the firmware, rebooted the Mavic, recalibrated compass and IMU  I tried to recalibrate the sensors via DJI Assistant but that doesn't function at all.  Any help or advice would be appreciated.
2018-4-9
Use props
DJI Diana
Administrator
Flight distance : 2408 ft

Offline

Hi there, I'm sorry to hear about the issue that you are experiencing. May I know that did your drone crash before or not? At the same time, could you please show us a screenshot of the error message on DJI GO4 app, we'll look into it. Thanks!
2018-4-9
Use props
MFPullen
Second Officer
Flight distance : 4735121 ft
  • >>>
United States
Offline

DJI Diana Posted at 2018-4-9 17:54
Hi there, I'm sorry to hear about the issue that you are experiencing. May I know that did your drone crash before or not? At the same time, could you please show us a screenshot of the error message on DJI GO4 app, we'll look into it. Thanks!

No crash, message just appeared in mid flight.  

Good news though, after researching several forums i found the issue.  I had to uninstall DJI Assistant, restart my Win10 laptop choosing the option of accepting unsigned device drivers.  I then reinstalled DJI Assistant accepting the Win10 warnings for three DJI unsigned device drivers.  After this I launched DJI Assistant and was able to recalibrate the forward and downward sensors successfully..
2018-4-9
Use props
DJI Diana
Administrator
Flight distance : 2408 ft

Offline

MFPullen Posted at 2018-4-9 18:00
No crash, message just appeared in mid flight.  

Good news though, after researching several forums i found the issue.  I had to uninstall DJI Assistant, restart my Win10 laptop choosing the option of accepting unsigned device drivers.  I then reinstalled DJI Assistant accepting the Win10 warnings for three DJI unsigned device drivers.  After this I launched DJI Assistant and was able to recalibrate the forward and downward sensors successfully..

That's really a good news, I'm glad to know that you have solved the issue and everything turns out to be great. Please fly outside and check the performance, if there is any further issue, please feel free to let us know, we'll here for help.
2018-4-9
Use props
Guina
lvl.1
Flight distance : 31302 ft
Brazil
Offline

DJI Diana Posted at 2018-4-9 22:20
That's really a good news, I'm glad to know that you have solved the issue and everything turns out to be great. Please fly outside and check the performance, if there is any further issue, please feel free to let us know, we'll here for help.

Hi Diana.
I have the same situation with my Mavic Pro 4 months old. I tryed reinstall all drivers and recalibrate, but it did not fix the issue.
I sent the drone to assistance in Brazil, but it returned with the same problem.
They said they replaced the sensors, but the issue persists.
Could you help me to the next steps?
Thanks
2018-4-16
Use props
Guina
lvl.1
Flight distance : 31302 ft
Brazil
Offline

Here is the image of error:

2018-4-16
Use props
Jenee 2
Captain
Flight distance : 7852129 ft
Offline

Guina Posted at 2018-4-16 18:12
Here is the image of error:

[view_image]

I will be interested to see if you get any help with this one. A few of us with Phantom 4 Pros have exactly the same error message and it seems to occur on every flight resulting in the rear lights going solid red and the landings are heavier than normal. The error never shows up in the log files.Can you tell me what firmware version the Mavic has and what version of the GO 4 app you are using.
2018-4-16
Use props
Guina
lvl.1
Flight distance : 31302 ft
Brazil
Offline

Jenee 2 Posted at 2018-4-16 20:28
I will be interested to see if you get any help with this one. A few of us with Phantom 4 Pros have exactly the same error message and it seems to occur on every flight resulting in the rear lights going solid red and the landings are heavier than normal. The error never shows up in the log files.Can you tell me what firmware version the Mavic has and what version of the GO 4 app you are using.

Hi Jenee,
I´m using a GO 4 version (v4.2.12) and aircraft firmware version V01.04.0300.
I sent the equipment to local authorized service and they said they changed the sensors, but the error persists.
2018-4-17
Use props
Jenee 2
Captain
Flight distance : 7852129 ft
Offline

Guina Posted at 2018-4-17 05:16
Hi Jenee,
I´m using a GO 4 version (v4.2.12) and aircraft firmware version V01.04.0300.
I sent the equipment to local authorized service and they said they changed the sensors, but the error persists.

Thanks for that. I just wanted to check if you were on the latest GO 4 app and firmware and you are. I am not sure what the issue is but I think there may have been some change in the code or additional code in either the latest firmware versions or the Go 4 app that is now detecting an error somewhere. If I am able to find out anything, I will let you know.
2018-4-17
Use props
Guina
lvl.1
Flight distance : 31302 ft
Brazil
Offline

Jenee 2 Posted at 2018-4-17 19:59
Thanks for that. I just wanted to check if you were on the latest GO 4 app and firmware and you are. I am not sure what the issue is but I think there may have been some change in the code or additional code in either the latest firmware versions or the Go 4 app that is now detecting an error somewhere. If I am able to find out anything, I will let you know.

Okay! Thank you!
2018-4-18
Use props
djiuser_oqSZgXcHZZto
lvl.1

United States
Offline

I have a Phantom 4 and I started getting the exact same error. Not very old and never been crashed.  I have done all of the calibrations.  It seemed to happen after a firmware update.
2019-6-10
Use props
LeafPeeper
Second Officer
Flight distance : 356496 ft
United States
Offline

I have this problem as well.   I went to fly my 'backup' MP1 yesterday for the first time in about a year.   It was fine the last time I flew it, but now I'm getting 'Downward Sensor Errors' mid flight - both yesterday and today.   It sends the back end indicator light solid red.   I tried rebooting everything between flights but it didn't make a difference.   It happened on two flights yesterday, and two tonight.   There were some shorter, lower altitude hovering only flights in between just to see what would happen and I didn't get errors.   They seem to only happen when I go above the downward sensor active height.

Since I haven't flown this particular Mavic in a very long time, I decided to restore it to factory defaults, refresh the firmware (same version it had), removed the app from my phone, deleted all the DJI directories and reset it up from scratch. I also recalibrated all the sensors, IMU and gimbal. I didn't bother with the compass since it showed very little interference prior to takeoff. Same error. Two flights..

I uploaded the log from one of the flights with the error to PhantomHelp - and sure enough, at 174 ft, suddenly the VPS indicator goes from NA to .7ft and the error is thrown and it goes back to NA.   Then the VPS starts reading again as I get within the VPS effective distance.   Could my Polarpro landing gear extensions be causing some light reflection issues?
LP
2019-6-10
Use props
djiuser_QZolncaGOsC0
lvl.1

Australia
Offline

DJI Diana Posted at 2018-4-9 17:54
Hi there, I'm sorry to hear about the issue that you are experiencing. May I know that did your drone crash before or not? At the same time, could you please show us a screenshot of the error message on DJI GO4 app, we'll look into it. Thanks!

My drone landed by itself after I selected return to home - every time I have used it previously it has had no issue. Despite the home point being updated the drone did not return. It stayed in the same place until the battery eventually died and it landed itself in water. I have dji after care (still valid) and DJI is refusing to honour it. Can someone please help..
2019-6-10
Use props
wrschmidt
New
Flight distance : 373212 ft
United States
Offline

Jenee 2 Posted at 2018-4-16 20:28
I will be interested to see if you get any help with this one. A few of us with Phantom 4 Pros have exactly the same error message and it seems to occur on every flight resulting in the rear lights going solid red and the landings are heavier than normal. The error never shows up in the log files.Can you tell me what firmware version the Mavic has and what version of the GO 4 app you are using.

I have a Phantom 4 and I’m experiencing the error and problems. Were you able to find a solution?
5-10 09:16
Use props
fanscbdd9b4a
New

United Kingdom
Offline

I have downward sensor issues with a Mavic Pro 2 after 6 months (DJI have already charged me £300 for the dreaded gimbal motor load issue - can't believe they charge you while drone is under warranty and never crashed). Anyway, does anyone know how to fix the downward sensor issue? I had fixed it by downgrading to the last firmware but the drone has since auto upgraded and won't let me downgrade now. Cant believe DJI release firmware which prevent me using my drone then they want to charge you money to fix the issue......criminals.
15 hours ago
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules