Please select Into the mobile phone version | Continue to access the computer ver.
Thought I Fried My Inspire During Latest Firmware Update (v1.2.1.03)
1460 1 2015-5-11
Uploading and Loding Picture ...(0/1)
o(^-^)o
TimG
lvl.2

United States
Offline

So this is a tale of how I screwed up installing the latest firmware v1.2.1.03 on May 10th, 2015. Or maybe I should say how it failed and I thought I had broke the airframe. I want to put this out there in case anyone else ever goes though the same couple of hours of suffering I just went through let them know how to bring their Inspire back to life. It's long but it's hopefully a through walk-thru of the steps that will bring them back from RC hell.

This is the second firmware update I've done since I bought the Inspire back in mid April. The first time worked just fine. The one I did yesterday locked up the Inspire for a couple of hours. Here's what happened.

I downloaded the firmware update v1.2.1.03 from the DJI website.
I unwrappeed the .bin file from the downloaded .zip file and placed it on a microSD card in the root level of the card.
I updated both controllers as per the firmware update instructions.
I then placed the microSD card into the camera mounted to the airframe.
Turned on the airframe and it went through it's update paces sounding away with a 'De-De-De-De'.
After about 30 minutes, maybe 40, the sound shifted to a 'Deeee-De,De'. Sounded like it had successfully completed the update so I tried to turn the battery off but the battery refused to shut off. I must have tried to push that battery button two dozen times but it would not shut off.
I decided to sit it out, thinking that maybe the update wasn't over so I waited for another 30 minutes.
Finally, with the battery refusing to shut off, I just pulled the battery out of the airframe. Pulling the battery, the beeping stopped and the lights went out.
I re-inserted the battery and the airframe came to life immeadiately, without pressing the battery button. It began beeping in a very strange way. All four motors and the camera beeped in unison. It was loud! As loud as the intial beeps of a normal startup but incessently every 2 seconds or so. I could also hear a weird hissing, like air escaping very softly out of the barometer. I thought 'Damn, I've fried the thing. I shouldn't have pulled the battery.' I waited about five minutes and the sounds continued but the beeps from each motor progressively got more out of sync.
I tried to shut off the battery again but it still would not accept the button shutdown sequence.
I just pulled the battery again silencing the airframe abruptly.
Pushing the battery button on the bad battery out of the airmframe, had no effect. No lights came on so I thought; 'Crap, I've burnt out this battery too!'.
I put another battery on the airframe (one that lit up when the button was pushed) and turned it on.
The wierd beeping continued with it's very loud beeping.
I waited another five minutes and tried to shut it off. The new battery shut off normally.

I dug into the DJI website looking for support. I found the 24/7 Chat support page and input my info. Strangely, the site accepts your info and then lists phone numbers and email addresses that run during normal business hours. 'So much for 24/7 support.' I thought. I was about to give up because it was a Saturday when I noticed a box at the bottom of the page that looked like a 'conversation box' you'd expect to see on a chat page. I typed. 'hello?' and to my surprise about two minutes later I got a response. Through a conversation with someone that spoke rudementary English I puzzled out that they were saying  I should just keep the Inspire powered on for 20 minutes no matter what crazy sounds it was making.

So I powered up the Inspire and let it sit beeping away at full volume. Since I'm in a hotel and I didn't want security to be called I placed towels over the motors to try and muffle the beeping. It kind of work. As promised, after about 20 minutes, the increasingly out of sync beeping motors all chirped in unison and started beeping the successful update beep of "Deeee-De-De". I shut down the airframe by pushing the button on the battery and it shut off just fine.
I turned the airframe back on and it started up as normal. Thank GOD!
I cycled through my other batteries updating them. It even brought the intiial battery back online and working fine.
The only thing I can think of that I did wrong during the update was that I kept one of the controllers powered on during the update of the airframe's firmware. I suspect that this may have caused the problem.

I'm happy to say that I flew the Inspire yesterday after doing an IMU calibration and a compass calibration and it fly beautifully. The mods were all good.

Hope this helps someone out there.

2015-5-11
Use props
fansb2093788
lvl.1
Flight distance : 60892 ft
  • >>>
United States
Offline

Thank you for posting this. Same thing happened to me. The key for me was formatting the SD card on PC (not Mac like I was doing) and followed your steps closely. The firmware upgrade FINALLY worked for me!
2017-7-12
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules