Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 2 Camera Sensor Error
1929 14 2018-5-12
Uploading and Loding Picture ...(0/1)
o(^-^)o
Mr Ludo
lvl.2
Flight distance : 448875 ft
Offline


I've just finished a film shoot with the drone and move to a different location to find that I'm not getting any video signal back to the remote from the Zenmuse X7.


An Error comes up saying Camera Sensor Error. Any help as soon as possible would be VERY welcome.


There is aso another Error that comes up saying: Aircraft Encode Error ((0x400000).


I've tried to update the firmware via Assistant to the lastest but it doesn't seem to be working. I've plugged the I2 into my laptop and connected it to Assistant 2. I've clicked the update firmware button to V01.02.0100. It goes through all the process of downloading the files and uploading it to the drone. BUT every time I plug the drone back into Assistant 2, it keeps asking from me to update the firmware to V01.02.0100.


I've also tried to get the upgrade log for you through: DJI Assistant 2(MAC): ~/Library/Application Support/DJI Assistant 2/upgrade_log This folder or files do not exist on my computer.


I'm heading across the globe on Wednesday of a film shoot on Climate Change with my drone and I'm exceedingly nervous and unconfident that I can't get this drone to work.


I'm getting increasly fustrated as I seem to be spending far more time trying to fix firmware issue with my Inspire 2 with the Zenmuse X7 that I'm getting to fly it.


Any help as soon as possible will me most welcome. thank you.


Ludo



2018-5-12
Use props
RobAlbania
Second Officer
Albania
Offline

Only thing I can think of (apart from hardware fault on your drone) is to check the little switch near the SD card is in the "down position" for PC mode when using DJI Assistant.
Also try a new USB lead in case the lead has intermittent contact (I have had several) and try a different USB port on your laptop, NOT a USB3 blue port.

If the above suggestions do not work, then flip the switch on your drone to the upper (remote controller) position, install the latest version of the Go4 App on your mobile device, connect it to the transmitter, power everything on and try performing the firmware update that way.

Thanks,
Rob
2018-5-12
Use props
Mr Ludo
lvl.2
Flight distance : 448875 ft
Offline

Hi Rob, many thanks for your reply and help.

Sadly I've tried the list of things you suggested.

Does anyone know how to roll back the firmware on the I2? - hopefully this might help
2018-5-12
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

Mr Ludo, sorry for the troubles, the latest firmware cannot be rolled back and we have made it clear in the release notes.
Does the APP show the firmware is the latest version? If you change another battery, the DJI Assistant 2 may request to update again when it detects the firmware is inconsistent.
Please try to enter/exit the travel mode again and make sure the gimbal has been mounted properly, you can also try a different Micro SD card.
2018-5-14
Use props
AngelI2
lvl.2
Flight distance : 276 ft
Netherlands
Offline

DJI Mindy Posted at 2018-5-14 23:10
Mr Ludo, sorry for the troubles, the latest firmware cannot be rolled back and we have made it clear in the release notes.
Does the APP show the firmware is the latest version? If you change another battery, the DJI Assistant 2 may request to update again when it detects the firmware is inconsistent.
Please try to enter/exit the travel mode again and make sure the gimbal has been mounted properly, you can also try a different Micro SD card.

Hi Mindy,
Can be the SD card the cause of the problem on the X5S getting sensor error and not imagen on the iPad ?
2018-9-6
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

AngelI2 Posted at 2018-9-6 09:35
Hi Mindy,
Can be the SD card the cause of the problem on the X5S getting sensor error and not imagen on the iPad ?

Angell, sensor error is usually related to the hardware, you can try to refresh the firmware or remove the SD card to see if the error persists, otherwise, the drone will need to be sent in for further evaluation.
2018-9-8
Use props
fans861a8515
lvl.3
Flight distance : 926549 ft
  • >>>
Israel
Offline

I just  had the EXACTLY the same experience as Mr. Ludo described with my X7 on a shoot in front of the client...

Did you find how to fix the problem?thank you.
2018-9-26
Use props
Mr Ludo
lvl.2
Flight distance : 448875 ft
United Kingdom
Offline

Hi fans861a8515,

Unfortunately, the only solution I had was to send the drone back to DJI to get it fixed. All the best and good luck. L
2018-9-26
Use props
fans861a8515
lvl.3
Flight distance : 926549 ft
  • >>>
Israel
Offline

Mr Ludo Posted at 2018-9-26 09:04
Hi fans861a8515,

Unfortunately, the only solution I had was to send the drone back to DJI to get it fixed. All the best and good luck. L

Thanks,
And do you know what they fixed? Anything to be learned from this?
2018-9-26
Use props
Mr Ludo
lvl.2
Flight distance : 448875 ft
United Kingdom
Offline

Hi fans861a8515, sorry to be of no help, but they gave me no reason.
2018-10-1
Use props
Dansker
lvl.2
Flight distance : 1930873 ft
  • >>>
United States
Offline

Same exact issue here. Infuriatingly frustrating because your large investment doesn't work like it should and it seems to ALWAYS act up when on a job with a client. After downgrading and upgrading several times and troubleshooting the issue, I'm just going to send in the bird for repair. Seems to be with the bird itself and not the cameras (although the error says camera sensor error). I have the x5s and x7 and with both cameras I get the same error on the bird.
2018-10-7
Use props
fans1e7d1508
Second Officer
Flight distance : 28799 ft
Spain
Offline

It is possible that the connection cables that go from the inspire 2 to the camera support are badly connected or broken.
2018-10-21
Use props
JPOliveira
lvl.1
Flight distance : 1876132 ft
Belgium
Offline

DJI Mindy Posted at 9-8 00:23
Angell, sensor error is usually related to the hardware, you can try to refresh the firmware or remove the SD card to see if the error persists, otherwise, the drone will need to be sent in for further evaluation.

Hi DJI Mindy,
I'm experiencing the same "camera sensor error" which happened right after the latest firmware update (16/nov/2018).
After re-trying several upgrades and not succeeding to downgrade it, I contacted DJI's problem report to ask for help.
What else could be done to solve this issue without having to send the aircraft to repair?
Screenshot_20181116-214914.jpg
2018-11-16
Use props
DJI Mindy
Administrator
Flight distance : 7 ft
Offline

JPOliveira Posted at 11-16 14:38
Hi DJI Mindy,
I'm experiencing the same "camera sensor error" which happened right after the latest firmware update (16/nov/2018).
After re-trying several upgrades and not succeeding to downgrade it, I contacted DJI's problem report to ask for help.

Hi JPOliveira, sorry for the troubles after the firmware upgrade, please follow the steps below and try again.
1. Power off the drone, remove the gimbal, control the aircraft enter Travel Mode.
2. Power on, exit Travel Mode, attach the gimbal to see if the error persists.
2018-11-18
Use props
snail.fpv
lvl.2
Flight distance : 537329 ft
Slovakia
Offline

Hi I am getting the Encoder Error as well but it acts strange.
I was on the latest FW and flown on last wednesday many packs and had zero issues - footage is perfect. I have flown another job today - first set of batteries no issue, in the half of the second set the problem occured. I kept loosing HD image transmission. When I was powering up my inspire 2 there appears this error (see picture) but it quickly goes away.  (see video)

When I looked at my footage I was in a shock. the footage on the SD card looks kinda ok but the CNDG files are corrupted and sequences are missing files resulting in a complete corrupted mess of media, which I can not use for the job - this will need a reshoot but don't want to encouter same problems again.



I have tried rebooting, entering and exitting travel mode, downgrading to .200 didn't help. Still getting the Encoder error x40000... blimp after IMU initialization



PLEASE HELP
5-7 12:15
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules