Please select Into the mobile phone version | Continue to access the computer ver.
P4P Always Says No!!! -Gimbal problem
329 11 2018-5-26
Uploading and Loding Picture ...(0/1)
o(^-^)o
OliveFr
lvl.1
France
Offline

Hi, I have a strange issue with my P4P Gimbal. It always wants to say no???? Do you know how can I fix it? I think the problem comes from the Gimbal accelerator circuit board but impossible to get one spare part.


Olive

2018-5-26
Use props
Hellsgate
Captain
Flight distance : 1991555 ft
Australia
Offline

Many pilots have had this issue. Including myself.
Have you crashed the drone or hard landed it?
There are a few things you can try.
Firstly make sure you have installed the latest firmware, try it again if it still plays up then you may want to try rolling back the firmware to an earlier version.
If those 2 option dont work then try doing a factory reset on the drone then reinstall the latest firmware.
If it still performs the same then you may need to send it in to dji for repairs.
Ive had the same issue twice and both times i had to send in for repairs.
Hopefully the firmware fixes the problem for you.
2018-5-26
Use props
Hellsgate
Captain
Flight distance : 1991555 ft
Australia
Offline

If it is a hardware issue you wont find spare parts for it unless you can get hold of a second hand drone and strip it for parts, just remember tho if its still under warranty then i wouldnt be going pulling it apart
2018-5-26
Use props
ALABAMA
Captain
Flight distance : 9367841 ft
United States
Offline

Looks like that one needs to go to repair.
2018-5-26
Use props
eman_vg
Second Officer
Flight distance : 1015440 ft
United States
Offline

Is this a problem with hardware or do you think it is glitching out? If you crashed it recently, its probably an external issue. If you don't know what happened, it probably has to do with firmware. Try redownloading the newest firmware or if that doesn't work backtrack on firmware. (BTW DJI will probably fix that thing for cheap to nothing if it is fairly new, I'd just contact them)
2018-5-26
Use props
OliveFr
lvl.1
France
Offline

Hellsgate Posted at 2018-5-26 04:47
Many pilots have had this issue. Including myself.
Have you crashed the drone or hard landed it?
There are a few things you can try.

Thanks, I crashed it in a tree :-(. I tried to make a firmware update without any modifications. I will try the factory reset then firmware update. Keep you informed

thx
2018-5-26
Use props
Hellsgate
Captain
Flight distance : 1991555 ft
Australia
Offline

I think crashing in a tree might be the cause of your problems
2018-5-26
Use props
OliveFr
lvl.1
France
Offline

Hellsgate Posted at 2018-5-26 15:49
I think crashing in a tree might be the cause of your problems

Yes, that's the reason I think the problem comes from the gimbal circuit board. When it crashed, it broke the yaw arm and the flex cable. I replaced them without success.
2018-5-26
Use props
Hellsgate
Captain
Flight distance : 1991555 ft
Australia
Offline

I think your best option will be to send it in for repair
2018-5-26
Use props
rwynant V1
Captain
Flight distance : 2005722 ft
Offline

Not to be insensitive,   but next time maybe you could LEAD with,  " I crashed into a tree"

Then we have a place to start.......Sorry about your troubles!

Randy
2018-5-27
Use props
OliveFr
lvl.1
France
Offline

rwynant V1 Posted at 2018-5-27 16:36
Not to be insensitive,   but next time maybe you could LEAD with,  " I crashed into a tree"

Then we have a place to start.......Sorry about your troubles!

Randy, thanks for your comment. The problem is not the crash since the damage parts have been replaced. Anyway, I ordered a complete new gimbal.
2018-5-27
Use props
DJI Susan
Administrator

Offline

Olive, sorry to read the issue. If it not recommended to disassemble at your end which may void the warranty. Please kindly start a case and send the unit in for diagnosis: https://www.dji.com/support
2018-5-27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules