Please select Into the mobile phone version | Continue to access the computer ver.
Ronin2 power hub not working
895 3 2018-6-25
Uploading and Loding Picture ...(0/1)
o(^-^)o
BDKFilms
lvl.1

United States
Offline

So I purchased a New Ronin2 Pro Kit  and recieved it in the mail about a week ago. I tested it at my house with a GH5 and Tilta Nucleus M Follow focus, powered from the Power Hub through the DJI supplied Lemo to Ptap Spliter. Everything worked great and I was able to pull focus using the Tilta gimbal hand grips.  Well yesterday I used the Ronin2 on set for the first time with an Alexa Mini, Terradek wireless video and Bartech Follow Focus but now I could not get any power out of the Power Hub to Ptap splitter and the RSS Cable to camera will not work at all. If I plug into the single power port on the oppisite side I have power just not from the power hub.  




Choosing the camera icon on the menu it just tells me to connect a power hub and try again yet the power hub is already installed.  Is there a menu setting that turns the power hub on and off or any known issues with it going out.  I really need it to work for more power for my accesories and RSS capability. Thanks for any responses.


2018-6-25
Use props
FlySteadyCam
lvl.1

Turkey
Offline

I am interested
5-12 03:34
Use props
JFeller15
lvl.1
Flight distance : 88241 ft
United States
Offline

Hey did you ever figure out how to fix this? I am having the same problem at the moment.
9-9 15:39
Use props
BDKFilms
lvl.1

United States
Offline

Yes. It’s happened twice to me. If you have a wire that shorts out plugged into your power hub. It will shut off  the hub.  If you keep trying it will fry the hub.  I believe one time my nucleus m motor power cable got caught in the tilt hinge and pulled the wire out of the Lemo which shorted it out and eventually fried my hub. I had it repaired twice under warranty.
9-11 00:27
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules