Please select Into the mobile phone version | Continue to access the computer ver.
UPDATE: SOLVED--> Camera Vibration -is this the "jello problem"?
958 35 2018-7-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

Here's an update to this original post.  I solved the problem.  I had my camera settings at 4K/24 fps.  I think the slow frame rate was the cause.  When I moved it up to 60 fps, the problem disappeared.

My Mavic Pro has suddenly started showing lots of vibration on my videos.  I tried changing the props, resetting the camera, the IMU and the compass.  No success.  I monkeyed with the settings for the control sticks too.  Nothing seems to help.  I know I've seen others talk about this problem in the past, but I don't remember what things were recommended.  Any advice?  I didn't do anything in post since I'm only trying to show the jitter.  Thanks in advance.
https://www.flickr.com/x/t/00940 ... 67@N06/43239941372/
2018-7-8
Use props
TX99517
Second Officer
Flight distance : 249045 ft
United States
Offline

Maybe I missed it, but I didn't see vibration.  I noticed the lack of smooth panning though, is that what you are talking about?
2018-7-8
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

TX99517 Posted at 2018-7-8 18:50
Maybe I missed it, but I didn't see vibration.  I noticed the lack of smooth panning though, is that what you are talking about?

Yes.  Perhaps I mislabeled the problem.  But I've been flying a long time and I've never had that kind of "wobble" or "shake" when doing a yaw.  I also get it just flying forward.  I always plant on finger hard alongside the bottom of the stick and then gently move that stick with my other hand.  So, I don't think it's me.  Like I said, I've been flying a long time and this effect is brand new.  Thanks for the quick response.
2018-7-8
Use props
HedgeTrimmer
Captain
United States
Offline

Have you update Smartdevice's OS you are running GO-4 on?  Added any new Apps to Smartdevice?  Have you updated GO-4 or Mavic Pro's Firmware?
2018-7-8
Use props
marklyn59
First Officer
Flight distance : 395072 ft
United States
Offline

Mine does that on a close up shot (like yours) when yawing.  When I'm high in the air and panning, I don't notice it then.  Same for you?
2018-7-8
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

Change your props.  When is the last time they have been changed?  Seriously you might be surprised by a bad one or two props that can cause this.  
2018-7-8
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

Oops sorry I missed in your OP that you already changed your props.  Although maybe change to another set if you have?  There is the prop test you can do to ensure that is not the issue at all because believe it or not even with a new set can introduct a bad prop.  
2018-7-8
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

Check this video to get an idea.  Basically shows if you are getting vibrations that could be causing this even with no props.  And can check one by one to find if you have any bad.  And to show the point in my post above this guy swapped one bad prop and the one he swapped was bad as well.  Check it out  
2018-7-8
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

And if the above does not work at all try refreshing the firmware on not only your AC but also your RC.  And my last suggestion if that does not work and you are say on the latest .400 firmware try rolling back to .300 to see if that clears it up.
2018-7-8
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

HedgeTrimmer Posted at 2018-7-8 19:23
Have you update Smartdevice's OS you are running GO-4 on?  Added any new Apps to Smartdevice?  Have you updated GO-4 or Mavic Pro's Firmware?

Thanks.  Yes, I've done all of the above before doing the video I posted.
2018-7-8
Use props
HedgeTrimmer
Captain
United States
Offline

SparksBird Posted at 2018-7-8 19:37
Check this video to get an idea.  Basically shows if you are getting vibrations that could be causing this even with no props.  And can check one by one to find if you have any bad.  And to show the point in my post above this guy swapped one bad prop and the one he swapped was bad as well.  Check it out  

I would have thought removing all but one prop would have caused a Pre-Flight start up error.
Have to give this a try on my Mavic Pro, being I recently replaced all four Props.  

Thanks for Prop Tip!  
2018-7-8
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

SparksBird Posted at 2018-7-8 19:33
Change your props.  When is the last time they have been changed?  Seriously you might be surprised by a bad one or two props that can cause this.

Did that before posting.  Always a good idea, but it didn't help.  Thanks for the suggestion.
2018-7-8
Use props
HedgeTrimmer
Captain
United States
Offline

StanfordWebbie Posted at 2018-7-8 20:32
Thanks.  Yes, I've done all of the above before doing the video I posted.

Which leads me to wonder if one of updates resulted in your ''Jello problem''.
Smartdevice's OS update may not be as efficient or smooth at playing live videos.
GO-4 App update may have a problem live view problem itself, or a problem working with your Smartdevice's OS.
Or updating Mavic Pro's firmware may have introduced live view streaming problem.

With multiple updates (multiple changes at once) it will be difficult to narrow down if one or more caused your ''Jello problem'' or eliminate the updates as possible causes - to get to actual cause.
2018-7-8
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

HedgeTrimmer Posted at 2018-7-8 20:53
Which leads me to wonder if one of updates resulted in your ''Jello problem''.
Smartdevice's OS update may not be as efficient or smooth at playing live videos.
GO-4 App update may have a problem live view problem itself, or a problem working with your Smartdevice's OS.

Good points.  But from experience, I always wait 2 to 3 weeks before implementing any updates to iPhone or drone.  I then watch the forum here to see if others are reporting any problems.  If not, then I make the update.  
2018-7-8
Use props
Alexei Merinov
Captain
Flight distance : 2244961 ft
Russia
Offline

Hello! I received a similar problem after replacing the control loop with a gimbal suspension. There was a slight crash, after which the gimbal suspension refused.
I changed the control loop with a gimbal  again, it only helped partially. And I completely solved the problem by completely replacing the gimbal with the camera. These kits are on Ali and cost about 200 dollars.
Replace is not very difficult - it took me about half an hour. There are quite a few instructions on the net

2018-7-8
Use props
HedgeTrimmer
Captain
United States
Offline

StanfordWebbie Posted at 2018-7-8 20:59
Good points.  But from experience, I always wait 2 to 3 weeks before implementing any updates to iPhone or drone.  I then watch the forum here to see if others are reporting any problems.  If not, then I make the update.

As we have read here about MA and MP, the problems with Installer, FW, GO-4 code, and/or Smartdevice OS does not impact every drone / drone-owner.   Maybe this time, you are one of unlucky ones?   
Or ''Jello problem'' is due to entirely different cause?
2018-7-9
Use props
HedgeTrimmer
Captain
United States
Offline

SparksBird Posted at 2018-7-8 19:37
Check this video to get an idea.  Basically shows if you are getting vibrations that could be causing this even with no props.  And can check one by one to find if you have any bad.  And to show the point in my post above this guy swapped one bad prop and the one he swapped was bad as well.  Check it out  https://www.youtube.com/watch?v=52N9Lfa0USI

Wonder if IMU's Pitch, Roll, Yaw and Surge, Heave, Sway motion sensors could be used in place of cup of liquid?  
DJI being able to add an optional Prop check under IMU calibration setup.
2018-7-9
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

HedgeTrimmer Posted at 2018-7-9 05:14
Wonder if IMU's Pitch, Roll, Yaw and Surge, Heave, Sway motion sensors could be used in place of cup of liquid?  
DJI being able to add an optional Prop check under IMU calibration setup.

I agree that would be great.  And could see the vibration in the app from the sensors.  No reason why this should not already be built in as it is.  Would mitigate the risk of somehow spilling that coffee
2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

marklyn59 Posted at 2018-7-8 19:25
Mine does that on a close up shot (like yours) when yawing.  When I'm high in the air and panning, I don't notice it then.  Same for you?

I went back and looked at some recent videos, and it shows up there too.  I guess it's been going on for awhile - certainly before the latest firmware update.
2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

SparksBird Posted at 2018-7-8 19:53
And if the above does not work at all try refreshing the firmware on not only your AC but also your RC.  And my last suggestion if that does not work and you are say on the latest .400 firmware try rolling back to .300 to see if that clears it up.

Thanks Spark.  I'll try both the coffee and the roll back later today.
2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

Alexei Merinov Posted at 2018-7-8 21:19
Hello! I received a similar problem after replacing the control loop with a gimbal suspension. There was a slight crash, after which the gimbal suspension refused.
I changed the control loop with a gimbal  again, it only helped partially. And I completely solved the problem by completely replacing the gimbal with the camera. These kits are on Ali and cost about 200 dollars.
Replace is not very difficult - it took me about half an hour. There are quite a few instructions on the net

Thanks Alexei.  I'm not too far form the LA repair office for DJI, so if I can't solve it with the suggestions I get here, I'll just send it down to them.  Better to have someone else do it who does it every day.
2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

See my note at the top.  Problem was solved by changing frame rate from 24 fps to 60 fps.
2018-7-9
Use props
HedgeTrimmer
Captain
United States
Offline

SparksBird Posted at 2018-7-9 06:39
I agree that would be great.  And could see the vibration in the app from the sensors.  No reason why this should not already be built in as it is.  Would mitigate the risk of somehow spilling that coffee

I plan to try the liquid test, but I plan to use a sealed cup.
Maybe steal a kid's sippy cup...  
2018-7-9
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

StanfordWebbie Posted at 2018-7-9 10:17
See my note at the top.  Problem was solved by changing frame rate from 24 fps to 60 fps.

Do you mean 30fps for 4k?  Or to 60fps in 1080p?  Was not aware could go 60fps in 4k.  
2018-7-9
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

HedgeTrimmer Posted at 2018-7-9 13:07
I plan to try the liquid test, but I plan to use a sealed cup.
Maybe steal a kid's sippy cup...

Yeah or seal the top with something but I would not leave an open cup on top of my MP that is for sure lol.  Great idea with the kids sippy cup.  
2018-7-9
Use props
TZero
Second Officer
Flight distance : 404767 ft
Brazil
Offline

SparksBird Posted at 2018-7-8 19:37
Check this video to get an idea.  Basically shows if you are getting vibrations that could be causing this even with no props.  And can check one by one to find if you have any bad.  And to show the point in my post above this guy swapped one bad prop and the one he swapped was bad as well.  Check it out  https://www.youtube.com/watch?v=52N9Lfa0USI



Great Test and solution !!!

I will to test with "Old Jack" (before drink it)

2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

SparksBird Posted at 2018-7-9 13:07
Do you mean 30fps for 4k?  Or to 60fps in 1080p?  Was not aware could go 60fps in 4k.

Very observant.  I changed to 1080 to get 60fps.  I haven't attempted to get a better resolution along with a higher fps, but I will next time I go out.  I was just excited to get back in the house and confirm that the problem was gone.
2018-7-9
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

StanfordWebbie Posted at 2018-7-9 14:57
Very observant.  I changed to 1080 to get 60fps.  I haven't attempted to get a better resolution along with a higher fps, but I will next time I go out.  I was just excited to get back in the house and confirm that the problem was gone.

Try 4K@30fps and see if you no longer have the issue as well.  I will do some testing using 4K@24fps and see if mine is choppy as well.  
2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

SparksBird Posted at 2018-7-9 16:00
Try 4K@30fps and see if you no longer have the issue as well.  I will do some testing using 4K@24fps and see if mine is choppy as well.

OK.  Let's exchange stories once we both test things out.  Thanks,
2018-7-9
Use props
HereForTheBeer
Captain
Flight distance : 5014068 ft
  • >>>
United States
Offline

my theory is the heaviest side of the gimbal is sagging or stretched just enough that its out of balance and causing small burst of gimbal vibration thus jello this i think comes from the metal lobe under the anti-drop hook either slipping past the anti drop hook or it getting past end of its understood range....using little piece of velcro (like 1CM by 1CM) over the lobe on the left side (heaviest side) where bands connect to the metal lobe under the anti-drop hooks allows the heavier side of the gimbal to not slip out of range or bash around on the anti-drop hook.   my testing is very premature, but thus far, no jello using it this botch....
2018-7-9
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
United States
Offline

HereForTheBeer Posted at 2018-7-9 20:49
my theory is the heaviest side of the gimbal is sagging or stretched just enough that its out of balance and causing small burst of gimbal vibration thus jello this i think comes from the metal lobe under the anti-drop hook either slipping past the anti drop hook or it getting past end of its understood range....using little piece of velcro (like 1CM by 1CM) over the lobe on the left side (heaviest side) where bands connect to the metal lobe under the anti-drop hooks allows the heavier side of the gimbal to not slip out of range or bash around on the anti-drop hook.   my testing is very premature, but thus far, no jello using it this botch....

Thanks for the response, but I think you missed my latest post letting people know that the problem was that I had my video set for 24 fps.  When I went to 60 fps, the problem went away.  That forced my resolution to be 1080, so I'll be going back out to try 4K at 30 fps.
2018-7-10
Use props
StanfordWebbie
Captain
Flight distance : 178018 ft
Offline

SparksBird Posted at 2018-7-9 16:00
Try 4K@30fps and see if you no longer have the issue as well.  I will do some testing using 4K@24fps and see if mine is choppy as well.

So I tried 4K at 30fps and it too works well.  So, at least for my Mavic Pro, I just need to stay away from 24 fps.
2018-7-10
Use props
HereForTheBeer
Captain
Flight distance : 5014068 ft
  • >>>
United States
Offline

StanfordWebbie Posted at 2018-7-10 12:18
Thanks for the response, but I think you missed my latest post letting people know that the problem was that I had my video set for 24 fps.  When I went to 60 fps, the problem went away.  That forced my ISO to be 1080, so I'll be going back out to try 4K at 30 fps.

that does not work for me, i still get jelloing with any frame rate and resolution fairly equally, and i like my ISO to be at most 800 pre fable the lowest i can go for the cleanest image...

my solution still testing out is a physical mod and so far its working, but really have to trim it down or gimbal itself can catch and freak out.
2018-7-10
Use props
QuadKid
Captain
Flight distance : 482349 ft
Offline

HereForTheBeer Posted at 2018-7-10 13:37
that does not work for me, i still get jelloing with any frame rate and resolution fairly equally, and i like my ISO to be at most 800 pre fable the lowest i can go for the cleanest image...

my solution still testing out is a physical mod and so far its working, but really have to trim it down or gimbal itself can catch and freak out.

My MP had jello issues right from the start with gimbal neutral weight. Had to add Polar pro filter to add weight to the gimbal, this helped but did not totally remove the jello, cut some thin strips of Gorilla Duct tape (measured for correct length and wrapped it around my ND's (added a little more weight) this cured the jello, if I take the filter off jello returns. This after many discussions seems to be a gimbal balance issue. Thinking a certain lot of MP's were released with this issue. For me the type of filter is irrelevant it is the weight that makes the difference. Been flying the MP for over a year now with no jello issues.



2018-7-10
Use props
HereForTheBeer
Captain
Flight distance : 5014068 ft
  • >>>
United States
Offline

QuadKid Posted at 2018-7-10 14:23
My MP had jello issues right from the start with gimbal neutral weight. Had to add Polar pro filter to add weight to the gimbal, this helped but did not totally remove the jello, cut some thin strips of Gorilla Duct tape (measured for correct length and wrapped it around my ND's (added a little more weight) this cured the jello, if I take the filter off jello returns. This after many discussions seems to be a gimbal balance issue. Thinking a certain lot of MP's were released with this issue. For me the type of filter is irrelevant it is the weight that makes the difference. Been flying the MP for over a year now with no jello issues.

https://www.youtube.com/watch?v=RjD7qNZK_TI

ill try this! my method is not ideal, because i just hit a nasty gust of wind and it caused my gimbal to move outside of normal range and my camera was pointed up and stuck... a mile out so that was interesting
2018-7-10
Use props
SparksBird
Captain
Flight distance : 10693363 ft
United States
Offline

I do not think the OP issue was a so called jello issue that others have due to gimbal shake, etc.  The OP issue was just choppy video all along due to fps.  If you watched the video you will see that is not a case of jello.  However I will say good solutions here regardless just stating the fact that this issue was not due to shake.  Thanks to this thread I have learned how to test for vibrations due to bad props, and also thanks to QK video how balancing out the weight with a filter can help if you do have a gimbal imbalance issue.  So good learning experience here
2018-7-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules