Please select Into the mobile phone version | Continue to access the computer ver.
Messed up firmware.
7062 16 2015-5-23
Uploading and Loding Picture ...(0/1)
o(^-^)o
whernst
lvl.1

United States
Offline

I was trying to perform the firmware update to 1.1.9 but phantom was making different power sounds during the upgrade.  The upgrade didn't seem to be going as the last two firmware upgrades and after 25 minutes or so I did power the unit off.   Now the phantom just beeps on power up.. Guess I screwed it up.  I know there is the possibility of a hard reset.. Can anyone help me out.  

William
2015-5-23
Use props
FantomDK
Second Officer

Denmark
Offline

Stupid question (?) did you follow the instructions to the letter?

Did you make sure the Remote Control was not turned on when you attempted to update the firmware? I didn't follow that clear instruction myself last time I updated - but after shutting everything down and doing it right, it updated fine.

I think/hope they made it so smart that you can't brick it. Good luck, hope you fix it
2015-5-23
Use props
Fingerlaker
lvl.2

United States
Offline

I'm having the same issue.  Following all the direction (as usual). Restarted the process twice now, but when I power up the phantom has constant loud beeping, BEEP-BEEP-BEEP-BEEP... and I can also hear soft beep-beep- beep-beep in the background
2015-5-24
Use props
hundleton1
Captain
Flight distance : 2466486 ft
  • >>>
United Kingdom
Offline

Try the following as we have worked through this all ready on a different site with a few people that could not update and had success.

Please don't skip as step



1: Turn off the P3 and remove the battery for 20 minutes. makes sure its charged over 50% at this point.



2: Format the SD card again. Use the one it was supplied with



3:.Download the correct file again from DJI website,



4:.Place the correct .bin file from the new downloaded file on the SD card,



5:Turn on your controller.



6: Connect tablet and open the DJI Pilot app to camera.



7: Insert battery and turn on P3 with out SD card in and see if it connects to controller



8: if it connects then shut the P3 off, if it don't connect leave a few minutes then turn P3 off, don't worry if it does not connect to the app.



9: Close the DJI App but leave the controller turned on,



10: Insert SD card into P3 and turn on and allow software update.



11: Check update text file after its changed to finished tones.

12: Then please post the hidden log file located under the MISC\LOG\ folder on the SD card, you will need to enable I view hidden files and folders on your computer to see it


IF this don't work perform again but this time at step 9 turn the controller off.



If this don't work then it likely got to go back to DJI
2015-5-24
Use props
rhutty
lvl.3

United Kingdom
Offline

Just done the same. Different sound so turned it off. When I tried again loud Beep Beep ect.. Tried reset button...nothing. Powered down left it in garage powered  up ...loud beep beep ....went inside turned controller on and mini iPad message check 8 pin connector or return unit for service. Camera pointing straight down with no response. After 30 minutes screen showed camera pointing normally ( still in garage) beeping stopped all normal. All seems ok, so just put it somewhere the loud beeping won't annoy you and wait. Worked for me;-)
RayH
2015-5-24
Use props
HunterBrooks
Second Officer

United States
Offline

Yes, this upgrade process seems much more intense than the last ones.  It will take longer, and lights flash, loud beep beep's happen a few times as if you just turned it on, soft d-d-d-d, etc.  Just let it sit.  I almost stopped the process also, but decided to just wait and see.  Maybe 20 minutes later, sure enough, I finally got the repeated soft d-dd d-dd sound.  I checked the txt file, and all was fine.

So, just let it run it's process and it should work.
2015-5-24
Use props
sofagbem
lvl.2

United States
Offline

The problems with the firmware update suggest to me that DJI needs to look into its approach to firmware/function updates.

I will suggest decoupling firmware update for the hardware from function updates, so that if a function needs to be improved upon, you can update that alone as opposed to risking bricking your aircraft.

In addition having multiple substantial updates in a short period of time makes me concerned about adequate testing before release.
2015-5-24
Use props
Tahoe_Ed
Administrator
Flight distance : 2605 ft
  • >>>
United States
Offline

This upgrade is almost 3x the size of the prior upgrades.  It takes a long time and goes through a lot of different states during the upgrade.  LEDs on, LEDs off, motors restart, very different than in the past.  Just wait it out.  
2015-5-24
Use props
Gustave
lvl.2
Flight distance : 138 ft
Netherlands
Offline

I had the same issue and was helped out by DJI 24/7 support.

- Format the SD card
- copy the fw *.bin file to the card
- insert card in P3
- turn on P3
- wait for it (about 10 min. in my case). It beeps continiously
- the beeping stops. FW upgrade succeeded.

Good luck

2015-5-24
Use props
whernst
lvl.1

United States
Offline

Gustave Posted at 2015-5-24 23:49
I had the same issue and was helped out by DJI 24/7 support.

- Format the SD card
Thanks for all the replies to my post.  I followed Gustave's steps and firmware updated.  Great feeling hearing the beeping stop and the camera pointing straight ahead.   I will say , I had performed the other two updates without issues and this one acted differently.  Like someone said,  put it in the garage and just let it do it's thing.

2015-5-24
Use props
dion
lvl.1

United States
Offline

Same happened to me.
This update seems different somehow. I interrupted the updated and thought I bricked my P3 when afterword I only got loud beeping and alternating red-green light on camera when powering on the P3.

I Followed above advice and just left it in the garage. Sure enough about 20mins. latter all seems good.

I guess the moral of the story is 'be patient' and don't let your update trick you into a premature abort.  

Thanks Everyone.
2015-5-25
Use props
kevinr621
lvl.2
Flight distance : 36427 ft
United States
Offline

dion Posted at 2015-5-26 03:14
Same happened to me.
This update seems different somehow. I interrupted the updated and thought I b ...

I started the update process however I am getting no beeping or flashing lights on the gimble...? 2 solid red lights on front and flashing yellow on rear... is it updating? been in the process for about 10 minutes now...
2015-6-25
Use props
docweiser
lvl.1

United States
Offline

kevinr621 Posted at 2015-6-26 06:15
I started the update process however I am getting no beeping or flashing lights on the gimble...?  ...

Yep clean SD and the bin file did it! When I 1st turned on P3 had red solid led's & flashing yellow - after a few minutes solid red and flashing green - it was done when it went back to flashing yellow.  I also had connection probs & had to enable usb reporting on Samsung Galaxy 4tab by first going to settings, about then find build # and tap 7 times, this unhides developer options where usb setting was found.

Going for 1st flight in a few with version 1.28
2015-6-30
Use props
docweiser
lvl.1

United States
Offline

docweiser Posted at 2015-7-1 06:27
Yep clean SD and the bin file did it! When I 1st turned on P3 had red solid led's & flashing yello ...

Well went for 1st flight and found out I needed to calibrate IMU so did that yesterday evening.  Today I started with auto take off & landing - perfect.  Then took her up to 150 ft & landed no issues other than it is very hard to see even though I made my own sunscreen.

Todays next flight - cruise around the area!
2015-7-1
Use props
tyson.verse
New

Offline

I could use a suggestion - can't get firmware updated after many tries of reformatted sd card and fresh .bin file.  (P3 Professional)

I currently get no noises when startinting up P3 with sd card with firmware (after a couple toots anyway) - no gimbal sounds at all. Just get red/green gimbal blinks, and sometimes steady green blinks (gimbal).

When connected to rc and P3, I get NO SIGNAL red banner from P3, but get satellite count, rc strength, hd indicator, battery status. No camera feed. Forward LED's on P3 red, rear are blinking yellow rapidly. Home point seemed to record. Location is accurate.

I did seem to get firmware update for rc through the app originally, but nothing for P3. Cannot format sd from App - it does not appear.

Thx for anything...
2016-4-23
Use props
djiuser_clXLdMtNtHeL
lvl.1

United States
Offline

When I try to update o.o get fast green light flashing in about 4 series of green lights then red and green lights about 51 and then green flashing fast about 4 different a and just keeps doing that time after time with no noises during sownload please help it's kicking my but
2018-6-6
Use props
djiuser_bMfDZAtf3aG9
lvl.1

Australia
Offline

tyson.verse@gma Posted at 2016-4-23 17:37
I could use a suggestion - can't get firmware updated after many tries of reformatted sd card and fresh .bin file.  (P3 Professional)

I currently get no noises when startinting up P3 with sd card with firmware (after a couple toots anyway) - no gimbal sounds at all. Just get red/green gimbal blinks, and sometimes steady green blinks (gimbal).

I have the same problem now, just wandering if you ever fixed yours?
2018-9-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules