Please select Into the mobile phone version | Continue to access the computer ver.
No WiFi Signal from Spark Controller
1388 7 2018-8-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
Rmalerich
lvl.1
United States
Offline

Just got the spark yesterday, watched a couple videos and followed the instructions to update the firmware on the Spark and the Controller. After updating the controller it no longer shows an SSID, tried to view on a laptop & phone (Google Pixel XL).

*Phone connects to Spark no problem, everything works great

*Controller connects to spark no problem, I can fly around within line of sight ect no problem

*Controller does not give off a wifi signal so I can not connect my phone to it to rollback the firmware or view the camera while I am using the controller to fly the spark.

I have seen other threads on here and on reddit, there seem to be no fixes. I have reset, reconnected, turned off/on in every possible configuration.

At one point the RC wifi came on and both my computer and phone saw the ssid, when trying to connect with it my phone would say "connecting" and then the wifi signal would dwindle out and then the connection would fail. Phone would keep retrying to connect but was never able to connect.

Loaded the DJI Go 4 app on my wife's phone, a samsung galaxy 8, same thing.

Let me know if there is any way to connect to the Controller via the micro USB port and rollback the firmware, or some other fix for this. I was trying to avoid sending the controller back before I ever got to use it.
2018-8-19
Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft

Offline

Our apologies for the inconvenience.  Kindly put your phone to airplane mode and try to connect to the wifi again. We can only update the firmware of the remote controller using DJI Go 4 app and it is not possible to connect it to DJI Assistant 2 to restore or update the firmware. May I know if you tried to use an OTG cable to connect the samsung galaxy 8 to the remote controller? May I know the current firmware version and DJI Go 4 app that you are using?
2018-8-20
Use props
S.J
Captain
Flight distance : 322454 ft
Kuwait
Offline

Also it seems your mobile doesn't work on dual band WiFi frequency. It only works on 2.4GHz .  Initially during take off SPARK uses 5.8GHz frequency and during long flights it switches to 2.4GHz .You need to change your Wifi mode to FCC from CE .  All your problems will go away.
2018-8-21
Use props
jacksonnai
Captain
Offline

Welcome to the forum mate
2018-8-22
Use props
fishneck
lvl.3

Offline

you are not alone with this issue. see the below links. may not be the same issue but kinda similar.(killed the wifi that projects publicly.)
Mine successfully updated and ending up like that and there is no solution still, i think.

https://forum.dji.com/forum.php? ... p;page=6#pid1513647
https://forum.dji.com/forum.php? ... p;page=1#pid1513847
2018-8-24
Use props
KyleHeg
lvl.1

Offline

hi im having the same problem how do you change your wifi to FCC from CE?
9-29 06:31
Use props
S-e-ven
Captain
Flight distance : 3740030 ft
Offline

KyleHeg Posted at 9-29 06:31
hi im having the same problem how do you change your wifi to FCC from CE?

You better open a own topic and describe your problem and your setup.
Because if your device is an droid and you are in CE limitations, your device is the one that isn't allowing you, to connect/use 5.8Ghz wifi.
So in case you are on droid, I suggest you use a otg cable, anyway.
This way, your RC and your Spark can deal with the band switching as they have to.
And after you can look up some topics about how to use other apps, to make the bird believe it is in FCC country.
9-29 07:42
Use props
Frunobulax
lvl.4
Flight distance : 12936 ft
Offline

KyleHeg Posted at 9-29 06:31
hi im having the same problem how do you change your wifi to FCC from CE?

It does it automatically from what region you are in
10-2 10:01
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules