Please select Into the mobile phone version | Continue to access the computer ver.
After 3 months Osmo2 is broken.
679 19 2018-9-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
Dave_bass5
lvl.4
United Kingdom
Offline

I got ther O2 in June, and its be working fine since then. Turned it on yesterday and my iphone(s) had all lost BT connection to the O2. In fact the O2 just wasnt sending out a BT signal. Nothing would see it. After a couple of hours it did appear in the Go app, but i still couldn’t connect to it. It did work after a while but its goes and comes back.
Worse, the stabilisation isnt working now. Everything is balanced well, and if i do an auto calibration it all goes well. The phone will centre if i push the button twice to centre it, but moving around shows that the phone is just moving freely, tilting and not staying level. The odd thing is it seems be better in mode 2.

I’m not sure what else i can do now. Anyone know if there is a hard reset? I have done all the fault finding, and anything that can be suggested as far as BT goes ive done it.

Please, don’t post any tips on how to set the O2 up, ive been using it day in day out for a few months, I’m well are of the basics and how it works. It wont help at all.

This was a gift and I’m not sure where it came from, probably the Apple store in London where i live but I don’t have a receipt. I feel like ill either need to buy a new one, or give up on it as it seems like there is no real after sales support.

Yes, i can upload a video of it, as i know thats a a standard reply here. Ill sort that out asap.
2018-9-9
Use props
DJI Tony
Super Moderator

Offline

Hi, Sorry for the inconvenience. May I know what happened to your Osmo prior this issue? Did you ensure that there are no devices that used a bluetooth connection aside from your mobile device and Osmo Mobile 2? I would recommend avoiding any devices that require bluetooth connection such as a smartwatch, other devices, speakers and etc. to isolate the issue.
2018-9-9
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

I didnt do anything out of the ordinary before hand. I had done a hyper lapse around our flat and packed the Osmo2 away.
Tried turning all BT devices off in the house. I also turned each phone back on to try it, one at a time, and none picked the Osmo2 up. Never had any issuers at all using my Apple Watch connected to my phone, but turned them off anyway.
The BT i can get working, but the stabilisation not. Its always been treated well, and as i said if doing an auto set up the Osmo2 is fine doing that, so it seems like the motors are working ok as well.
2018-9-9
Use props
DJI Tony
Super Moderator

Offline

Dave_bass5 Posted at 2018-9-9 22:38
I didnt do anything out of the ordinary before hand. I had done a hyper lapse around our flat and packed the Osmo2 away.
Tried turning all BT devices off in the house. I also turned each phone back on to try it, one at a time, and none picked the Osmo2 up. Never had any issuers at all using my Apple Watch connected to my phone, but turned them off anyway.
The BT i can get working, but the stabilisation not. Its always been treated well, and as i said if doing an auto set up the Osmo2 is fine doing that, so it seems like the motors are working ok as well.

Hi, Appreciate your response. Would it be possible if you can send a short video of this issue? You can use google drive or dropbox then provide the link here for further help. Thank you for the support.
2018-9-11
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Here you go. Starts off with phone and O2 off so you can see its balanced properly.

https://www.dropbox.com/s/yles3jt9utsbprz/IMG_0002.MOV?dl=0
2018-9-11
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

So any advice? How do i go about getting this fixed?
2018-9-18
Use props
djiuser_m6JQJka2DXqv
New

Pakistan
Offline

Hello team
I bought OSMO 2 recently but one of the buttons just fell off.
I wanted to know if it's normal/usual for a button to just fell down.
Also, can you please help me on how to get this fixed?

Waiting anxiously for your reply.

Regards,
2018-9-26
Use props
pjollain
Second Officer
Flight distance : 92110 ft
Luxembourg
Offline

Dave_bass5 Posted at 2018-9-18 09:43
So any advice? How do i go about getting this fixed?

Sorry to learn about the issue you are experiencing, I hope a solution will be provided by DJI.
I saw on your video that you are using a support to hold your Osmo Mobile vertical, where did you get it from?
2018-9-27
Use props
WebParrot
Captain
Flight distance : 8871 ft
  • >>>
United States
Offline

Dave.... while you're waiting for a solution from DJI I have an additional step for you to try.  This may not help directly (as I've never had the problem you describe), but I've found that with a number of DJI products (aircraft included) they don't behave well if there are any old pieces of "legacy" code in memory :-)  For any major update I delete the Go/Go4 App and do a clean install.  And BEFORE the fresh install I make sure the iPhone has memory cleared as well.  

To do this takes two steps.  First double tap the home button and 'flick' all of the active apps from memory.  Then do a second routine that (I believe) completely clears memory.  Hold down the on/off button until the "off" shutdown slider displays.... don't slide!... instead hold down the Home button until the Home Screen appears.  Now download the Go App.

Of note.... deleting any App, then doing this two step procedure will delete anything in memory/storage associated with the App itself including any settings.  So when you re-install the App you will have to re-enter your settings.



2018-9-27
Use props
iiaXeii
Second Officer
Flight distance : 31047 ft
Canada
Offline

the motor or mechanism on mine started to make noise once but then stopped and can't replicate... very weird
2018-9-27
Use props
Dave_bass5
lvl.4
Offline

pjollain Posted at 2018-9-27 03:36
Sorry to learn about the issue you are experiencing, I hope a solution will be provided by DJI.
I saw on your video that you are using a support to hold your Osmo Mobile vertical, where did you get it from?

Thanks for the support. The base is made by DJI  for the Osmo2. You can find it on the DJI website or Amazon etc.
2018-9-27
Use props
Dave_bass5
lvl.4
Offline

WebParrot Posted at 2018-9-27 05:18
Dave.... while you're waiting for a solution from DJI I have an additional step for you to try.  This may not help directly (as I've never had the problem you describe), but I've found that with a number of DJI products (aircraft included) they don't behave well if there are any old pieces of code in memory :-)  For any major update I delete the Go/Go4 App and do a clean install.  And BEFORE the fresh install I make sure the iPhone has memory cleared as well.  
To do this takes two steps.  First double tap the home button and 'flick' all of the active apps from memory.  Then do a second routine that (I believe) completely clears memory.  Hold down the on/off button until the "off" slider displays.... don't slide!... instead hold down the on/off switch while pressing the Home button.  Now download the Go App.

Thanks for the suggestion.
I have tried the Osmo 2 with a fresh phone, as well as with and without the GP app installed on both my phones. The result is always the same.
2018-9-27
Use props
Dave_bass5
lvl.4
Offline

iiaXeii Posted at 2018-9-27 05:23
the motor or mechanism on mine started to make noise once but then stopped and can't replicate... very weird

Mine has never done that. Ive always been careful with it. Never turned on without a phone, phone always balanced correctly etc.
2018-9-27
Use props
WebParrot
Captain
Flight distance : 8871 ft
  • >>>
United States
Offline

Dave_bass5 Posted at 2018-9-27 05:26
Thanks for the suggestion.
I have tried the Osmo 2 with a fresh phone, as well as with and without the GP app installed on both my phones. The result is always the same.

Got it.  I'll keep an eye on this thread to see what DJI offers for assistance ;-)
2018-9-27
Use props
WebParrot
Captain
Flight distance : 8871 ft
  • >>>
United States
Offline

djiuser_m6JQJka2DXqv Posted at 2018-9-26 16:35
Hello team
I bought OSMO 2 recently but one of the buttons just fell off.
I wanted to know if it's normal/usual for a button to just fell down.

You should contact DJI Support directly through the online " Chat "
You will get a direct reply and "talk" through the issue.  Plus if replacement is necessary they can issue a Case # and arrange for replacement.

This forum is not as efficient, plus you are hijacking a thread and changing the subject.  Please review the forum rules.
2018-9-28
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Just wanted to finish off this thread by saying i got 0% help from DJI over this. Even  after DJI Tony asked me to post a video he didnt have the decency to reply back in this thread.
I raised a support case via the DJI website and heard nothing from them.
Looking at this forum there seems to be a lot of people asking for help, and all they seem to get is basic generic questions without actually any real help or resolve. Seems to be just to bolster the Admin’s points without them actually having to do much other than a bit of cut and pasting from a text file.

So I’ve moved on and got another brand of Gimbal, and will never buy or recommend DJI to anyone.

Thanks to all that did bother to try and help, and good luck with your own DJI products.
2018-11-8
Use props
fans376e5147
lvl.3
United States
Offline

I didnt see any problem with the device base on the video you posted. You are in follow mode.
2018-11-8
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

No i wasnt. Well ok, i was at one point but as you can see, i changed modes and in one mode it wasnt working properly.
2018-11-8
Use props
fans376e5147
lvl.3
United States
Offline

I think you may want to enable the pitch lock. If that is the setting you are looking for.
9C457AF4-976D-481C-80D6-FB667F57A065.png
2018-11-8
Use props
Dave_bass5
lvl.4
United Kingdom
Offline

Tried that many times. It seem to be stuck off, even though the app is saying its on.  
Thanks anyway.
2018-11-8
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules