Please select Into the mobile phone version | Continue to access the computer ver.
Sudden Gimbal Failure
446 13 2018-10-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
Jarrod Photography
lvl.2
Flight distance : 84646 ft
Canada
Offline



Hi,

I have had my Phantom 4 since it first came out over 2 years ago.  I bought it brand new, and up until last week never had an issue with it.

I have used it numerous times for real estate videos, weddings, portraits etc. I have NOT ONCE crashed the drone and have been very careful with my equipment. I also have updated to the latest software.

I was doing a simple flight over some country land, filming some sequences for a barn wedding. You will notice in the video for no apparent reason, the gimbal starts shifting left, then up, you can also notice it trying to stablize, but it starts going wonky. Since this never happenned to me before i brought it down quickly without incident.

I took it home and tried to Auto Calibrate Gimbal and got a failure message. It appears that the gimbal may be dead and itsn't moving to any controls on the remote..

What should I try? Any suggestions?


2018-10-19
Use props
ALABAMA
Captain
Flight distance : 9758504 ft
United States
Offline

This same thing happened to me recently.  I brought it down, turned everything off, then restarted and it was corrected and hasn't happened again since.  However, I did not lose gimbal control.  Check and make sure no motors are hot to the touch.
2018-10-19
Use props
DJI Natalia
Administrator

Offline

Hi, we're sorry about this issue. Can you please try to do Restore Factory Default via DJI Assistant 2? After that, please kindly refresh the firmware of your drone and please do calibrate your gimbal. If the issue persists, I'm afraid that you may consider sending the unit in so we can analyze the problem. Should you have further question, please let me know. Thank you.
2018-10-19
Use props
Roadstar1700
lvl.3
Flight distance : 1203484 ft
United States
Offline

I had a similar issue the other day. I bought mine new 2+ years ago. I decided to update the firmware to the latest levels.

RC 1.9.3

AC 4.02.00.0700

DJIGO 4   4.3.0

On my second flight of the day I brought it up ~100 feet and immediately noticed the live video was moving all around. I first thought the AC was doing this, but it was stable in the air. I couldn't control the gimbal with the thumb wheel, so I landed, restarted the AC and it flew fine.

I'm going to re-cal the gimbal/sticks, but I'm wondering if the updates may have caused the issue.

Have you recently updates any of your firmware?

2018-10-22
Use props
fans398f75ed
lvl.2
New Zealand
Offline

Check the cable from the gimble to the housing. It often comes loose and I have had similar situations and it has always come back to the cable popping loose.
2018-11-4
Use props
RedHotPoker
Captain
Flight distance : 165105 ft
Canada
Offline

fans398f75ed Posted at 11-4 20:51
Check the cable from the gimble to the housing. It often comes loose and I have had similar situations and it has always come back to the cable popping loose.

That would be such an easy fix. Fingers crossed it works for them.



RedHotPoker
2018-11-4
Use props
boxerman
Second Officer
Flight distance : 39695 ft
United States
Offline

The same thing happened to me.  Take out the micro SD card and then perform a reformat of it.  Make sure to NOT do the quick reformat - do a fully secure format.  That fixed mine.  One thing I found is that if you take the SD card out you can fly with no "gimbal disconnected" messages.  The red LED near the SD slot will flash and you cannot record, but that showed me that it was an SD card problem.  This took me quite a long time to discover.

I tried to use Windows 10 to do a secure format, but with no feedback, I could not tell that anything was happening.  The progress bar stuck at 10% and never moved again.  So I used Fat32 using Disk Utility on an iMac running Mojave and selected the secure erase which took a couple of hours, but that fixed it.  I had read somewhere in the forums about problems with the SD card causing this.  After letting the Phantom do the format, that did not fix the disconnected gimbal problem.  It wasn't until today after reinstalling the firmware and making all the updates that I just took the SD card out, took the Phantom outside and started it all up.  The video feedback was fixed and the gimbal was working correctly.  So try the secure format (or a brand new SD card) and see if that sorts out the problem.
2018-11-4
Use props
Jarrod Photography
lvl.2
Flight distance : 84646 ft
Canada
Offline

Roadstar1700 Posted at 10-22 15:31
I had a similar issue the other day. I bought mine new 2+ years ago. I decided to update the firmware to the latest levels.

RC 1.9.3

Hey,

Thank you for the response. Sounds exactly like what happenned to me. I have upgraded to latest firmware, since that day haven't had the chance to get out and try it again. Will do that..
2018-11-6
Use props
Jarrod Photography
lvl.2
Flight distance : 84646 ft
Canada
Offline

fans398f75ed Posted at 11-4 20:51
Check the cable from the gimble to the housing. It often comes loose and I have had similar situations and it has always come back to the cable popping loose.

Hey,

Checked that, that is not the issue.
2018-11-6
Use props
Jarrod Photography
lvl.2
Flight distance : 84646 ft
Canada
Offline

boxerman Posted at 11-4 23:08
The same thing happened to me.  Take out the micro SD card and then perform a reformat of it.  Make sure to NOT do the quick reformat - do a fully secure format.  That fixed mine.  One thing I found is that if you take the SD card out you can fly with no "gimbal disconnected" messages.  The red LED near the SD slot will flash and you cannot record, but that showed me that it was an SD card problem.  This took me quite a long time to discover.

I tried to use Windows 10 to do a secure format, but with no feedback, I could not tell that anything was happening.  The progress bar stuck at 10% and never moved again.  So I used Fat32 using Disk Utility on an iMac running Mojave and selected the secure erase which took a couple of hours, but that fixed it.  I had read somewhere in the forums about problems with the SD card causing this.  After letting the Phantom do the format, that did not fix the disconnected gimbal problem.  It wasn't until today after reinstalling the firmware and making all the updates that I just took the SD card out, took the Phantom outside and started it all up.  The video feedback was fixed and the gimbal was working correctly.  So try the secure format (or a brand new SD card) and see if that sorts out the problem.

Hmmm interesting
2018-11-6
Use props
ATJ
First Officer
United States
Offline


SD has a very nice card formatter:

SD Memory Card Formatter
2018-11-6
Use props
Jarrod Photography
lvl.2
Flight distance : 84646 ft
Canada
Offline

Hey a quick update to this issue. It has mysteriously been solved. Turned on the drone today and no issue whatsoever. Odd. Will re-post if something else happens. I would hate to be on a paid shoot to have my gimbal fail again.

Thanx everyone for your suggestions
2018-11-10
Use props
DJI Natalia
Administrator

Offline

Jarrod Photography Posted at 11-10 08:16
Hey a quick update to this issue. It has mysteriously been solved. Turned on the drone today and no issue whatsoever. Odd. Will re-post if something else happens. I would hate to be on a paid shoot to have my gimbal fail again.

Thanx everyone for your suggestions

Hi, glad to know that is now working. Should you have further question, please don't hesitate to reach us. Thanks for your support and have a safe flight always.
2018-11-10
Use props
RedHotPoker
Captain
Flight distance : 165105 ft
Canada
Offline

Jarrod Photography Posted at 11-10 08:16
Hey a quick update to this issue. It has mysteriously been solved. Turned on the drone today and no issue whatsoever. Odd. Will re-post if something else happens. I would hate to be on a paid shoot to have my gimbal fail again.

Thanx everyone for your suggestions

That’s great news. Hope it keeps up...


Have fun, fly safe, happy landings.


RedHotPoker
2018-11-10
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules