Please select Into the mobile phone version | Continue to access the computer ver.
Unable to bind RE700 to P2 Vision
493 5 2018-11-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
mrmaia
lvl.1

Brazil
Offline

Hi guys, I'm new to the forum.

So I have an old P2 Vision+ that crashed and is retired, but with a working RE700 range extender, and a P2 Vision (no "plus") fully funcional with a RE500 range extender.
I want to rebind the RE700 to the working P2 Vision, and I know they're compatible from other posts on this forum, and I go through the entire procedure described in both manuals.

However, sometimes it shows the "wifi repeater connection failed" message and fails right away, or it does seem to complete the procedure but doesn't bind the drone to the range extender at all (no error message).

What can I be doing wrong? If I use the RE500 everything works normally, so any cable connections in the drone are discarded.

Thanks!
2018-11-13
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

Are you sure you're employing the binding procedure correctly?  Do you have the MAC address for the camera?  

Yes, sometimes you get no message at all.  That happens sometimes.  If so, tap the check mark in the upper right again.

Sometimes you get "wifi repeater connection failed" ... but it should take some time to see that message, say 10 seconds, with the little circle going around.  And that's kind of normal.  Repeat the procedure and it'll likely work the second time.  

If it says "wifi repeater failed" instantly, something is fundamentally wrong such as using the wrong MAC address perhaps, not initially resetting the range extender to binding mode, or your mobile device is not connected to the correct wifi signal (i.e. it's connected to your home's router rather than the RE signal).  
2018-11-14
Use props
mrmaia
lvl.1

Brazil
Offline

Mark The Droner Posted at 11-14 04:12
Are you sure you're employing the binding procedure correctly?  Do you have the MAC address for the camera?  

Yes, sometimes you get no message at all.  That happens sometimes.  If so, tap the check mark in the upper right again.

I'm using the very procedure specified in the manuals, the same I used to bind the RE500 previously. The MAC on the bird is clearly readable and the QR-code is also intact.

Tapping the checkmark when no error message appears (and it seems to have completed the procedure correctly) does nothing; the app returns to main menu but the binding fails, power cycling or not.

What I did observe is that those times when the "wifi repeater connection failed", the wifi simply disappears and takes over a minute to show back. Disabling all other wifi networks and mobile data to prevent connection with other networks doesn't work either.
2018-11-14
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

If the app returns to the main menu after attempting to complete the binding (tapping the check mark), something is wrong.  You should get a message Binding Successful or Wifi Repeater Failed.  Sometimes you may get no message at all.  But in all three examples, you should be left in the binding area, not the main menu area.  

I do know that when the "wifi simply disappears", that's because it is rebooting.  That is the RE rebooting.  That's normal and it's supposed to happen after a successful binding (maybe after an unsuccessful binding too, I can't remember).  After it reboots, you can connect again manually if it doesn't connect automatically.  

It almost sounds like something might be wrong with the transmitter in the camera.  But you say it works perfectly.  

You might search youtube for some P2V binding vids to get some ideas.  As far as I can tell from your description, you're doing it correctly.  

You might try to rebind the RE 500 from scratch.  If you can rebind it successfully, that would be a clue that maybe there's something wrong with your RE 700.  But that doesn't happen often.

I gotta go to work.

Good luck


2018-11-14
Use props
mrmaia
lvl.1

Brazil
Offline

Mark The Droner Posted at 11-14 06:04
If the app returns to the main menu after attempting to complete the binding (tapping the check mark), something is wrong.  You should get a message Binding Successful or Wifi Repeater Failed.  Sometimes you may get no message at all.  But in all three examples, you should be left in the binding area, not the main menu area.  

I do know that when the "wifi simply disappears", that's because it is rebooting.  That is the RE rebooting.  That's normal and it's supposed to happen after a successful binding (maybe after an unsuccessful binding too, I can't remember).  After it reboots, you can connect again manually if it doesn't connect automatically.  

I'm afraid to try rebinding the RE500 and somehow brick it, since even amidst these issues with the RE700 I can use and fly with the 500 perfectly fine.

The RE700 was bound to another bird once in its lifetime, could it have any influence? It does show as N/A today on the app.
2018-11-14
Use props
Mark The Droner
Captain
Flight distance : 2917 ft
United States
Offline

No it doesn't matter if the RE 700 was bound to something else before.  It should bind to whatever Phantom Vision series wifi transmitter you want provided the RE is in binding mode and you enter the correct MAC address for that transmitter.  
2018-11-14
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules