Please select Into the mobile phone version | Continue to access the computer ver.
Mavic Pro won't take pictures
1675 22 1-5 17:32
Uploading and Loding Picture ...(0/1)
o(^-^)o
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

Hi all. Really hoping for some help here. My Mavic Pro won't take pictures. The photo trigger button on the controller doesn't do anything, and when pushing the button on screen, I hear the shutter sound effect but the screen does not flash black like it normally would during a photo, and no photo appears on the SD card.
Sometimes, the drone takes an initial pre-flight photo and it will appear on the SD card. Sometimes it does not take this picture.


Video works fine. I have been able to intermittently take photos here and there since the problem started, but 90% of the time, I am unable to take pictures. I have made sure the Mavic, Controller, and app are updated to the latest firmware. I've also tried rolling back the Mavic's firmware to the oldest possible firmware version and this does not fix the problem.

I am using a Sandisk Extreme PLUS 32GB SD card. I have also tried a Samsung EVO Select 64GB card. Neither card fixes the issue. I have formatted each card using both my computer and the drone, and this does not fix the issue. I have tried all varieties of photo settings (Raw, JPG, etc) and photo types (single, HDR, etc) and nothing changes. I have used the short cable that plugs into the side of the controller, and a longer cable plugged into the bottom of the controller, and am unable to take photos either way. All other functions and buttons of the controller work fine. Auto focus on photos and videos works fine. Gimbal has been calibrated and functions normally.


When I first noticed the problem a couple of weeks ago, I was able to use the Airmap app to trigger photos and this worked great. However, yesterday when I tried to take photos, neither the Go app or Airmap app would allow me to take photos.

All of this started as soon as my 1-year warranty was up, which I would find suspicious, except that I seem to be the only one on the internet with this problem.
1-5 17:32
Use props
GroTToFlyeR
First Officer
Flight distance : 1064790 ft
United States
Offline

What phone u using? That happened to me before. Worked fine , then it didn’t, tried a family members pad and phone it worked fine. Hope this helps
1-5 19:51
Use props
DJI Stephen
Super Moderator

Offline

Hello and good day dreamhouse. I am sorry to know that you are having issues with your DJI Mavic Pro. May we know when did this issue started and may we know as well what is the model of the mobile device that you are using please? Thank you.
1-6 06:36
Use props
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

DJI Stephen Posted at 1-6 06:36
Hello and good day dreamhouse. I am sorry to know that you are having issues with your DJI Mavic Pro. May we know when did this issue started and may we know as well what is the model of the mobile device that you are using please? Thank you.

Sorry, I'm not sure when the issue started exactly because I used to only use the drone for video. The devices I have tried are:

iPhone 7 Plus - iOS 12.1
iPad 5th Gen - iOS 11.4.1

I am using the side port with the included cable for the iPhone, and the back port with a lightning cable for the iPad. Both devices are not able to take photos. I am guessing this is a hardware issue either with the camera or the controller at this point.

Is there any way to bypass the remote controller or reassign the photo taking button on it? If the hard button was malfunctioning on the controller, would that cause the app to not take pictures?

Just now during testing, the drone did a take an automatic picture when first booting up using the iPhone, and that picture saved to the SD card. Then, when booting up the app on the iPad it did not take this automatic picture. I then tried turning everything off, booting up in this manner:

1) Power on drone and wait 30 seconds.
2) Power on controller and wait 30 seconds.
3) Open app on iPad.

No automatic photo was taken during this 3rd reboot, and I am still unable to trigger a picture myself. I also noticed tonight that there are two more of these "automatic" photos on the SD card, and they are dated 1/1/14. (January 1st 2014). One of these photos is from tonight's testing, and one is from the night I started this post.

Videos are still working fine, and are dated correctly.

1-7 20:38
Use props
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

So, upon further testing, I can get the drone to take an automatic photo when the app is first opened up ONLY if the drone has been rebooted first. So, if I shut everything off, power the drone on, then the RC, then the app, it will take a photo and date it "1/1/14". It does this on my iPhone 7 Plus (iOS 12.1), my wife's iPhone 7 Plus (iOS 12.1.2), and my iPad 5th Gen (iOS 11.4.1).

If the drone has not been restarted, but I close the app and plus in a different device, it will try to take that automatic photo (I hear the shutter sound) but nothing appears on the SD card. The first photo will only work if the drone has been restarted first. So, the mechanics of the camera seem to be working fine (focus, photo taking, gimbal movement, etc.). I am still not able to use the photo button on the RC with any device, and the date of the initial photos is wrong.

When taking video, the video is stored on the SD card and the correct date is shown.

I've attached a photo of the Playback screen. The bottom row is all of the automatic boot up photos from tonight's testing, except the first one on the left which is from the other night when I made this post.

1-7 21:00
Use props
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

GroTToFlyeR Posted at 1-5 19:51
What phone u using? That happened to me before. Worked fine , then it didn’t, tried a family members pad and phone it worked fine. Hope this helps

Replied with the specs of each device I'm trying above, but I just wanted to see if it ended up working again on your own phone? Did you have to do anything special?

I use this for work, and this is killing me.
1-8 09:26
Use props
M2Wair
Captain
Flight distance : 1049770 ft
  • >>>
Ireland
Offline

Try using bottom port on controller with the cable from your phone, not the cable supplied with your drone.

Missed the part you've tried bottom port, my bad.
1-8 09:48
Use props
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

M2Wair Posted at 1-8 09:48
Try using bottom port on controller with the cable from your phone, not the cable supplied with your drone.

I've used the side port for both phones I tested, and the bottom port for all 3 devices. Same results.
1-8 09:49
Use props
M2Wair
Captain
Flight distance : 1049770 ft
  • >>>
Ireland
Offline

Have you uninstalled go4 and reinstalled it?

Last time I had a similar problem doing a uninstall and reinstall fixed it.

Sucks being a work drone so hope you get this resolved really quickly
1-8 09:59
Use props
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

M2Wair Posted at 1-8 09:59
Have you uninstalled go4 and reinstalled it?

Last time I had a similar problem doing a uninstall and reinstall fixed it.

App was freshly installed on my wife's phone, with no change. Didn't see a point in reinstalling it on all 3 devices since it doesn't seem like the app in the issue here.

I guess I'm not one of the lucky ones who will get a response from DJI in here?
1-9 12:17
Use props
M2Wair
Captain
Flight distance : 1049770 ft
  • >>>
Ireland
Offline

dreamhouse Posted at 1-9 12:17
App was freshly installed on my wife's phone, with no change. Didn't see a point in reinstalling it on all 3 devices since it doesn't seem like the app in the issue here.

I guess I'm not one of the lucky ones who will get a response from DJI in here?

I would open a support ticket and get it sent for repairs, seems like you've tired everything. Hope this is resolved quickly for you.
1-9 12:42
Use props
Ex Machina
Captain
Flight distance : 1418406 ft
United States
Offline

Try refreshing your firmware -- that's fixed the problem for me in the past.
1-9 13:23
Use props
Ex Machina
Captain
Flight distance : 1418406 ft
United States
Offline

dreamhouse Posted at 1-9 12:17
App was freshly installed on my wife's phone, with no change. Didn't see a point in reinstalling it on all 3 devices since it doesn't seem like the app in the issue here.

I guess I'm not one of the lucky ones who will get a response from DJI in here?

Your third response was from DJI.
1-9 13:24
Use props
GroTToFlyeR
First Officer
Flight distance : 1064790 ft
United States
Offline

dreamhouse Posted at 1-8 09:26
Replied with the specs of each device I'm trying above, but I just wanted to see if it ended up working again on your own phone? Did you have to do anything special?

I use this for work, and this is killing me.

No buddy. Sorry to say, once I got that black screen , it was no more for my phone. Sparaticly I update my go4 on android hoping but no. For now i am pad only
1-15 18:24
Use props
dreamhouse
lvl.1
Flight distance : 137740 ft
United States
Offline

GroTToFlyeR Posted at 1-15 18:24
No buddy. Sorry to say, once I got that black screen , it was no more for my phone. Sparaticly I update my go4 on android hoping but no. For now i am pad only

I'm not getting a black screen, and this is happening on 3 different devices. It's not the phone.
1-24 06:59
Use props
Bob Brown
First Officer
Flight distance : 3772907 ft
United States
Offline

Ex Machina Posted at 1-9 13:23
Try refreshing your firmware -- that's fixed the problem for me in the past.

Agreed. I would re-flash the drone FW.
1-24 07:47
Use props
Shopguy10
lvl.1
Flight distance : 189606 ft
United States
Offline

dreamhouse Posted at 1-24 06:59
I'm not getting a black screen, and this is happening on 3 different devices. It's not the phone.

I am having the exact same problem!  I mean exactly!  Have you had any luck fixing this problem? I had a job shooting aerial photos for a wedding and that’s when I found out my mavic decided to take one photo at start up and then store none of the pictures I took during the wedding. It makes the sound like it’s taking pictures when I use the screen trigger but it doesn’t store any pictures on Sd or internally. The photo button does nothing at this point either. Lost tons of money and thoroughly disappointed the wedding party. Please let me know if you find a fix.
6-18 19:44
Use props
Lonesome Crow
First Officer
Flight distance : 279311 ft
  • >>>
United States
Offline

Have you tried another cable?  Someone might have asked that already, and if so, my apologies.
6-19 14:54
Use props
Marten_Skallena
lvl.1
Flight distance : 51175 ft
Norway
Offline

Hi,  I am having the exact same problem.  Video works fine, bute the drone wont shoot any pictures; neighter from the Controller nor the App.  :-(    Any sugestions out there?

Thanks!
7-7 01:05
Use props
MauriceMavic
lvl.1
Netherlands
Offline

I had the same problem, newest firmware, reinstalled DJI Go 4 app, formatting SD card and internal storage: no results.
Eventually I used 'Reset Camera Settings' in de photo settings and after that everything worked fine again.
Hopefully this helps others as well.
7-13 02:15
Use props
Gazmg
First Officer
United Kingdom
Offline

Another thread........

go 4 app version 4.3.14 aircraft version 01.00.0300 remote 01.00.0300 Was able to get the camera button working again
7-13 02:58
Use props
Kelvecion
lvl.1
United Kingdom
Offline

Just got the same problem. Hitting the shutter button either on screen or receiver returns the shutter sound but no image is taken. I went into settings and reset the 'Camera Settings' This solved the problem and all's back to normal.
8-14 03:24
Use props
mawardibahar
New

Malaysia
Offline

Same issue just happen to me since yesterday. Before that all smooth, everthing perfect..

I used huawei p30 pro, and since updating dji apps, this problem happen..

This issue just happen when i try to snap photo..
Video no problem at all.
8-31 16:41
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules