Please select Into the mobile phone version | Continue to access the computer ver.
A2 LED problem - green LED won't illuminate
262 2 1-6 18:17
Uploading and Loding Picture ...(0/1)
o(^-^)o
fansf97e5d35
lvl.2

United States
Offline

Hi Everyone - I have been struggling to make headway with the repair service at DJI. I have a brand new A2 controller and the green LED is not working (red and blue are fine). I provided them these three videos to help diagnose the problem. Before reviewing the videos, keep in mind Green+Red=Yellow. DJI 'engineers' believe my end points are not properly configured because red is being displayed instead of yellow, eventhough the first video shows the end points are properly configured.

This video shows all A2 components up to latest revision firmware and radio has been properly configured (proper end points)
  
  
  
GPS and Attitude modes with GPS lock… after GPS locks, double purple blink (as documented in user manual) when in GPS mode and throttle not at 50%. Switch to attitude mode and LED changes to red, not yellow (green LED not working). In the second half of the video I repeat the same two modes but with the throttle at 50%.... single blinks in both cases as documented on the A2 user manual, but red (because green LED defective) instead of yellow in Attitude mode.
  
  
  
Compass calibration …. After horizontal calibration, LED should switch from solid blue to solid green…. Instead LED turns off since green LED is not working.
  
  
To me is seems pretty cut and dry the LED is defective. I was hoping others could weigh in and tell me what else I can do to convince the repair center to take my LED back only, instead of disassemblying the drone and sending the entire A2 hardware set back.

DJI - if you're monitoring this, my request number is 1536624.

Thanks!!
1-6 18:17
Use props
fansf97e5d35
lvl.2

United States
Offline

It turns out DJI has implemented a simple LED illumination test. Helicam Ireland was kind enough to post various A2 LED blink codes at vimeo.com/92766220, the first of which is the power on sequence of Green. Yellow, Blue. My defective green LED video   shows the power on sequence of Red, Blue. It is quite surprising to me the DJI 'engineers' who reviewed my videos never requested to see the power on sequence.
1-9 17:59
Use props
fansf97e5d35
lvl.2

United States
Offline

Here is an update for anyone interested in this wild ride with DJI tech support. I decided to send in just the LED module and DJI tested it and said everything was working fine and 'the problem is most likely with the PMU or flight controller'. I requested they provide me a video showing me all three LEDs were working. Another two days passed and they were unable to provide the video. However they decided to send me a new LED module. This last video shows the new LED module has resolved the issue with green and yellow now visible..... the original LED module was defective. For the life of me I cannot understand how DJI trained technicians were able to say the original LED module worked without issue. This problem was 100% repeatable and never displayed the green LED. I even shook the LED module to see if there was an intermittent connection in the module, with no success. Also recall, DJI 'engineers' said my end points were not setup properly

A rather disapointing first time experience with DJI products and their technical support. A total of 5 weeks lost on a simple problem.

1-9 18:03
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules