Please select Into the mobile phone version | Continue to access the computer ver.
"Camera Sensor Error"
120 1 2-8 09:31
Uploading and Loding Picture ...(0/1)
o(^-^)o
TheMightyThor
lvl.4
Flight distance : 501100
United States
Offline

Yesterday, I received my Inspire 2 back from repair, and when I connected my X7, I got a "Camera Sensor Error" and an "Air Encoder Error///Check if Gimbal is Installed". I then try my second X7 on the same Inspire 2, and I get the same error. I then tried both X7's on my second Inspire 2, and they both work fine. No errors. So I ship it back out for service and then had an Inspire 2 overnighted to me from BnH.

I'm now turning on the new Inspire I just received this morning, and once again I'm getting the same "Camera Sensor Error" and "Check if Gimbal is Connected" error with no picture. This happens on both my X7's, which work fine on my now one working Inspire 2.

Has anyone else experienced this or I am just really unlucky? What exactly would cause these errors on two separate drones, but work fine on a third?

All firmware is updated to the latest, but the issue persists even when reinstalling old firmware.


2-8 09:31
Use props
DJI Paladin
Administrator
Flight distance : 97

Offline

Hi TheMightyThor, my sincere apologies for the unpleasant experienced. You could try to clean the gimbal terminal pins with 95% alcohol and a soft cloth to see if the issue will persist. If it is convenient for you, please provide a screenshot or a short video of the issue for further checking. You can upload it by using google-drive or Dropbox and provide the link here. Thanks for your support.
2-10 15:30
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules