Please select Into the mobile phone version | Continue to access the computer ver.
DJI Go 4 - Android - Mavic Pro
415 9 4-17 11:29
Uploading and Loding Picture ...(0/1)
o(^-^)o
SUPNorway
lvl.1
Norway
Offline

So frustrated. Latest firmware, Galaxy S9+, Latest DJI Go 4 app. Mavic Pro (Always worked fine before the last few updates and firmware)DJI Go 4 says that my Mavic Pro is connected as an Inspire 1.
I choose Mavic pro from the list and it still says connected as Inspire 1.
Disconnects constantly. Does not recognise SD Card (formatted by Mavic Pro when it worked. Litchi has no problem)
These updates have bricked my £900 drone.
PLEASE HELP.




4-17 11:29
Use props
DJI Tony
Super Moderator

Offline

Hi, we're sorry for the troubles that it caused. The Inspire 1 drone supports DJI GO application while the Mavic Pro supports DJI GO 4 app. I would like to ask if you manage to uninstall and re-install the application? Please ensure that the application is DJI GO 4 app that would support the Mavic Pro. Also, during the disconnection problem, are you getting an error message says "DISCONNECTED" or "Aircraft Disconnected"?  Please keep us posted on the latest progress.
4-17 12:19
Use props
SUPNorway
lvl.1
Sweden
Offline

I know that the Inspire 1 uses the other app.  As I said above. I have the Latest DJI Go 4 app. The SD card is not recognised. The app looses image connectivity everytime or goes to a  a blanck screen. It switches to opti mode all the time even though there are 11 satelites locked in. I get the error messages everytime it disconnects or the image disconnects.

I have rolled back the firmware and reinstalled up to the latest version. I have uninstalled and reinstalled the DJI Go 4 app several times.

I have read the App reviews on Google play and there are hundreds of Android users experiencing similar difficulties.
4-18 00:06
Use props
SUPNorway
lvl.1
Sweden
Offline

When i connect my phone it prompts "Always open DJI Go 4 when Inspire 1 is connected"
It also prompts " Always open Litchi when Inspire 1 is connected" when I'm running Litchi.

Is it possible that I have some how updated Inspire 1 firmware into my Mavic Pro? If so what can i do about it?
4-18 00:34
Use props
MavSpa_user
Captain
Netherlands
Offline

Revert back to a go version which work for you, I am still on 4.1.22 for my Mavic Pro.
4-18 01:11
Use props
SUPNorway
lvl.1
Sweden
Offline

Thanks MavSpa  How do you get legacy versions of the app? Should I roll back the firmware too?
4-18 01:14
Use props
MavSpa_user
Captain
Netherlands
Offline

No just download it at apkmirror, firmware works!
https://www.apkmirror.com/apk/dj ... o-4-4-1-22-release/
4-18 03:20
Use props
SUPNorway
lvl.1
Norway
Offline

Hi . Thank you for your responses.
I rolled back the firmware to 1.4.10000 and deleted every DJI file i could find on my Galaxy S9+ and re installed.
Everything is working perfectly now so I'm just going to leave it like that.
Basically the latest firmware just does not work. For me at least.
4-18 03:58
Use props
GhostWolf010
Captain
Flight distance : 1118323 ft
Netherlands
Offline

I have the same. Too bad I still had a few disconnects last Saturday that prevented me from flying... if I have the time I will try to fix it
4-18 08:37
Use props
djiuser_7tCYdBU1eufZ
New

United Kingdom
Offline

Dji, have you fixed this yet,  I have exactly the same issues... disconnection,  inspire one, though I  did get access to the mavic by saying yes to the inspire connection. Darenth fly in that configuration though
11-15 07:56
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules