Please select Into the mobile phone version | Continue to access the computer ver.
New DJI Smart Controller No Video Feed
123Next >
3877 88 5-9 19:30
Uploading and Loding Picture ...(0/1)
o(^-^)o
fansbac7c326
lvl.2
United States
Offline

I just received my DJI Smart Controller for my MAVIC2 Zoom.  I did all the updates for the controller and firmware for the drone so everything is updated.  When I start the controller and drone,  I am not receiving any video feed on the screen.  I would click the shutter and review and I can see that the camera is working for both video and picture.  I relink my old contoller and I see video on my phone using the GO4 app. Any ideas or this is going back to the store.
5-9 19:30
Use props
DJI Susan
Administrator

Offline

Hi there, I'm sorry to read the issue. May I know what's the current version of the aircraft and controller? It will be better to upload a short video of your operation. we'd like to check the exact status, thank you!
5-10 00:11
Use props
LoloEyo
lvl.2
United States
Offline

5-10 07:53
Use props
LoloEyo
lvl.2
United States
Offline

The above pictures show the version of the firmware etc.  In trying several times,  I would sometimes get the gray blank screen,  sometimes the image is displayed but in gray,  and then sometimes it works.  I need to know if I need to return this if not fixable.  This has to work 100% all the time.  
5-10 07:56
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline

Hi I have got the same issue, started after the last firmware update. every time it as done it i have been in the settings menu,  when i come out of the menu it sometimes does it, i have other issues, the go4 app crashes, i get a message from the SC " the Go4 App has stopped working" i think it is something to do with the SD card, im testing the SC at the minute without the sd card to see if it still crashes. I was using a recommended SD card when the App crashed. I don't think you SC is faulty because mine was ok until the last update but for the date issue
5-11 09:10
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

did you tried to reset dji go app data and relink controller with aircraft?
5-12 06:49
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline

DH_Pilot Posted at 5-12 06:49
did you tried to reset dji go app data and relink controller with aircraft?

Hi DH, how do you do that?
5-12 09:49
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

TVOD Posted at 5-12 09:49
Hi DH, how do you do that?

Go to Settings - Apps - DJI GO 4 - Storage - Clear Data. Before doing that do not forget to sync all flights in DJI GO 4 to do not loose anything.

Relinking you could do from quick settings - swipe from top of screen and click option  Linking. After that click button on drone which is under cover opposite SD card cover.
5-12 09:55
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline

DH_Pilot Posted at 5-12 09:55
Go to Settings - Apps - DJI GO 4 - Storage - Clear Data. Before doing that do not forget to sync all flights in DJI GO 4 to do not loose anything.

Relinking you could do from quick settings - swipe from top of screen and click option  Linking. After that click button on drone which is under cover opposite SD card cover.

Cheers DH
5-12 10:17
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline


Was it helpful?
5-12 20:16
Use props
raven swe
Second Officer
Flight distance : 469144 ft
Sweden
Offline

mines been losing video feed at times upon startup since the latest sc update, turning the sc off then back on and its back, done a reset and relinked the drone made no difference, still does it randomly but never in flight or in and out of menus, only on first startup.
5-13 11:28
Use props
LoloEyo
lvl.2
United States
Offline

I cleared the data and reentered my DJI info and then relink my controller but the same thing is happening.  The first time I tried to connect,  I can see the video feed and then all other attempts were blank gray screen.  This is ridiculous after spending $700 including tax and its a piece of junk.  I am going back to the original controller and my iphone and this is going back to Bestbuy.  I read they charge 15% restocking fee for returns so that sucks even more but this is very frustrating.  Thanks for the replies.
5-13 11:38
Use props
CRAIGMART75
Second Officer
Flight distance : 692625 ft
  • >>>
United States
Offline

I have the same problem after I updated to the new firmware. I have relinked the controller and drone . Some times I get a grey screen sometimes video.. I have used the SC since it came out with no problems.
5-13 18:21
Use props
MAVICDLNM
Second Officer
Flight distance : 7930738 ft
  • >>>
Hong Kong
Offline

LoloEyo Posted at 5-13 11:38
I cleared the data and reentered my DJI info and then relink my controller but the same thing is happening.  The first time I tried to connect,  I can see the video feed and then all other attempts were blank gray screen.  This is ridiculous after spending $700 including tax and its a piece of junk.  I am going back to the original controller and my iphone and this is going back to Bestbuy.  I read they charge 15% restocking fee for returns so that sucks even more but this is very frustrating.  Thanks for the replies.

if you get from best buy, just return it or exchange a new one.  Definitely is the hardware QC fault.  
5-13 18:39
Use props
MAVICDLNM
Second Officer
Flight distance : 7930738 ft
  • >>>
Hong Kong
Offline

LoloEyo Posted at 5-13 11:38
I cleared the data and reentered my DJI info and then relink my controller but the same thing is happening.  The first time I tried to connect,  I can see the video feed and then all other attempts were blank gray screen.  This is ridiculous after spending $700 including tax and its a piece of junk.  I am going back to the original controller and my iphone and this is going back to Bestbuy.  I read they charge 15% restocking fee for returns so that sucks even more but this is very frustrating.  Thanks for the replies.

if you get from best buy, just return it or exchange a new one.  Definitely is the hardware QC fault.  
5-13 18:39
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

For me it was working so far without issue with latest version. Only thing I have done differently is that I have linked aircraft via Aircraft management and added my AC with name to SRC.
5-13 20:23
Use props
CRAIGMART75
Second Officer
Flight distance : 692625 ft
  • >>>
United States
Offline

I have done the same with linking the drone to the SC in aircraft management and still get no video sometimes.
5-13 20:48
Use props
MaxPDSK
lvl.2
Slovakia
Offline

I have the same issue from the very start. First thing I did after unpacking was firmware update for both SC and drone. When I start the controller and app automaticly launch, randomly I get no camera picture, same like the photos above. When I close the app, go to settings and click on my drone's icon (in device manager or how it's called), DJI Go app starts and I can see the camera picture. I did reset of controller setting, reconnected it with drone and it was ok. But maybe the problem will come back again, because I just tried to open the app 2 or 3 times and have not used it since than. ..I think this is a software problem.
I would also like to ask, if the SC automaticly reconnect after the signal lost? ..when I was testing the drone, I flew over the hill with trees and lost the signal (of course I did ). The drone came back at the safe altitude, but the picture didn't came back, only the beeping sound was present.
5-14 04:05
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline


Hi DH, not sure if it was helpful, but thanks anyway, still using the SC without a SD card to see if the Go 4 app crashes, up to now it has not crashed once, and thats with Six battery changes, the Loss of video is obviously a bug looking at the response above, found another bug with the RTH sometimes when I press the RTH button the drone just starts to land where it is. the drone was about 23 metres away when this happened, i was testing the precession landing on my new landing pad, i cancelled the RTH and moved the drone a bit further away and pressed the RTH button again and the drone returned to the landing pad, what bothers me with this is, if there are things that are not in your control like lost of signal and the drone just lands where it is , that the 5th time its happen to me now,,. Cheers
Roy
5-14 10:30
Use props
raven swe
Second Officer
Flight distance : 469144 ft
Sweden
Offline

that's what it programmed to do, if its within so many meters of home,, cant remember how many it will land on RTH, tis in the manual somewhere,

from the manual

Relating to RTH, the manual says:-
.....that if your drone is less than 20 meters away from you when you press the RTH button then it will land just where it is ......
5-14 11:00
Use props
Trailkill
Second Officer
Flight distance : 316762 ft
  • >>>
United States
Offline

Ok I just started having the same problem gray screen after boot-up. I shut down and restart then maybe I get a picture.
Got to keep an eye on this.

TK
5-14 11:11
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline

raven swe Posted at 5-14 11:00
that's what it programmed to do, if its within so many meters of home,, cant remember how many it will land on RTH, tis in the manual somewhere,

from the manual

Cheers I thought i had read that somewhere, still even so its a bit S@@t, because you could be near water with no control, that need sorting out, i was showing a mate at work how good the drone was by demonstrating the RTH and the drone nearly landed on a corrugated roof,

Roy
5-14 12:41
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

TVOD Posted at 5-14 12:41
Cheers I thought i had read that somewhere, still even so its a bit S@@t, because you could be near water with no control, that need sorting out, i was showing a mate at work how good the drone was by demonstrating the RTH and the drone nearly landed on a corrugated roof,

Roy

Yes that is correct RTH is working fully only from some distance from home point if you are within some range it will just start landing without RTH to home point, this is the same also with normal controller and normal dji go app.

Regarding SD I'm using 64gb sd in controller and switched all application data to SD, after upgrade it was asking if I would like to use SD as primary storage for everything so clicked yes it rebooted, did something like DJI GO 4 data reset and since then I'm running from SD. Maybe that is the culprit of issue?
5-14 21:38
Use props
simonesimone
lvl.2
Flight distance : 86706 ft
  • >>>
Italy
Offline

Same problem here! Both the drone and the controller are up to date:
- Smart Controller 01.00.0530
- Mavic 2 Pro v01.00.0400

This is a screenshot of the situation I have:



Please help us, I really don't feel safe to go in flight in these conditions. Thanks.
5-19 12:59
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

simonesimone Posted at 5-19 12:59
Same problem here! Both the drone and the controller are up to date:
- Smart Controller 01.00.0530
- Mavic 2 Pro v01.00.0400

Could you please describe exact conditions when this will happen? Step by step like:
1. powered on SRC
2. powered on drone
3. ......

And also conditions when it is working? I would like to test on mine the same scenario.

Thanks
5-20 06:40
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline

Hi DH the resetting the data in the Go4 app seems to be working up to now, i have had a SD card in the SC for 4 battery changes and not had a glitch yet , time will tell, cheers and thanks for the advice

Roy
5-20 10:12
Use props
simonesimone
lvl.2
Flight distance : 86706 ft
  • >>>
Italy
Offline

DH_Pilot Posted at 5-20 06:40
Could you please describe exact conditions when this will happen? Step by step like:
1. powered on SRC
2. powered on drone

Sorry but I didn't find a way to replicate the problem. I can just say: on ground, motors off, playing with the menus. As soon as I have any other update I'll write you. Thanks to all!
5-20 10:36
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

TVOD Posted at 5-20 10:12
Hi DH the resetting the data in the Go4 app seems to be working up to now, i have had a SD card in the SC for 4 battery changes and not had a glitch yet , time will tell, cheers and thanks for the advice

Roy

Thanks for info.
5-20 10:56
Use props
DH_Pilot
First Officer
Flight distance : 2306526 ft
  • >>>
Slovakia
Offline

simonesimone Posted at 5-20 10:36
Sorry but I didn't find a way to replicate the problem. I can just say: on ground, motors off, playing with the menus. As soon as I have any other update I'll write you. Thanks to all!

Are you using SD card in Controller and did you set SD as preferred location for all data when asked after reboot?
5-20 10:57
Use props
Quentyn
First Officer
Flight distance : 37759 ft
United Kingdom
Offline

hi I have the same issue since the last firmware update, several reboots and its fixed

at the moment its just annoying
5-20 11:17
Use props
simonesimone
lvl.2
Flight distance : 86706 ft
  • >>>
Italy
Offline

DH_Pilot Posted at 5-20 10:57
Are you using SD card in Controller and did you set SD as preferred location for all data when asked after reboot?

I would exclude this: it happened to me the first time without having never plugged any SD. Now I have an SD configured as preferred, and it happened also in this case.
5-20 12:02
Use props
ENC DRONES
lvl.2
United States
Offline

Having the same issue. New Zoom and SC. I have updated everything and have NOT added SD cards to either. Grey screen. So much for a test flight today or any fun this weekend. Have turned it all off and turned everything back on. Checked all the setting and even checked again for updates.
5-25 12:49
Use props
simonesimone
lvl.2
Flight distance : 86706 ft
  • >>>
Italy
Offline

ENC DRONES Posted at 5-25 12:49
Having the same issue. New Zoom and SC. I have updated everything and have NOT added SD cards to either. Grey screen. So much for a test flight today or any fun this weekend. Have turned it all off and turned everything back on. Checked all the setting and even checked again for updates.

Very sad to read these stories, I have chosen the SC to have superior stability and a dedicated solution to fly but I encountered:
- embarrassing first update workflow;
- grey screen issues;
- continuous prompt of inconsistent firmware found;

Hope these problems will be solved ASAP but I'm afraid since the SC is out from a while now.
5-25 15:11
Use props
ENC DRONES
lvl.2
United States
Offline

I have the M2 pro I use with a 10" tablet without issue and went with the M2 Zoom with SC to make it faster to handle some of the smaller jobs I do that didn't require super detailed photos and to allow me to get closer picts without getting the drone into tight spots but I am not so sure I feel comfortable using it now. I haven't even had my first flight on her.
5-25 15:59
Use props
fans76b622a7
lvl.2
Flight distance : 10 ft
United States
Offline

Same problem here, started after the last update.  Seems to be software related.
5-28 06:35
Use props
ENC DRONES
lvl.2
United States
Offline

I reloaded the update and today had no issues, everything came up just fine. I did a quick 15 min flight with a max altitude of 100ft and about 200 feet away without issue. Heavy winds today and it was the maiden so did not want to push too hard as I had it around a few trees and over a pond.
5-28 16:56
Use props
LexonTuxi
lvl.4
Flight distance : 56657 ft
Austria
Offline

+1 as mentioned here: https://forum.dji.com/forum.php?mod=viewthread&tid=190218

@DJI: anything further to do to fix this issue?
5-29 01:16
Use props
TVOD
lvl.4
Flight distance : 1680082 ft
United Kingdom
Offline

HI , reseting the dji go app data and relink controller with aircraft has worked for me up tp now over multiple flights, still finding little bugs like settings changing on their own. i fly in mode 3 as i am left handed, i was out yesterday, when i tried to take off, the drone would not go, thats when i found out the mode had changed back to mode 2, its  just worrying what else may have got changed, i did check btw

Roy
6-2 01:01
Use props
djiuser_1iD2VvhUb5xT
lvl.2

United States
Offline

Same problem here, happened since last FW update.  No video feed upon boot up with SC and M2P.  Have relinked several times and still occurs.  Requires multiple reboots to regain video feed.  DJI please fix this soon!
6-2 07:58
Use props
fanse466a791
lvl.2
Flight distance : 1970413 ft
United States
Offline

I will chime in as well.  This happened to me too today for the first time.  That is why I searched for others with same issue.  My SC also had a proper SD card inserted. My incident happened as my Mav2pro  was sitting on landing pad (thankfully).   I checked my image transmission settings and a few others during my GSOD (Grey Screen Of Death) while standing right next to it.  After about 5 minutes and realizing I was stumped, I powered off then back on both SC and MAv2pro.  Issue went away and I decided to fly (close and cautiously) through a full battery.  Then flew farther on next three batteries.  My SC is still like new but about 3 months old.   It has the latest firmware update (first thing I checked when I got home).  Is this issue going to be resolved I wonder?  Seems like there is small percentage of us experiencing the same thing.  I'm sure others have or will experience this at some point and I hope DJI investigates the problem.

I thought I would try taking off and hover just above landing pad to see if the problem would correct itself before I power cycled SC and Mav2Pro.  It did not.




6-16 19:38
Use props
123Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules