Please select Into the mobile phone version | Continue to access the computer ver.
P4 RTK issues with storing images
2101 29 2019-6-12
Uploading and Loding Picture ...(0/1)
o(^-^)o
akmentins
lvl.2

Latvia
Offline

Hello!
Has anyone encountered problem with image storing on SD card during the flight? Im using P4 RTK with latest firmware updates.
So there are several scenarios:
1. Start misson, taking photos and everythings OK (and this is not the problem);
2. Start or resume mission, the flight goes on, it shows that SD card is OK, it looks like camera is taking photos on RC screen, but SD capacity is not decreasing and there is no ongoing taken image count;
3. Start or resume mission, the flight goes on, it shows that SD card is OK, it looks like camera is taking photos on RC screen, but SD capacity is decreasing, ongoing taken image count goes up to 12 and stops (SD capacity still decreasing, but in the end only 12 images stored).


I tried different SD cards, on different firmware versions, but the issue is still present. Any clues, maybe its actually some kind of mechanical problem?


2019-6-12
Use props
patiam
First Officer
  • >>>
United States
Offline

Haven't run into this on the P4 RTK or any other DJI AC I've flown. I'm assuming that in addition to swapping SD cards you also tested each to the extent possible in either another AC or some other device.

For #2 do you mean you get no images at all?

In #3 s it overwriting with only the last 12 images kept, or do you get the 1st 12 images and then no more?



2019-6-12
Use props
akmentins
lvl.2

Latvia
Offline

patiam Posted at 6-12 07:58
Haven't run into this on the P4 RTK or any other DJI AC I've flown. I'm assuming that in addition to swapping SD cards you also tested each to the extent possible in either another AC some other device.

For #2 do you mean you get no images at all?

It seems that it has something to do with SD card writing speed, I guess its too low, will try with higher ones.

And yes for #2 no images at all, just empty folder.
#3 first 12 images.
2019-6-12
Use props
patiam
First Officer
  • >>>
United States
Offline

My bad, I assumed you were using SD cards w/ recommended specs. I should have asked what kind.
2019-6-12
Use props
Geebax
Captain
Australia
Offline

akmentins Posted at 6-12 10:51
It seems that it has something to do with SD card writing speed, I guess its too low, will try with higher ones.

And yes for #2 no images at all, just empty folder.

When this happens, it is more usually caused by an SD card that is too slow for the job. Other factors that influence it are the shooting mode you are using (JPEG or RAW) and how long since you last formatted the SD card. The latter is important because DJI create hidden folders on the card and fill them with files that are of no use to you, formatting gets rid of them.
2019-6-12
Use props
patiam
First Officer
  • >>>
United States
Offline

P4 RTK can't shoot RAW
2019-6-12
Use props
fans3cf3ca7b
lvl.3
Flight distance : 1837 ft
France
Offline

Hello
I encounter the same problem of saving photos on the SD card. I tested several SD card the problem is still the same. These SD cards work perfectly on my I2, P4Pro or Mavic 2 Pro.
I realize long mission for surveyor and I realize that this problem appears during the management multi batteries. After changing the battery I run the intermediate mission that was created, at this time we have the impression that the photos are taken (screen gets dark quickly) but the number of photos on the map does not decrease !!!!! !
DJI soon support a correction of this bug? which makes me lose a lot of time seeing makes the realization of multi-battery mission impossible.
Another problem is present on the classification of the photos and the loss of the signal RTK during the mission for no particular reason the photos will be recorded on a file DCIM and not survey (whereas the application does not indicate that I am connected to the RTK )
DJI make something !!!!
2019-6-14
Use props
jivago
Second Officer
Flight distance : 23671 ft
Iran
Offline

patiam Posted at 6-12 12:19
My bad, I assumed you were using SD cards w/ recommended specs. I should have asked what kind.

Hi
I encountered to something like that when I used SD card with slow read/write speed. When I changed it, no more saw that issue.
2019-6-14
Use props
akmentins
lvl.2

Latvia
Offline

jivago Posted at 6-14 06:42
Hi
I encountered to something like that when I used SD card with slow read/write speed. When I changed it, no more saw that issue.

I changed SD card, using now one with 80 MB/s writing speed, but still with multi battery missions problem still pops up from time to time…
2019-6-26
Use props
akmentins
lvl.2

Latvia
Offline

As you can see in the image, there is some shooting lines missing. Thats because of not storing taken images on SD card… fast one
DJI do something...
2019-6-26
Use props
patiam
First Officer
  • >>>
United States
Offline

akmentins Posted at 6-26 04:04
[view_image] As you can see in the image, there is some shooting lines missing. Thats because of not storing taken images on SD card… fast one
DJI do something...

i think you may have another issue now, having to do with multi-battery mission behavior not your slow SD card- see this thread:

Phantom 4 RTK wont return to breakpoint

as DJI4Survey notes in  post 34#:

Pressing Pause FIRST, rather than End.   The drone will hover in place, then RTH.

It creates a visible waypoint at the pause location and returns to the spot upon battery change.

Happy multi-battery flying.

2019-6-26
Use props
Mayehem
lvl.2
Flight distance : 9672 ft
Canada
Offline

patiam Posted at 6-26 08:00
i think you may have another issue now, having to do with multi-battery mission behavior not your slow SD card- see this thread:

Phantom 4 RTK wont return to breakpoint

Nailed it!
2019-6-26
Use props
akmentins
lvl.2

Latvia
Offline

patiam Posted at 6-26 08:00
i think you may have another issue now, having to do with multi-battery mission behavior not your slow SD card- see this thread:

Phantom 4 RTK wont return to breakpoint

Nope! It returns to the exact point where mission was interrupted (I can see on the RC map), resumes flight, I have controller screen blinking like its taking pictures, but none saved. Some times it even does not create the flight directory on SD card, but sometimes it does and it contains 4 files, but no pictures.
Besides I changed SD card which has much more writing speed than requireed.
2019-6-27
Use props
patiam
First Officer
  • >>>
United States
Offline

akmentins Posted at 6-27 06:41
Nope! It returns to the exact point where mission was interrupted (I can see on the RC map), resumes flight, I have controller screen blinking like its taking pictures, but none saved. Some times it even does not create the flight directory on SD card, but sometimes it does and it contains 4 files, but no pictures.
Besides I changed SD card which has much more writing speed than requireed.

Hmmm sounds like a different problem indeed....
2019-6-27
Use props
DJI4Survey
Second Officer

Australia
Offline

Hey buddy,

Have you got a SD card with high write speed yet and re-tested?  I have had this problem with other UAVs and it was the card write speed was too slow to keep up with the forward overlap (Fixed wing drones).

Go the highest speed you can afford and I think it will solve the issue.

Cheers,
2019-6-27
Use props
akmentins
lvl.2

Latvia
Offline

DJI4Survey Posted at 6-27 14:20
Hey buddy,

Have you got a SD card with high write speed yet and re-tested?  I have had this problem with other UAVs and it was the card write speed was too slow to keep up with the forward overlap (Fixed wing drones).

Yes, 80 MB/s writing speed does not solve it...
2019-6-28
Use props
EOandA
lvl.1
United States
Offline

I flew a 1000 acre site today and ran into the exact same problem about 3/4 of the way through the project - appears to be taking photos but the count is not going up. Only a handful of photos in the SURVEY directory. I broke this site up into four pieces and only ran into this issue on one 300 acre chunk. I struggled with it for hours and figured I would have to go back and fly it over. When I got back to the office, I did find the images in the DCIM/100MEDIA folder and they do appear to have all the RTK EXIF info, but no rinex files. Trying now to see if they will process successfully.

If it is any help, I just upgraded to the latest firmware right before this job.
2019-6-28
Use props
akmentins
lvl.2

Latvia
Offline

It seems that problem solved with this memory card:
2019-8-1
Use props
patiam
First Officer
  • >>>
United States
Offline

It's not just about write speed. That's a UHS-1 card. DJI recommends Class 10 / UHS-1 cards for the P4P RTK.

(see pg 8 for English Specs)

If the supposed 80MB/s card you were using before was not at least Class 10 / UHS-1 then that was probably your issue. Glad you got a card that works!
2019-8-2
Use props
Hurricane323
lvl.1
  • >>>
United States
Offline

PPKRAW.BIN file showing 0KB. Is that normal?
2019-10-17
Use props
jogari8804
lvl.1

Mexico
Offline

akmentins Posted at 8-1 23:58
It seems that problem solved with this memory card:
[view_image]

So this memory card is the solution?  because I have the same problem
2019-11-20
Use props
Bill68
lvl.1
United States
Offline

Just flew a mission today.  Last chance before a snow storm.  Got back to the office to process and found the P4RTK  only recorded ONE jpg.  There is still 32Gb left on this 64Gb card.  I've used the same card for the past 10 missions with no problem.   It's been a couple of months since my last mission.  I noticed there is a PPKRAW.sig file in the folder not in any other mission.  
2019-11-23
Use props
Bill68
lvl.1
United States
Offline

The card I'm using is a Samsung 64Gb EVO Select (Class 10).
2019-11-23
Use props
Geebax
Captain
Australia
Offline

Bill68 Posted at 11-23 11:01
Just flew a mission today.  Last chance before a snow storm.  Got back to the office to process and found the P4RTK  only recorded ONE jpg.  There is still 32Gb left on this 64Gb card.  I've used the same card for the past 10 missions with no problem.   It's been a couple of months since my last mission.  I noticed there is a PPKRAW.sig file in the folder not in any other mission.

Try formatting the SD card in the aircraft before each mission. DJI write lots of files to the card and put them in hidden folders where you can't see them.
2019-11-23
Use props
RTC_Droneguy
lvl.1
Flight distance : 172635 ft

United States
Offline

This my first time posting, so I want to start out by saying thanks to all the power users on the forum. Stalking the pages over the last year led me to get the P4RTK and create a good usable workflow for my needs. Unfortunately, I had this happen to me a few weeks ago. I have used SanDisk extreme 64 GB cards in the drone for the past 8 months with no issues. I usually format the card before each mission, but didn't do it this time because I had data on this card that I wan't sure that I had saved. I was doing a large area and didn't notice that the data had not been recorded until processing. I have the latest firmware, have never had this happen before and have flown several mission since then with no issues. I have no idea why it did it this time, but this is the only time that I have flown a mission with out formatting the card prior to start.
2019-11-28
Use props
Skyveyor112
lvl.4
United States
Offline

We just had a similar issue. We flew five flights today.  3/5 flights captured and stored images although only 1/5  stored images in the survey folder, despite being RTK fixed.  So we are having two problems:

1) Images are in the media folder instead of the survey folder with an RTK fix.  Typically, the image counter starts counting then stops aorund 12. However, the SD memory card indicator continues to decline, indicating images are being stored. At the end of the flight, the RTK fixed tally is 12 or where ever the counter stop.  12 images are in the Survey folder while the remaining images are in the media folder. The images in the media folder have an RTK value of 50 (fixed) in the EXIF data. And they import into Pix4d with high precsion horizontal and vertical error values. While annoying I can live with this anomaly. I would like to understand why its happening though.

2) 2/5 flights didn't save any images to the SD card.  I remembered this thread and read it thoroughly. We checked the sd card. We are using a UHS-3/V30 card that was recently formatted.  One of the two flights that didnt store images, stored one image.  Why it stored one and not others is a preplexing mystery.  It was cold, around 22f and windy. Could this be a factor?

At this point we are not sure how to proceed as we can't confidnetly go to the field knowing the Phantom RTK will store images.  

We have never seen this problem with our Phantom 4 Pro V2s and have flown them on similar days.

Any ideas are appreciated.

Thanks,

Dave
2019-12-18
Use props
tahirturan
lvl.1

Turkey
Offline

I'm having this problem too. Especially since 2 months. I have tried several different SD cards (Samsung Evo, Sandisk Extrem etc) but the problem is not solved. Did the above SD card solve the problem? Or can it be related to firmware?
2019-12-23
Use props
tahirturan
lvl.1

Turkey
Offline

akmentins Posted at 8-1 23:58
It seems that problem solved with this memory card:
[view_image]

Does the problem persist?
2019-12-23
Use props
Skyveyor112
lvl.4
United States
Offline

tahirturan Posted at 12-23 15:09
Does the problem persist?

If you are using a high speed memory card,  and it's still not working it may be a formatting issue.

We used two SD cards unknowingly formatted differently.   The one that worked was FAT32, not sure how the other one was formatted.
2019-12-23
Use props
akmentins
lvl.2

Latvia
Offline

tahirturan Posted at 2019-12-23 15:09
Does the problem persist?

So far its working fine with hi-speed memory card.
2-5 11:39
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules