Please select Into the mobile phone version | Continue to access the computer ver.
Wiring error during the build, robot turns backwards
Uploading and Loding Picture ...(0/1)
o(^-^)o
LTrain
lvl.2
Flight distance : 91919 ft
  • >>>
United States
Offline

Somewhere along the way we made a wiring mistake.
In FPV model the robot turns left when we move the stick right and vise versa.
Coding up a simple program in scratch has the same effect.

So clearly we got two wires crossed in the control module.  
Is there a wiring diagram for the four wheels that shows the correct inputs?
7-16 19:41
Use props
LTrain
lvl.2
Flight distance : 91919 ft
  • >>>
United States
Offline

Figured it out we put the wheels on backwards even after I called myself checking gfor that...
7-16 19:48
Use props
daev2018
lvl.4
Flight distance : 12263740 ft
  • >>>
United States
Offline

I have the wheels on correct but I have to slide the left control pad down to go forward. Is that correct?
7-19 15:00
Use props
Saberfly
lvl.2
United States
Offline

What you need to do is re learn the wheels step. I didnt notice it on the screen but when it prompts you to spin the wheels 3 times, one side shows to turn them backwards. I didnt notice it the first time either but when I re did it, mine worked fine. Let me know if it helps you.
7-19 18:29
Use props
Malibu Aerial
Second Officer
Flight distance : 143898 ft
United States
Offline

daev2018 Posted at 7-19 15:00
I have the wheels on correct but I have to slide the left control pad down to go forward. Is that correct?

The wheels are not the same. 2 clockwise and 2 counter clockwise. You must have mixed them up.
7-20 07:08
Use props
Saberfly
lvl.2
United States
Offline

Mine did the same thing and they were on right.
7-20 07:44
Use props
djiuser_LXNCTQ1omKMP
lvl.1
Flight distance : 46155 ft
Offline

My robomaster’s left and right is fine but it’s it able to move forward or backward
image.jpg
9-23 11:51
Use props
Duane Degn
lvl.4
Online

djiuser_LXNCTQ1omKMP Posted at 9-23 11:51
My robomaster’s left and right is fine but it’s it able to move forward or backward

Have you tried addressing the motors in the app?
From the "Solo" FPV screen tap the "Settings" icon in the top right.
Select "System" and then use the "Motor Addressing" feature.
It looks like your wheels are on correctly. The rollers should make an "X" when viewed from the top.
9-23 12:02
Use props
djiuser_LXNCTQ1omKMP
lvl.1
Flight distance : 46155 ft
Offline

Duane Degn Posted at 9-23 12:02
Have you tried addressing the motors in the app?
From the "Solo" FPV screen tap the "Settings" icon in the top right.
Select "System" and then use the "Motor Addressing" feature.

After motor addressing the movements are working as intended. Thanks for the help!
9-23 12:06
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules