Please select Into the mobile phone version | Continue to access the computer ver.
Robomaster S1 Windows App - camera problems
Uploading and Loding Picture ...(0/1)
o(^-^)o
Robi_DE
lvl.1
Offline

Hi!

I recently tried to use the windows app for the Robomaster S1, but I have some problems with that. The camera does not work and the robot status is bad (nearly every system is listed). However the movement control is working.
I tried this with my desktop pc and my laptop (windows 10 pro). I wonder if anyone else has this experience - or better a hint for solving it :-)



Everything is working fine with my iPhone (both connection methods) and love this robot. But it would be great to use also the windows app - especially for the lab.


Otherwise I have to wait for an update of the windows app.

9-2 22:25
Use props
Duane Degn
lvl.4
Offline

Did you scan the on screen QR code with the robot's camera as part of the connection process?
It's really odd the camera would work to scan the QR code but not after than.
Which sections of the app have you tried? Are you using the "Solo" option? Have you tried "Lab"?
9-3 06:41
Use props
rhoude57 - YUL
Second Officer
Offline

I'm using the RoboMaster S1 PC program for Windows 10 with no issues whatsoever.

Have you tried disabling your Firewall? It may be blocking ports the PC app and S1 are trying to use to communicate.
9-3 13:22
Use props
Robi_DE
lvl.1
Offline

Good question about the qr code scan - and yes it is odd, because this works. I tried a wireless and wired connection, but it's alway the same result. No camera - in solo mode and lab. Robot status red, but movement and gimbal works.
Also strange is, that I can't save anything in the lab. And the library is empty. This works only on my iPhone.

"Bad luck" with the windows app here. But it is good to know, that it works for you. I disconnected every wlan repeater, direct connection to the router, eset firewall and av deactivated. I will check everything again, maybe there is something that blocks the connection. It looks like something is blocking the ports - sounds right.




Thanks so far - I will report back :-)
9-4 01:09
Use props
sevreNniarB
lvl.4
Online

Same Problem for me, you will find my post here in the forum. Only solution at the moment is to get the older Windows App in Version 1562232499731-RoboMaster_x64_v1.0.2(260).exe

I can upload it for you, but I need the permission from DJI.

Cheers
9-4 05:56
Use props
Duane Degn
lvl.4
Offline

I'll add a warning about having other WiFi devices connected to your PC while using the app. I had to disable a link to a wireless camera in order to use the app. I think the app also behave a bit better if I made sure I used the wireless connection to my router rather than a wired connection (I'm not sure about this last part, I just recall having some issues myself initially).
9-4 11:02
Use props
MarkusXL
Second Officer
Offline

If troubleshooting reveals a WiFi connection issue, I suggest getting an AC50 Mobile Router from TP-Link.   For $35 (amazon) it is a very handy and capable device.  It possibly resolve this issue by providing a separate, private WiFi that only your PC and your S1 would connect to, while allowing internet access via your home network.

Also note that, if you want to use your S1 at work (on a corporate network) or you want to host a multi-player battle away from any WiFi, you'll need this gizmo.
9-5 09:17
Use props
Robi_DE
lvl.1
Offline

That was a great tip sevreNniarB! I didnt think about that. I uninstalled Version 1.04 and installed 1.02 (RoboMaster_x64_v1.0.2(260)) which I luckly downloaded before I bought the robomaster to consolidate my buying decision.

Everthing works now - movement, gimbal, camera. Even the lab works now. I can see the programs and also my saves in the cloud.

It works for me with windows 10, wireless and wired, with the repeater, with my firewall and av software. I dont know what it is, but I hope, that DJI can fix this in newer versions.

Thanks to all for your help!
9-6 03:32
Use props
sevreNniarB
lvl.4
Online

Robi_DE Posted at 9-6 03:32
That was a great tip sevreNniarB! I didnt think about that. I uninstalled Version 1.04 and installed 1.02 (RoboMaster_x64_v1.0.2(260)) which I luckly downloaded before I bought the robomaster to consolidate my buying decision.

Everthing works now - movement, gimbal, camera. Even the lab works now. I can see the programs and also my saves in the cloud.

You are welcome Downside is that you will be unable to access the advanced features that came with the recent update. Hope DJI will fix this soon.

Cheers
9-6 05:42
Use props
ouro_n
lvl.1
Offline

Can someone please share me the v1.02 file?
I am also having issue with 1.04, camera does not work
9-7 01:37
Use props
rhoude57 - YUL
Second Officer
Offline

MarkusXL Posted at 9-5 09:17
If troubleshooting reveals a WiFi connection issue, I suggest getting an AC50 Mobile Router from TP-Link.   For $35 (amazon) it is a very handy and capable device.  It possibly resolve this issue by providing a separate, private WiFi that only your PC and your S1 would connect to, while allowing internet access via your home network.

Also note that, if you want to use your S1 at work (on a corporate network) or you want to host a multi-player battle away from any WiFi, you'll need this gizmo.

I second the motion.

I also have a TP-Link AC750 mobile router to which I connect my S1s and my smartphone and PC to interact with the S1s.

A very good purchase.
9-7 10:15
Use props
MarkusXL
Second Officer
Offline

If anyone has this issue PM me, I put the original 1562232499731-RoboMaster_x64_v1.0.2(260).exe file in a shareable Dropbox folder.
9-9 07:39
Use props
Stephpar
lvl.1
Offline

Hi MarkusXL,

This is exactly what I’m looking for to (potentially) resolve a windows connection issue. Could you please provide me your Dropbox link at your convenience. Very much appreciated.

Steph
9-9 11:55
Use props
sevreNniarB
lvl.4
Online

rhoude57 - YUL Posted at 9-7 10:15
I second the motion.

I also have a TP-Link AC750 mobile router to which I connect my S1s and my smartphone and PC to interact with the S1s.

Well, in my opinion DJI should fix the problem. The PC software was working in the 1.0.2 version and they broke something with the last update. No need to buy a new router... this would fix the symptom but not the cause.
9-9 12:29
Use props
sevreNniarB
lvl.4
Online

Would be nice if some DJI staff could provide some kind of update regarding this situation (we already have 3 forum threads and I'm sure there are more users out there with the same problem). Will we see an update of the firmware or PC software in the near future?

Cheers
9-19 06:58
Use props
Evan Wang
lvl.1

Offline

Duane Degn Posted at 9-3 06:41
Did you scan the on screen QR code with the robot's camera as part of the connection process?
It's really odd the camera would work to scan the QR code but not after than.
Which sections of the app have you tried? Are you using the "Solo" option? Have you tried "Lab"?

My robomaster s1 doesn’t even connect to to the pc, can someone help me with that
9-29 07:12
Use props
Duane Degn
lvl.4
Offline

Evan Wang Posted at 9-29 07:12
My robomaster s1 doesn’t even connect to to the pc, can someone help me with that

Which version of the app are you using? Apparently version 1.0.2 works better than the latest version.
Here's a Dropbox link to version 1.0.2 of the app.
If you have any other WiFi devices connected to your PC, you might want to try disconnecting these to see if they cause a problem. I think a WiFi camera I have interfered with the app at one point.
9-29 07:39
Use props
RockGoose
lvl.2
Flight distance : 8097 ft
Offline

Duane Degn Posted at 9-29 07:39
Which version of the app are you using? Apparently version 1.0.2 works better than the latest version.
Here's a Dropbox link to version 1.0.2 of the app.
If you have any other WiFi devices connected to your PC, you might want to try disconnecting these to see if they cause a problem. I think a WiFi camera I have interfered with the app at one point.

Thank you !!!
9-30 11:48
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules