Please select Into the mobile phone version | Continue to access the computer ver.
Smart Controller Will Not Connect to my Wifi
894 8 2019-9-19
Uploading and Loding Picture ...(0/1)
o(^-^)o
DroneNewsGuy
lvl.4
  • >>>
Offline

Have reset wifi settings.
Wifi password is 100% correct.
When i select 'connect' the Smart Controller does nothing.
There is no popup or message that says that it tried and failed or anything.
Not acceptable.
PLease advise DJI.
2019-9-19
Use props
DJI Tony
Super Moderator

Offline

Hi, we're sorry for the inconvenience. I would like to clarify if you successfully activated the Smart controller? If so, you may try to perform a factory reset to the Smart controller to see if there will be changes. You may follow the screenshots below for resetting the wi-fi. Thank you for your support.





2019-9-19
Use props
DroneNewsGuy
lvl.4
  • >>>
Offline

DJI Tony Posted at 9-19 10:12
Hi, we're sorry for the inconvenience. I would like to clarify if you successfully activated the Smart controller? If so, you may try to perform a factory reset to the Smart controller to see if there will be changes. You may follow the screenshots below for resetting the wi-fi. Thank you for your support.

[view_image]

This did not work.
There is no reason for the controller to not connect to my wifi.
Network is visible.
Correct password entered.
When I google this problem there are a lot of other users experiencing the same issue I am.
Please resolve.So far I can only get smart controller to connect to internet using the hotspot on my iphone.

2019-9-30
Use props
Keule
Captain
Flight distance : 3454482 ft
  • >>>
Online

DroneNewsGuy Posted at 9-30 17:45
This did not work.
There is no reason for the controller to not connect to my wifi.
Network is visible.

On your WiFi router set the authentication method to Personal WPA and the encryption method to TKIP or TKIP+AES and try again.
2019-9-30
Use props
DJI Tony
Super Moderator

Offline

DroneNewsGuy Posted at 9-30 17:45
This did not work.
There is no reason for the controller to not connect to my wifi.
Network is visible.

Hi, we're sorry for the late response. May I know if it would allow you to have an access to the internet when the Smart controller is connected to the hot spot of the phone? Would it be possible if you could try to change the password of your wi-fi to see if that would help? Please keep us posted on the latest progress. Thank you!
2019-10-3
Use props
DroneNewsGuy
lvl.4
  • >>>
Offline

DJI Tony Posted at 10-3 14:08
Hi, we're sorry for the late response. May I know if it would allow you to have an access to the internet when the Smart controller is connected to the hot spot of the phone? Would it be possible if you could try to change the password of your wi-fi to see if that would help? Please keep us posted on the latest progress. Thank you!

If I remove security on my wifi and make it an 'open' network the smart controller connects fine.
As soon as I change to WPA Personal with a password it will not connect.
2019-10-7
Use props
DJI Tony
Super Moderator

Offline

DroneNewsGuy Posted at 10-7 12:41
If I remove security on my wifi and make it an 'open' network the smart controller connects fine.
As soon as I change to WPA Personal with a password it will not connect.

Hi. we're sorry for the late response. Would it be possible if you could try to use a different internet connection to see if you would get the same behavior? Please let us know for further check. Thank you for your support.
2019-10-19
Use props
Dronie2
First Officer
Flight distance : 1082320 ft
Spain
Online

DroneNewsGuy Posted at 9-30 17:45
This did not work.
There is no reason for the controller to not connect to my wifi.
Network is visible.

Try this...

Settings, More...., Go Share, Set Go Share Hotspot, scroll down to select AP Band choose 2.4GHz band or 5GHz band.
2019-10-19
Use props
Monument.AL
lvl.1
Flight distance : 133182 ft
Australia
Offline

Hi DroneNewsGuy.  I too had this problem.   I had just updated the firmware on my Smart Controller plus had a new router installed when converted over to Australia's National Broadband Network (NBN) this week. I wasn't sure what caused the Wi-Fi connection to no longer work on the Smart Controller.  Tried the above suggestions but none worked (that last one setting the Go SHare Hotspot was a bit left field).  I then went to the MavicPilots forum at https://mavicpilots.com where I get most of my information and discovered a thread that suggested.... Some devices having troubles to connect to WiFi hotspots with authentication set to WPA2 personal encryption AES only.  Change this setting in your WiFi hotspot/router to "WPA personal AES+TKIP"

In my case I changed the Security Mode in my modem from WPA2 PSK to WPA+WPA2 PSK, and then my Smart Controller connected first time.  Try it.  Good Luck.
2-21 01:21
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules