Please select Into the mobile phone version | Continue to access the computer ver.
DJI Fly app not compatible
123456
27052 218 2019-11-13
Uploading and Loding Picture ...(0/1)
o(^-^)o
fans2b21ef70
lvl.1
Flight distance : 5794 ft
United Kingdom
Offline

for it to work with s10+ i downgraded back to 1.0.3 and connected the mavic mini controller first . switching it on and waiting for the prompt to activate the app, now working fine .will now wait for fix
1-4 11:50
Use props
fans2b21ef70
lvl.1
Flight distance : 5794 ft
United Kingdom
Offline

for it to work with s10+ i downgraded back to 1.0.3 and connected the mavic mini controller first . switching it on and waiting for the prompt to activate the app, now working fine .will now wait for fix
1-4 11:51
Use props
fans2b21ef70
lvl.1
Flight distance : 5794 ft
United Kingdom
Offline

for it to work with s10+ i downgraded back to 1.0.3 and connected the mavic mini controller first . switching it on and waiting for the prompt to activate the app, now working fine .will now wait for fix
1-4 11:53
Use props
fans2b21ef70
lvl.1
Flight distance : 5794 ft
United Kingdom
Offline

for it to work with s10+ i downgraded back to 1.0.3 and connected the mavic mini controller first . switching it on and waiting for the prompt to activate the app, now working fine .will now wait for fix
1-4 12:01
Use props
Rychu72
lvl.1

Poland
Offline

I have got message from one guy in Poland that Samsung Xcover 4S work fine with Dji mini. There is Exynos chipset.
Recently I have checked Samsung Galaxy active2 tab with Android 9, 64 bit, 3 Ram with Exynos. It doesnt work.
1-5 08:01
Use props
djiuser_COCNQDPR6DvO
New

India
Offline

I Aalready Bought DJI MAVIC MINI.
But Problem My Device Not SUPPORT DJI FLY APP On SAMSUNG A6 PLUS Because My Mobile Android 9.0 & DJI FLY APP Need Android 10.
So I Have Not Enough Money For Buy A New Flagship Mobile.
I Allredy Thinking About SAMSUNG M20 Where Is Have Now ANDROID 10. So It Will Be SUPPORT In This Device?
Please Reply Urgent.
1-5 14:40
Use props
BorisTheSpider
lvl.1
United States
Offline

You guys are mad that you had no way of knowing ahead of time whether your device would work with DJI Fly. That's infuriating, for sure. In my case, my device (LG G6) is listed as a recommended device and doesn't work right. I have to use a silly workaround to get it to stay connected. I'm hoping upgrading to Android 9 (currently 8) will help, but I don't want to try it only to find out it made it worse or something. I have seen a single report that it does work, but I was hoping for that to be corroborated by at least one other personal experience.

On that note - for anyone listing devices that aren't on the list and either work or don't work, please list which version of Android the device runs. Ideally, try it with different versions. I have a hunch that it matters. Like the LG G6, maybe it works fine on Android 7 and 9, but not 8.
1-5 18:33
Use props
BorisTheSpider
lvl.1
United States
Offline

BorisTheSpider Posted at 1-5 18:33
You guys are mad that you had no way of knowing ahead of time whether your device would work with DJI Fly. That's infuriating, for sure. In my case, my device (LG G6) is listed as a recommended device and doesn't work right. I have to use a silly workaround to get it to stay connected. I'm hoping upgrading to Android 9 (currently 8) will help, but I don't want to try it only to find out it made it worse or something. I have seen a single report that it does work, but I was hoping for that to be corroborated by at least one other personal experience.

On that note - for anyone listing devices that aren't on the list and either work or don't work, please list which version of Android the device runs. Ideally, try it with different versions. I have a hunch that it matters. Like the LG G6, maybe it works fine on Android 7 and 9, but not 8.

Just updated my android. It does seem to be working well with LG G6 on Android 9, while it didn't with Android 8.
1-6 21:02
Use props
Cosmin Popa
lvl.1
Flight distance : 653 ft
Cyprus
Offline

updated DJI Fly on 15th of January
It WORKS on Samsung S10+ running Android10

thank you. Now I can finally use my Mini
1-15 14:49
Use props
djiuser_l9QwFiO9Ui4y
New

Czechia
Offline

Hello droners!
Have anyone encountered problem using DJI Fly app on iPhone 11 Pro Max? All the time I open the app, it automatically turning off the permission I gave it before to use WLAN and Cellular Data. If anyone has experienced the same problems;em on iOS device, how you got it fixed?  I have tried using the app on the latest iPad Pro and iPhone 7 Plus, both updated to the latest version of iPadOS and iOS respectively, and there's no such problem. However the newest iPhone seems not compatible to use DJI Fly app.
1-16 19:52
Use props
RevealingMind
lvl.1

Australia
Offline

Ive come up with what i reckon is the best and cheapest workaround for the app compatibility issue, i bought a second hand iPad Mini 2 running IOS 12.4.4

1-18 23:24
Use props
djiuser_UIQEvtpssTVV
New
United States
Offline

Tim Twerp Posted at 2019-11-23 09:35
Really?  You Buy a $500 toy drone and  still have a cheap android phone?  Yes, third party apps will catch the wave and be available, but invest a little in a new or second phone for your drones!  Do you still use 32 bit for your computers?  if you want your equipment to support the future, expect the software to be current and up-gradable... not down gradable.  Go ahead and hate this message, but buy a $500 dollar toy drone and then complain that they expect you to have current technology in your phone... return it and get your money back.  Buy a tello.

The problem is "Reading is fundamental", the issue is not 32 or 64bit OS's.  The problem many people have stated is DJI's only requirement is an android OS of 6 or higher.
1-26 10:56
Use props
djiuser_7RpssnecsLkP
lvl.1

Canada
Offline

Anyone install DJI FLy on Vankyo MatrixPad Z4 it run a  64 bit Quad-core processor 1.5GHz, 2gigs of ram, Native and latest Android OS - Android 9 Pie. Someone can tell me if the DJI FLY will run on the describe tablet?

Thank you for your time
1-26 15:03
Use props
Arcmanov
lvl.2
Trinidad and Tobago
Offline

Works on the Samsung Galaxy A50.
1-26 19:18
Use props
djiuser_ECCh74iJ1DUX
New

United Kingdom
Offline

First drone purchase and first time I've bought anything from DJI.

Not impressed as I just seem to have bought an expensive paper weight. My phone is a Motorola G7 Power (Android 9 64 bit) . No trouble downloading the app and all seems fine except the first time I come to use it the RC says that it needs to calibrate something, which I do. However gets to 95% completed and then stops. Nothing further happens. DJI support says because my phone isn't on their recommended list there is nothing they can do.

Will be making sure I let everyone I can know about this problem and advice them not to buy DJI.
1-29 09:11
Use props
eruby
lvl.2

United States
Offline

djiuser_UIQEvtpssTVV Posted at 1-26 10:56
The problem is "Reading is fundamental", the issue is not 32 or 64bit OS's.  The problem many people have stated is DJI's only requirement is an android OS of 6 or higher.

I have a Samsung Galaxy A10e. Below are the specs for my phone but DJI Fly is still not supported on my device. No my phone is not on the list but it does have Android 9 and 64 bit processor.

Android 9.0 (Pie)
Exynos 7884
Process 14nm FinFET
Multi-core Octa
CPU (Primary) Cortex®-A73 1.6GHz Dual
CPU (Secondary) Cortex®-A53 1.6GHz Hexa
GPU Mali™-G71 MP2
Video FHD 60fps encoding and decoding
Codec HEVC (H.265), H.264 and VP8, VP9 (decoding)
Display WUXGA (1920x1200), Full HD+ (2220x1080)
Camera (Rear) 21.7MP
Camera (Front) 21.7MP
Camera (Dual) 16MP+16MP
Modem LTE Cat.12 3CA 600Mbps (DL) / Cat.13 2CA 150Mbps (UL)
Connectivity GNSS
Storage eMMC 5.1, SD 3.0
Memory LPDDR4
Application Smartphone, Tablet

The ARM Cortex-A73 is a microarchitecture implementing the ARMv8-A 64-bit instruction set designed by ARM Holdings' Sophia design centre.
1-29 12:32
Use props
Visualweddings
lvl.1
Flight distance : 9160 ft
Serbia
Offline

Hello everyone. Today I got my first dron, Mavic Mini. Not tested yet, because my phone is old and I need a new one just to fly this drone. So I`m thinking about some cheap Android like Nokia 4.2 or maybe Xiaomi Redmi Note 8 Pro. Does anyone use these phones to fly Mavic Mini?
Thank you all.
1-30 10:20
Use props
Droneyal8r
lvl.1

Australia
Offline

Tim Twerp Posted at 2019-11-23 09:35
Really?  You Buy a $500 toy drone and  still have a cheap android phone?  Yes, third party apps will catch the wave and be available, but invest a little in a new or second phone for your drones!  Do you still use 32 bit for your computers?  if you want your equipment to support the future, expect the software to be current and up-gradable... not down gradable.  Go ahead and hate this message, but buy a $500 dollar toy drone and then complain that they expect you to have current technology in your phone... return it and get your money back.  Buy a tello.

i wouldn't consider it a toy
1-31 05:09
Use props
timoat
lvl.1

Sweden
Offline

Lolik12345 Posted at 2019-11-21 11:42
I'm facing same issue with mavic mini that purchased today . Can't download at all the fly app.
And if I managed to download it's can't be install.
Never fougt that the mavic mini forcing user to by more expensive phone or tablet.

I too have a note 4, what the hell? I just ordered the mini, and now i find out it wont work?
2-2 08:58
Use props
123456
Advanced
You need to log in before you can reply Login | Register now

Credit Rules