Please select Into the mobile phone version | Continue to access the computer ver.
Unable to connect Smart Controller with DJI Assistant 2 for Mavic
Uploading and Loding Picture ...(0/1)
o(^-^)o
Gary Blake
lvl.1

Canada
Offline

PC with Windows 7/64 Ultimate fully updated, 32GB Ram, Intel i7 2.4ghz, no computer issues with updating firmware on at least 6 other devices via USB.  
New DJI Mavic 2 Pro with Smart Controller January 4, 2020.
  
1) Downloaded and installed DJI Assistant 2 for Mavic, latest version, connected and updated the Mavic   2 Pro to latest firmware no issues.

2) Could not connect Smart Controller with DJI Assistant 2 for Mavic via USB, finally connected after multiple attempts, the download failed about 7-8 times and then finally installed. The firmware was unfortunately flawed in that parts were not translated from Chinese. (I have the v01.00.0650 with PAD V00.00.09.80 release keys line) It appears DJI pulled the firmware update down and quickly issued a fixed update with the same version number but with PAD V00.00.09.84 release keys.

3)  After this update the Smart Controller will no longer connect after hours of trying in order to refresh the firmware.

4) Have tried all the possible solutions I could find on this forum and others with no luck including:
  
a) Factory reset (does not reset to the originally installed version 01.00.0530?, saves all other settings as well, so no sure what a factory reset even does…..)
  
b) Uninstall and re-install DJI Assistant 2 for Mavic 3X
  
c) Manually install DJI drivers.
  
d) Enable developer options and manually select MTP file transfer USB setting, with USB debugging on and off.
  
e) Logging out of DJI Assistant 2 for Mavic, then logging back in.
  
f) Wifi and Wlan say I have the current version and will not connect to refresh.
  
g) Tried a couple of different USB C cables. No luck.
  
h) Tried on my son’s Macbook – no connection there either.
  
i) When connected the Smart Controller shows up in my computer as rm500, Portable Media Player, and in Device Manager under portable devices as rm500 with no exclamation marks, status: This device is working properly. Driver details C:\Windows\system32\DRIVERS\winUSB.sys (others listed but I believe this is the critical one)
So Windows is seeing the smart controller on USB and I can access the folders on the internal storage and SD card. DJI Assistant 2 for Mavic is working fine for the Mavic 2 Pro aircraft.
  
I think my Smart Controller is toasted, any other suggestions before I send the whole lot back?

Called DJI support and said I was having issues with my Smart Controller - tech asked what mobile device I was using with my M2Pro - it got even worse after that......
  
1-14 16:54
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules