Please select Into the mobile phone version | Continue to access the computer ver.
Latest Assistant 2 not compatible with OSX 10.15.1
215 6 1-15 06:50
Uploading and Loding Picture ...(0/1)
o(^-^)o
CineView Media
First Officer
Flight distance : 4108484 ft
  • >>>
Norway
Offline

Will there be a fix?
Tried updating directly from SC, but after finishing, it detects the new version and asks again for update.
1-15 06:50
Use props
DJI Gamora
Super Moderator

Offline

Hi, thank you for reaching out and we do apologize for the inconvenience. Can you please send us a screenshot showing the exact error message for us to help you further? Please keep us posted. Thank you!
1-15 08:01
Use props
CineView Media
First Officer
Flight distance : 4108484 ft
  • >>>
Norway
Offline

DJI Gamora Posted at 1-15 08:01
Hi, thank you for reaching out and we do apologize for the inconvenience. Can you please send us a screenshot showing the exact error message for us to help you further? Please keep us posted. Thank you!

There is no error message, it just keeps asking if i want to update to the latest version after running and finishing the update directly on the controller.
Assistant 2 wont detect the controller on the latest OSX, probably due to the incompatible version of Horndis Kernel app.

1-15 09:24
Use props
CineView Media
First Officer
Flight distance : 4108484 ft
  • >>>
Norway
Offline

CineView Media Posted at 1-15 09:24
There is no error message, it just keeps asking if i want to update to the latest version after running and finishing the update directly on the controller.
Assistant 2 wont detect the controller on the latest OSX, probably due to the incompatible version of Horndis Kernel app.

So how do i update the controller?
Ive been retrying straight from the controller 15-20 times now, it still ask me if i want to update to the latest version.
1-15 13:49
Use props
Dronie2
First Officer
Flight distance : 1056955 ft
Spain
Offline

DJI Assistant V2.0.10 is fully compatible with MacOS Catalina 10.15.2
1-16 04:08
Use props
Indio
First Officer
Flight distance : 56322 ft
  • >>>
Austria
Offline

and you dont need to install HoRNDIS

DJI assistant 2 does not work on USB-C
use an apple USB-C to USB-A adapter
1-17 09:23
Use props
DJI Gamora
Super Moderator

Offline

CineView Media Posted at 1-15 09:24
There is no error message, it just keeps asking if i want to update to the latest version after running and finishing the update directly on the controller.
Assistant 2 wont detect the controller on the latest OSX, probably due to the incompatible version of Horndis Kernel app.

Hi, sorry for the late response. If a warning stating that the HoRNDIS driver is not compatible with the macOS system when installing DJI Assistant 2 appears, exit the driver installation, and then download the driver installation package separately from the link below. Unzip the file and double-click the PKG file to install it. After a successful installation, it can be used normally. Please keep us posted on the latest update. Thank you for your understanding.


https://github.com/jwise/HoRNDIS ... ina_install.pkg.zip
1-17 12:50
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules