Please select Into the mobile phone version | Continue to access the computer ver.
Vision App on Nexus 7
6313 31 2014-11-21
Uploading and Loding Picture ...(0/1)
o(^-^)o
cslogue
lvl.1

United States
Offline

Hello all,

I have been using the Phantom 2 Vision+ with a Nexus 7 tablet with great results. Got a system udate for the tablet, ran the upgrade  and now have Android 5.0. DJI Vision will start and I can see the video link to the camera with the Phantom at idle. When I begin to take off the app closes.

I have a Samsung S4 and the Vision App still works fine.

Anyone else using a Nexus 7 with the newest operating sytem? Any Problems?

Thanks
2014-11-21
Use props
DJI-Autumn
First Officer

China
Offline

Hi,

U can reset and restart the Extender, bind it to ur P2V+ again, then connect the camera with DJI VISION App.
If still not work, maybe something wrong with the Extender.
2014-11-23
Use props
Gerry1124
Captain

United States
Offline

I'm running an Apple ipad 9.7 inch screen.  I had to upgrade my IOS on the ipad to 6.1.  Can you upgrade any higher than 5.0?
2014-11-23
Use props
cslogue
lvl.1

United States
Offline

Autumn, I tried resetting the extender and rebinding but the app still closes on takeoff. Like I mentioned, it works fine on the Samsung S4.

Gerry, Android 5.0 is the most current operating system, or so the tablet tells me.

Thanks for the help
2014-11-24
Use props
marcel.goergens
lvl.1

Germany
Offline

cslogue@gmail.c Posted at 2014-11-24 22:42
Autumn, I tried resetting the extender and rebinding but the app still closes on takeoff. Like I men ...

Hello,

I have the same issue on my nexus 4 mobile!
If i turn on the motors, the app closes immediately!  If I turn them off again, I can launch the app and see the camera picture again.
Turning on the motors again, results in an immediate closing of the app. If i try to restart the app when the motors are on, it closes directly after i launched it.

Further to that:
Since i´ve upgraded to Android 5 lollipop,  connecting the WLAN to the range extender sometimes fails. This never happend with the same device and android 4.4.4. But that´s just a minor issue i could live with.

Conclusion: The app is unusable with Nexus 4 and probably with Nexus 7 devices and android 5.0 Lollipop!

@DJI: This is obviously a bug! I´m willing to help in resolving it. if there is anything i can do on my end (collecting trace files, etc..) please drop me a line.

Thanks,
Marcel
2014-11-26
Use props
DJI-Autumn;-)
First Officer

China
Offline

@marcel.goergens @cslogue
Have you updated firmware to newest version?
Did you take video before take off?
2014-11-26
Use props
marcel.goergens
lvl.1

Germany
Offline

DJI-Autumn;-) Posted at 2014-11-27 09:45
@marcel.goergens @cslogue
Have you updated firmware to newest version?
Did you take video before tak ...

hello,

yes---I´m using the latest FW on Phantom2 (3.08) and the Vision app has also the latest version (1.0.54).
I did not take a photo before I turned on the propellers also I did not switched on recording.

BR,
Marcel  
2014-11-27
Use props
DJI-Autumn;-)
First Officer

China
Offline

marcel.goergens Posted at 2014-11-27 19:34
hello,

yes---I´m using the latest FW on Phantom2 (3.08) and the Vision app has also the latest v ...

It could be a compatibility problem of Android 5.0
Seems you have to use Andriod 4.4.4 device until they improve it.
Any one using Android 5.0 can run the App successfully????
2014-11-27
Use props
marcel.goergens
lvl.1

Germany
Offline

DJI-Autumn;-) Posted at 2014-11-28 10:29
It could be a compatibility problem of Android 5.0
Seems you have to use Andriod 4.4.4 device un ...

Hello,

yes...It is definitely a compatibility issue as the app was working with the same device and Android 4.4.X! I already raised a support call on Monday with DJI Europe, but no response up to now...
As nexus devices are the official Google smartphones i wonder why it´s not working.
I know that other vendors like HTC,LG or Samsung are working on an Android 5 release for their devices, but as soon as those releases are wide spread, DJI will have a bigger issue!

So is there anyone out here who has the same issues like a crashing app when powering on the propellers since an update to Andorid 5 was made???

Cheers,
Marcel

2014-11-28
Use props
johnkilcline
lvl.4

Portugal
Offline

marcel.goergens Posted at 2014-11-28 20:57
Hello,

yes...It is definitely a compatibility issue as the app was working with the same device a ...

Ok just tried to reproduce your problem, except I had no props connected, otherwise
Vision 2+,
nexus 7 (2013),
Android 5,
App 1.0.54 ,
one think to note is I upgraded the central board firmware this morning
to 1.0.2.10 (new upgrade today on DJI website)

I "flew" the quad round the house with my hands and recorded  a couple of minutes of video, NO PROBLEMS at all
UPDATE

Been out to my flying field, performed immaculately, even went up to 600 feet no dropouts, do 28th November 2014 firmware upgrade!
2014-11-28
Use props
tobias.westerbl
New

Sweden
Offline

On my Nexus 5 with Android 5 the drone isn't recognized by the app even if the wifi is connected to it.

To get the app to see the drone I need to turn off mobile data.

On my Nexus 7, Android 5 the DJI VISION app is marked as incompatible with the device and won't even show up in play store if I search for it.

I'm sure it is a compatibility issue with Android 5.
2014-11-29
Use props
jamesnns
lvl.4

United States
Offline

The new lollipop 5.0 is horrible.  Android needs to fix it fast. My Nex. 7 is almost bricked after the update.
It has nothing to do with DJI or any other App.  Even Facebook with its billions in resources force closes on Lollipoop. (Pun intended)
Not much to do imo other than wait for Android to fix it
2014-11-29
Use props
marcel.goergens
lvl.1

Germany
Offline

johnkilcline@gm Posted at 2014-11-28 23:30
Ok just tried to reproduce your problem, except I had no props connected, otherwise
Vision 2+,
ne ...

Hello John,

thanks for the hint!

I did the upgrade to the latest fw update but it´s still the same behavior with my Nexus 4 device...
I downgraded it to android 4.4.4 and now it´s working again.
I´ve decided to wait until a stable version of the Vision app will be released which works with android 5.

Again..Thanks for your investigation!

Cheers,
Marcel
2014-11-30
Use props
cslogue
lvl.1

United States
Offline

Hello everyone,

Just did as Marcel (upgraded firmware to latest version) and had the same problem. Unlike John my Nexus 7 is the 2012 version so maybe that is the difference in why his works and mine doesn't. Who knows.

App is still force closing when starting motors. I definitely think it is an Android 5.0 issue. Just glad it still works on the S4

Thank you all for the help
2014-12-1
Use props
cslogue
lvl.1

United States
Offline

I just rolled my Nexus 7 (2012) back to Android 4.4 and everything works fine.
2014-12-3
Use props
slabastrou
New

Canada
Offline

I have the same problem on Nexus 10 (5.0.1) and Nessus 5 (5.0). I believe it is related to android trying to use Mobile Data instead of wifi when internet is not reachable.  The trick (according to forums) is either to "accept the network as is"  or use airplane mode and activate Wifi. I am not finished troubleshooting and will continue tonight with my old Nessus 4 (4.0.4) and compare all the behavior.
2014-12-11
Use props
johnkilcline
lvl.4

Portugal
Offline

jamesnns@gmail. Posted at 2014-11-29 23:45
The new lollipop 5.0 is horrible.  Android needs to fix it fast. My Nex. 7 is almost bricked after t ...

They (Android) have released the upgrade to 5.0.1, perhaps this is what you have been waiting for?
2014-12-11
Use props
rperkins
New

United States
Offline

marcel.goergens Posted at 2014-11-26 23:38
Hello,

I have the same issue on my nexus 4 mobile!

I have the very same issue.  Nexus 4, Lollipop 5.0.   I Just got the notification and upgraded to 5.01; no joy.  I uninstalled/reinstalled vision app.   No good.   I also cannot get Ground Station to come up.  Swiping left in camera causes app to crash and return to selection screen.   I have map cached locally.
2014-12-18
Use props
cheong
lvl.4
Flight distance : 2778799 ft
  • >>>
Singapore
Offline

cslogue@gmail.c Posted at 2014-12-3 22:22
I just rolled my Nexus 7 (2012) back to Android 4.4 and everything works fine.

Hi I am also thinking of getting a Nexus 7 (2012) 8 8GB for the FPV, do you experience any lag in video ? and what is your video display ? 640 ? 320 ?

appreciate your reply
2014-12-19
Use props
tonydunn
lvl.1

United States
Offline

cheong Posted at 2014-12-19 17:14
Hi I am also thinking of getting a Nexus 7 (2012) 8 8GB for the FPV, do you experience any lag in  ...

Hi Guys
I have the same problem with Nexus-4 ver 5.01
Upgraded the Phantom 2 Vision+ to the latest firmware from DJI no fix.
3.04; 6.0.1.4; 1.0.1.3; 2.0.0.0; app is at 1.0.54; camera 1.1.9 and Naza-m at 3.08
Either I will have to roll back 5.0.1 or wait for a fix from Android.
2014-12-30
Use props
tonyphantom147
lvl.4

United Kingdom
Offline

tonydunn@pacbel Posted at 2014-12-30 16:10
Hi Guys
I have the same problem with Nexus-4 ver 5.01
Upgraded the Phantom 2 Vision+ to the latest ...

I took my nexus back for refund because of this lollipop upgrade.
2014-12-30
Use props
wouterkcs
lvl.2
United States
Offline

tonyphantom147@ Posted at 2014-12-30 17:47
I took my nexus back for refund because of this lollipop upgrade.

Hi -- My NEXUS 7 2012 updated last night to Lollipop 5.02.

I have the same issues --:
1) bad connection to Phantom  when I connected.\ (poor WI-FI connection)
2) Disconnects when I start the props

Even with 2.4.4 things worked, but NEXUS 7 2012 had a hard time keeping connection and slow download speeds. Maybe  DJI knows that there are issues with NEXUS 7 as it doesn't download the APP from Google Play. I had to install by downloading the app from DJI website, and install it manually.

I have NO such issues with Note 2 on 4.4.2.

Hope DJI will reply to this POST :

1) Support for Nexus 7 in general
2) Specifically with Lollipop 5.02

Samsung will update S5 and Note 4 (any moment I hear) to Lollipop. Many DJI users will have  MAJOR issues then!!!!

DJI -- please ACT before many Vision users will loose their drones!

Thank you,
2015-1-18
Use props
cathalspot.emai
lvl.2

Ireland
Offline

wouterkcs@gmail Posted at 2015-1-19 03:21
Hi -- My NEXUS 7 2012 updated last night to Lollipop 5.02.

I have the same issues --:

Hi guys,
I hope you can help cause now I am even more confused.
Just got my pv2+, was using with samsung s4 a few minor glitches but overall great.  
I no longer have that phone and am about to get a new one (Ireland) want to fly fpv and using groundstation.
Was considering a samsung note 4 but can't find anything on it regarding its use with the phantom and don't know if it will work and it's a bit pricy.
So I was considering getting a dedicated nexas 7 second gen, but after reding all the comments I am unsure. I like the idea of the bigger screen for setting coordinates and fpv.
iPad are very expensive here so any ideas please no desire for an electronic paperweight or incompatibility leading to a fly away.

Thanx in advance
2015-1-19
Use props
Gerry1124
Captain

United States
Offline

cslogue

Gerry, Android 5.0 is the most current operating system, or so the tablet tells me.



http://www.ebay.com/itm/Apple-iP ... cvip=true&rt=nc

As you can see in the photo,  version IOS 8.1
apple tablet IOS 8.1.jpg
2015-1-19
Use props
kenargo
First Officer
  • >>>
United States
Offline

Shameless plug for a new Android app I am creating; 1st version is in beta and if you would like to try in on Lollipop (Android 5) have a go; I'm waiting to hear back but initial tests have suggested that it doesn't suffer from the crash seen on some 5.0 devices.

http://www.kenargo.com/AndroidApps/UltimateFlight
2015-1-19
Use props
limmer20
New

United Kingdom
Offline

kenargo Posted at 2015-1-20 09:19
Shameless plug for a new Android app I am creating; 1st version is in beta and if you would like to  ...

Hi having same probs on nexus 4 since upgrading,app still works on wife's android with kit Kat and on latest Apple ver 8. Have downloaded your new beta app "hoping" BUT no luck as soon as engines are powered up app shuts down ! Very frustrating.hope DJI are listening. Tried local UK DJI APPOINTED conduit , pleasant reply but suggested it was a fault in the updated android app. (Basically stating the * obvious) . Very willing to try any further updates you are working on and will report back. Good luck.
2015-1-20
Use props
kenargo
First Officer
  • >>>
United States
Offline

limmer20 Posted at 2015-1-20 21:56
Hi having same probs on nexus 4 since upgrading,app still works on wife's android with kit Kat and ...

The issue has been raised to DJI; there is a new drop of the SDK, I've been told it will be Feb/Mar and hopefully this issue is fixed in that release.
2015-1-20
Use props
BWJ
Second Officer

Denmark
Offline

My Nexus 7 runs Android version 5.0.2 problems with app., it came 06-01-2015
2015-1-20
Use props
adrianmizzi1983
lvl.3

Malta
Offline

I have Nexus 7 (2012) with 5.0.2 and it shuts down.   What are my options?

Roll back?
New Device?
New app?
Or just wait for an app or android update?
2015-2-5
Use props
jf.mourron.free
New

France
Offline

Sure it's an incompatibility between the app and android Lollipop. I've updated my HTC a M8 with Lollipop and I've the crash now when rotors start running.
2015-2-13
Use props
adrianmizzi1983
lvl.3

Malta
Offline

I have used the app of Nexus 2013 with Lollipop 5.0.2 and it worked fine.  Im not sure what the difference is between by 2012 and my 2013 running same version of Android?!?
2015-2-13
Use props
martinmarty
New

United States
Offline

I see in the release note http://download.dji-innovations. ... elease_Notes_en.pdf that there was a fix for Android 5.0.1 on Feb. 13. I have a Nexus 7 (2012) running Android 5.0.2. Can anyone confirm whether this device will work with Phantom Vision 2+ v3? I have not bought one yet but am considering. THANK YOU.

@adrianmizz1983i: I see your post was dated 2-13-15 which is the same date of the release note I am referring to. Were you already on the latest app update with your Nexus 7 2012? Thanks again for any info because that is the device I would like to use.
2015-2-24
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules