Please select Into the mobile phone version | Continue to access the computer ver.
USB connection options keep changing (Android)
332 2 2020-10-26
Uploading and Loding Picture ...(0/1)
Second Officer
Flight distance : 889688 ft
  • >>>
United Kingdom

Has anyone using Android devices come across this one, when I start my controller and connect my phone I always get asked what the USB status should be pictures 1 & 2, I've always assumed it to be transfer files so it will communicate with the controller.
Once I've made the selection then the App option page comes up to select which app I'll be using for my task.
At this stage it's all normal and the app would open and show either the aircraft select page or search for updates, however now it repeats the request of which app I wish to use (while I'm already in one) sometimes other apps will try to ask permissons etc.. I cleared all of these requests and closed the app I was in and checked what the USB status was, that's when I notice it keeps going back to charging only. It's not the phone or an Android issue as I can connect to 2 differnt PCs (laptops) and download images etc, but it does this with 3 of my DJI controllers.

Mavic Air
Phantom 4 standard
Phantom 4 Pro v.2

This is a bit of an emergentcy as I did a firmware update 2 nights ago before I realized what was coursing the connection issues so now the controller won't connect to the Phantom 4 Pro v.2 as it keep popping up half way though the update terminating the update every now and then, it did finish but I don't think it updated properly.

Use props
DJI Paladin
Super Moderator
Flight distance : 318 ft


Hello Inferno-Videos, thank you for reaching us out and my apologies this has caused you. Regarding your concern about connecting the remote controller to your mobile device that asks if what action you are going to select every time you connect it, may I ask if what is the model of your mobile device and would you be able to tell me if there is a recent software update with your mobile device?

Have you also tried to select "Always" under the picture 2 to keep the setting save.

Meanwhile for the updating firmware issue. You can update the firmware for the Phantom 4 Pro v.2.0 manually using the DJI Assistant 2. Kindly follow the steps below.
1. Download the DJI Assistant 2 from the official website of DJI. You can refer to this link to download the DJI Assistan2 for your Phantom 4 Pro v.2.0 ( ... t-dji-2-for-phantom) select the corresponding file format depending on your computer Operating system.2. Install and Launch DJI Assistant 2.
3. Power on your Aircraft and connect it to the computer using a USB cable.
4. Enter and Login your account in DJI Assistant 2 and select Phantom 4 pro V2.0.
5. Firmware list will showed up and select "Upgrade" if it requires a new update or select "Refresh" if the firmware is updated and refresh to fix the issue.
6. During the update do not turn off the Aircraft or exit/remove the USB cable. Wait until it successfully completed the update/refresh and the Aircraft will turn off automatically.
7. You will need to do same process with the Remote Controller.

You can also check out the video below on how to update/refresh the firmware using the DJI Assistant 2
Please keep us posted so that we can further assist you. Thank you.

Use props
Second Officer
Flight distance : 889688 ft
  • >>>
United Kingdom

Okay thank you for trying to help but I'm no further forward at the moment. I've used the DJI Assistant tool, first I checked the aircraft (namely  P4P V2) and as soon as connected the assistant tells me the firmware and device don't match even though on the latest version, so I let it do it's thing and then did the same with the controller, no issues detected on the controller but I refreshed the update anyway.

Once outside it would connect to the app as normol but kept going grey and saying "aircraft disconnected" and if I try to open DJI PILOT and start a mission it would re-launch DJI GO 4, if I try swiping back it would just relaunch again. I'm basically not in control of anything, and because it wouldn't stop asking silly questions like which app to use neither is the device in control.

I then went back inside and tried both downgrading the software and even doing a factory reset, neither had any effect, the obvious thing would be to say it's the Andriod device however I can use my Phantom 4 standard perfectly okay and even got my Mavic Air working too (Mavic Air now has a "weak signal message" instead which I think is a different problem) and I've tried a second phone. The phones I'm using are primarily the Huawei P20Pro and secondly Motorola G4. I don't currently have access to an apple device.

There was a clitch while I was doing the update to the controller (ie had an issue with the usb connection) so I'm wondering if the problem is which the comms board in the controller itself? Could it be it's not talking to the device properly and loosing connection to the aircraft in the process?
Use props
You need to log in before you can reply Login | Register now

Credit Rules