Please select Into the mobile phone version | Continue to access the computer ver.
Control stick movement recognized on ground system but not on air system.
1625 5 2014-11-23
Uploading and Loding Picture ...(0/1)
o(^-^)o
hhackbarth
lvl.2
Flight distance : 375761 ft
Germany
Offline

Hi,
I am trying to get my new Lightbridge working with Wookong M and "Taranis X9D pus" radio control. After unpacking, all components were updated to latest firmware releases.

First, what is already working :
   
  • Ground- and air aystem connect to each other, HDMI-vdeo and OSD (telemetry) is transmitted to ground system and displayed successfully on Android smartphone (connected via USB). Both LEDs on air system are green.
  • On the smartphone app, video downlink shows about 92% signal strength and remote control link shows about 98%
  • Taranis radio control is connected with cable (red plug on the RC) to trainer port bus, RC trainer mode configuration is set to "slave" and RF module is switched off. Air system D-bus cable is connected to X2 port of Wookong M flight controller. When RC is switched on, the warning "Control signal lost" dsappears from smartphone display.
  • When I connect Lightbridge Assistent via USB cable to ground system, I can see in the channel display the movement of the RC control sticks for the first 4 channels (A/E/T/R).

Now, what is not working so far :
   
  • When I connect the Lightbridge Assistent via USB to the Air System, the channel indicators do not show any reaction to movements of the controller sticks on the RC.
  • Perhaps needless to say that the Wookong M Assistent connected to the USB port of the flight controllor does not show any reaction to the controller stick movement as well. Neither with setting to D-Bus, nor with setting to receiver type " PPM ".

Any idea what is missing or going wrong?

2014-11-23
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

You will not see movement when the air unit is connected to the LB assistant.
Is the control LED green? Did you reboot the wkm after you switched it to dbus?
2014-11-23
Use props
hhackbarth
lvl.2
Flight distance : 375761 ft
Germany
Offline

Thank you for your quick reply. OK, so the LB assistant should disable channel tab when connected to the air system.

Yes, the WKM was rebooted after switching to D-Bus.

I think, I will have to go a bit deeper into Taranis channel mixer configuration and return to this thread with a solution or further questions later...
2014-11-25
Use props
Blade_Strike
Super Moderator
Flight distance : 872694 ft
  • >>>
United States
Offline

Make sure you calibrate all channels in the lightbridge assistant.
2014-11-26
Use props
DJI-Julain
lvl.3

China
Offline

hhackbarth@goog Posted at 2014-11-26 06:27
Thank you for your quick reply. OK, so the LB assistant should disable channel tab when connected to ...

Check your setting on LB and RC.
Make sure reboot your drone and device every time after you change the setting.
2014-11-26
Use props
hhackbarth
lvl.2
Flight distance : 375761 ft
Germany
Offline

Thanks for your help. It was just an issue with the channel and mixer configuration on the Taranis. Now everything works perfect.

In total I can control now 16 channels on the air system's D-bus.
2015-1-1
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules