Please select Into the mobile phone version | Continue to access the computer ver.
System Sensor error, GPS error
3172 37 3-13 15:57
Uploading and Loding Picture ...(0/1)
o(^-^)o
zombiepilot
lvl.1
United States
Offline

I just got my FPV drone in the mail and after setting it all up I took it out for a first flight and everything went fine. came home to charge all the batteries and when I turned everything on again I got a "System Sensor Error" and a "GPS Error." I tried restarting the drone but i still get the messages. anyone else have this issue or know how to fix it?
3-13 15:57
Use props
djiuser_ozlN8F6G55ID
lvl.2
Flight distance : 48445 ft
Canada
Offline

Same thing happening here - I've re-run calibration and refreshed the drone firmware - still happens
3-13 18:34
Use props
supernicko
lvl.1
Flight distance : 203002 ft
Australia
Offline

Me too same errors sensor and gps and when looking in goggles I get 0 satellite connections- I’ll look under the plastic dome see if I can find any loose ribbons or plugs
3-14 00:08
Use props
tomekyo
Second Officer
Flight distance : 3032835 ft
Netherlands
Offline

supernicko Posted at 3-14 00:08
Me too same errors sensor and gps and when looking in goggles I get 0 satellite connections- I’ll look under the plastic dome see if I can find any loose ribbons or plugs

fellows, you are outside correct? Because if you are not you might try to give it a go there, where the satellites are - outside ...
3-14 00:28
Use props
djiuser_ozlN8F6G55ID
lvl.2
Flight distance : 48445 ft
Canada
Offline

supernicko Posted at 3-14 00:08
Me too same errors sensor and gps and when looking in goggles I get 0 satellite connections- I’ll look under the plastic dome see if I can find any loose ribbons or plugs

anything? check the top board over with usb microscope or macro shot... didn't see anything unusual for mine or the side boards.
3-14 14:13
Use props
supernicko
lvl.1
Flight distance : 203002 ft
Australia
Offline

Can’t see any bad connections tried recalibration imu and compass in drone worked fine- camera works - dji assistant 2 recalibrate sensor works as does refresh firmware - just not connecting the gps and sensor I assume gps is the top chip with the fpv sticker on it - and white black cable runs down left and right side towards the sensor array seems to be the connection tot the top rear coax mini plugs maybe antenna maybe sensors not sure - got me beat I can’t be bothered sending in I wanna play more I even painted go fast gt stripes on her !
1565C1BF-4227-49EF-9968-2D31779DBD3C.jpeg
7A0BD785-9852-474C-8098-06C3D4FAB619.jpeg
83E5E4B5-239A-496D-A458-61075080F3F3.jpeg
B6B3F208-3782-41DF-BB5E-9A03A5C83FFA.jpeg
3-14 17:23
Use props
djiuser_ozlN8F6G55ID
lvl.2
Flight distance : 48445 ft
Canada
Offline

Went through all the same troubleshooting steps with support, ended up getting it exchanged via reseller. hope the next one doesn’t hit any issues
3-15 19:10
Use props
supernicko
lvl.1
Flight distance : 203002 ft
Australia
Offline

djiuser_ozlN8F6G55ID Posted at 3-15 19:10
Went through all the same troubleshooting steps with support, ended up getting it exchanged via reseller. hope the next one doesn’t hit any issues

Hey there - any chance you have any logs or copies of your conversations - looks like im going to have to try the same and im sure it will help if i show it has been previously an issue and fixed with an exchange...
Anyone else feel free to post the same it would be pretty awesome if you could - ill keep it updated with my info see if it can help others... supernicko@bigpond.com
3-16 16:48
Use props
zombiepilot
lvl.1
United States
Offline

Same here. Contacted DJI and they are setting me up with a replacement.
3-17 09:08
Use props
djiuser_ng2bL6c0dGWx
New

Germany
Offline

same ... the pic is home bute the same sh... outside
3-17 11:03
Use props
djiuser_ozlN8F6G55ID
lvl.2
Flight distance : 48445 ft
Canada
Offline

supernicko Posted at 3-16 16:48
Hey there - any chance you have any logs or copies of your conversations - looks like im going to have to try the same and im sure it will help if i show it has been previously an issue and fixed with an exchange...
Anyone else feel free to post the same it would be pretty awesome if you could - ill keep it updated with my info see if it can help others...

Phone convo but basicaly confirming I exhausted the troubleshooting and calibration steps.. try it in a few different areas, inside, outside, reset everything, refresh firmware, IMU and compass calibration, goggles and controllers work with sim.. camera on drone works.. drone won't take off with error messages and RED N....
3-17 12:17
Use props
djiuser_IwJVjwGfOVdy
lvl.1
Flight distance : 1191388 ft
United States
Offline

I only got this after replacing the dome to green one. Bought mine no issues now I changed dome and this crap. Changing back to the clear I'll keep posted.
3-21 16:14
Use props
djiuser_IwJVjwGfOVdy
lvl.1
Flight distance : 1191388 ft
United States
Offline

djiuser_IwJVjwGfOVdy Posted at 3-21 16:14
I only got this after replacing the dome to green one. Bought mine no issues now I changed dome and this crap. Changing back to the clear I'll keep posted.

Nope still getting same error...
3-21 17:05
Use props
szacs93
lvl.4
Flight distance : 4143743 ft
  • >>>
Hungary
Offline

Hello All!

Let me tell you you are lucky this happend for you while you were on the ground. On 21st mine got lost with the last message "Sensor system error" over a lake.
Yesterday I raised a ticket with the support. I hope I will get a new one...

The story in short: I was flying in manual mode and then the image transmission signal was weak (I think it tried to switch to normal mode and come back). But it was gone.
I think in manual mode the sensors are not being actively monitored only if you switch back to normal or sport mode. (There were noo errors on the Goggles before the signal issue.)

I hope your cases get resolved shortly
3-23 00:25
Use props
Buzzyone
Captain
Flight distance : 2417297 ft
  • >>>
United Kingdom
Offline

The GPS board on the drone is self contained and outputs the GPS data to the control board. So any GPS problems will be confined to that board. The two antenna cables, I believe are the ADS-B antennas feeding into the GPS board.

If you can’t get a lock then I would return as faulty. I have had a few Mavics in for repair where there was a dry solder joint on the GPS antenna to the PCB. As it’s under warranty then I would be using it.
3-23 01:16
Use props
djiuser_FOZjefmeMeZg
lvl.4

Greece
Offline

Hello guys. I have the same error messages. I bought this drone on Saturday and only have 2 flights. There hasn't been a crash and the drone is in pristine condition.
Yesterday i powered on to check my battery levels and i show the errors! This morning i contacted my dealer and went to have it checked. Now i am waiting for a replacement (RMA)
Here are some photos i got from the goggles



3-31 08:52
Use props
ApoIIo
lvl.3
Flight distance : 36860 ft
Australia
Offline

djiuser_FOZjefmeMeZg Posted at 3-31 08:52
Hello guys. I have the same error messages. I bought this drone on Saturday and only have 2 flights. There hasn't been a crash and the drone is in pristine condition.
Yesterday i powered on to check my battery levels and i show the errors! This morning i contacted my dealer and went to have it checked. Now i am waiting for a replacement (RMA)
Here are some photos i got from the goggles

Replaced mine under warranty. If it happens again ill be annoyed
3-31 16:58
Use props
FlyingSnoopy
lvl.4

Greece
Offline

As i said on the other topic, i returned mine yesterday to the dealer and i am waiting for the RMA process to complete so i can get a replacement. I am really sad !
4-1 12:34
Use props
ApoIIo
lvl.3
Flight distance : 36860 ft
Australia
Offline

FlyingSnoopy Posted at 4-1 12:34
As i said on the other topic, i returned mine yesterday to the dealer and i am waiting for the RMA process to complete so i can get a replacement. I am really sad !

It is sad man. I was extremely annoyed. I really hoping it’s just a bad Batch of drones and now a model wide problem. I would love to hear from DJI if they are investigating the issue.
4-1 16:28
Use props
Riwak
lvl.2
Flight distance : 996506 ft
France
Offline

Exact same situation for me here ! We are Beta tester...
4-3 12:05
Use props
FlyingSnoopy
lvl.4

Greece
Offline

Riwak Posted at 4-3 12:05
Exact same situation for me here ! We are Beta tester...

This is exactly what my dealer told me! We are beta testers!
I got a replacement unit and in the middle of the first flight i got a yellow spot, look here:

https://forum.dji.com/forum.php? ... D767%26typeid%3D767
4-3 12:11
Use props
ApoIIo
lvl.3
Flight distance : 36860 ft
Australia
Offline

FlyingSnoopy Posted at 4-3 12:11
This is exactly what my dealer told me! We are beta testers!
I got a replacement unit and in the middle of the first flight i got a yellow spot, look here:


Far out! What the hell is going on with these drones lol
4-3 14:25
Use props
Rob_G
lvl.3
Flight distance : 56732 ft
Canada
Offline

Wow, I'm just shocked at all the hardware and software issues that many seem to be having with the DJI FPV.  Bad pixels, can't activate (blank goggle serial), sensor errors, transmitter issues etc.  It just seems to be a wide gamut of quality control issues affecting many different components.  It's a shame because I really wanted the DJI FPV, but I bought a Mini 2 instead.  

Rob     
4-6 00:21
Use props
djiuser_rGkMf0dvhPJN
lvl.1
South Korea
Offline

Same problem sensors error/gps error
4-6 01:35
Use props
Arbie Cawilan
lvl.1

Japan
Offline

Is there anyone how to fix this problem
4-17 04:00
Use props
fansb0b342a7
lvl.1
Flight distance : 8212 ft
Belgium
Offline

I am experiencing the same problem, the device keeps saying there is a gps error...
4-17 13:54
Use props
fansb0b342a7
lvl.1
Flight distance : 8212 ft
Belgium
Offline

I am experiencing the same problem, the device keeps saying there is a gps error...
4-17 13:55
Use props
djiuser_sYlyUkiVgcaV
lvl.1

United States
Offline

Adding another one to the pile. Talked to DJI this AM and they said "yea send it back". I got mine from Amazon so it should happen relatively quickly.
Just highly frustrating and worried it'll happen again.

Got the drone 4/5 days ago. Flew 3 times. No water, no crashes, only sport and normal mode.
Changed from the clear cover to the green one (that I painted white), and got this error the next time I powered on.
Tried recalibrating everything I can find to recalibrate. Reinstalled firmware update. Let it sit over night. Triple checked both batteries on the drone were fully charged and all other batteries were charged. Tried with and without a phone tethered to it. Tried switching back to the clear cover. Tried with no cover. Inspected all the internals as best I could.
Nothing changed it.

It DOES look like you could easily dislodge the two small plugs behind the chip with the FPV sticker on it (they're under a sticky foam pad), but I checked those and they were solid. Then tried unplugging them and plugging them back in.

Absolutely seems like a design fault in the drone itself.

The only other thing I did "differently" between it working and not working (Showing "GPS Error" and "Sensor System Error"), was do a few training courses on their Virtual Flight app (which also required adjusting the control stick).
Can anyone else chime in with whether or not they've had this happen after FPV training? I doubt it's related, but can't hurt to take a roll-call.
Replacing the clear cover with a painted one though seems to be the most common denominator.

I should have my new one on Wednesday (May 12, 2021). I plan on testing it out, then immediately swapping the covers to see if that reproduces the same issue. I'll try to remember to report back.
5-5 17:53
Use props
djiuser_sYlyUkiVgcaV
lvl.1

United States
Offline


Adding another one to the pile. Talked to DJI this AM and they said "yea send it back". I got mine from Amazon so it should happen relatively quickly.
Just highly frustrating and worried it'll happen again.

Got the drone 4/5 days ago. Flew 3 times. No water, no crashes, only sport and normal mode.
Changed from the clear cover to the green one (that I painted white), and got this error the next time I powered on.
Tried recalibrating everything I can find to recalibrate. Reinstalled firmware update. Let it sit over night. Triple checked both batteries on the drone were fully charged and all other batteries were charged. Tried with and without a phone tethered to it. Tried switching back to the clear cover. Tried with no cover. Inspected all the internals as best I could.
Nothing changed it.

It DOES look like you could easily dislodge the two small plugs behind the chip with the FPV sticker on it (they're under a sticky foam pad), but I checked those and they were solid. Then tried unplugging them and plugging them back in.

Absolutely seems like a design fault in the drone itself.

The only other thing I did "differently" between it working and not working (Showing "GPS Error" and "Sensor System Error"), was do a few training courses on their Virtual Flight app (which also required adjusting the control stick).
Can anyone else chime in with whether or not they've had this happen after FPV training? I doubt it's related, but can't hurt to take a roll-call.
Replacing the clear cover with a painted one though seems to be the most common denominator.

I should have my new one on Wednesday (May 12, 2021). I plan on testing it out, then immediately swapping the covers to see if that reproduces the same issue. I'll try to remember to report back.
5-5 17:55
Use props
Arbie Cawilan
lvl.1

Japan
Offline

I already fix mine, and I’m flying again with no issues.
5-7 19:43
Use props
djiuser_rGkMf0dvhPJN
lvl.1
South Korea
Offline

Arbie Cawilan Posted at 5-7 19:43
I already fix mine, and I’m flying again with no issues.

how was fixed?
5-8 17:42
Use props
sbarton
lvl.4
Flight distance : 877110 ft
United States
Offline


You have to send it back and get a new one.
5-10 06:04
Use props
Robpca81
lvl.1

United States
Offline

Looks like I will be shipping mine back! Never even got to fly it once!
5-12 20:54
Use props
Spikemixture
lvl.3
Flight distance : 49918 ft
  • >>>
Philippines
Offline

djiuser_sYlyUkiVgcaV Posted at 5-5 17:55
Adding another one to the pile. Talked to DJI this AM and they said "yea send it back". I got mine from Amazon so it should happen relatively quickly.
Just highly frustrating and worried it'll happen again.

It DOES look like you could easily dislodge the two small plugs behind the chip with the FPV sticker on it (they're under a sticky foam pad), but I checked those and they were solid. Then tried unplugging them and plugging them back in.

Yep mine 'unplugged' with very little force - that I am aware of ! And I could not 'replug' them.
I sent it back and they repaired it but now get the errors mentioned here.


Has everyone here that gets this error changed or taken off the cover ?


5-12 22:58
Use props
FlyingSnoopy
lvl.4

Greece
Offline

Spikemixture Posted at 5-12 22:58
It DOES look like you could easily dislodge the two small plugs behind the chip with the FPV sticker on it (they're under a sticky foam pad), but I checked those and they were solid. Then tried unplugging them and plugging them back in.

Yep mine 'unplugged' with very little force - that I am aware of ! And I could not 'replug' them.

Like 9 out of 10 people got this error by replacing the cover.
I got a replacement drone, but i am not going to change the cover untill i have enough fun with it.
Around September i will try to repalce the cover and see if i get the error again.
P.S I doubt that the problem is the plugs on the back. Probably there is a disconnection of the flex tape between the GPS module and main module
5-12 23:47
Use props
djiuser_sYlyUkiVgcaV
lvl.1

United States
Offline

got my “replacement” from Amazon (I just ordered another one before returning my original one)
I wanna fly it for a bit before replacing the cover again. However, I have confirmed it’s the drone itself. Not the controller or goggles (not that there was much question of that, but at least it’s a little more information).
I’m using my original goggles and remote with the new drone and it’s currently working.

Pretty shocked DJI’s still silent on the matter.
5-13 09:08
Use props
fans5230e465
lvl.2
Flight distance : 70325 ft
Italy
Offline

Spikemixture Posted at 5-12 22:58
It DOES look like you could easily dislodge the two small plugs behind the chip with the FPV sticker on it (they're under a sticky foam pad), but I checked those and they were solid. Then tried unplugging them and plugging them back in.

Yep mine 'unplugged' with very little force - that I am aware of ! And I could not 'replug' them.

Same problem. Just yesterday try to change the cover. At the end of the process the problem appear. Try to plug and unplug the tiny cable on the back but nothing happens. Just opened an RMA ticket. I’m waiting to have answer from DJI. So sad
5-13 19:34
Use props
supernicko
lvl.1
Flight distance : 203002 ft
Australia
Offline

supernicko Posted at 3-14 17:23
Can’t see any bad connections tried recalibration imu and compass in drone worked fine- camera works - dji assistant 2 recalibrate sensor works as does refresh firmware - just not connecting the gps and sensor I assume gps is the top chip with the fpv sticker on it - and white black cable runs down left and right side towards the sensor array seems to be the connection tot the top rear coax mini plugs maybe antenna maybe sensors not sure - got me beat I can’t be bothered sending in I wanna play more I even painted go fast gt stripes on her !

FIXED : it sat on a shelf for months as i couldnt be bothered with the bs of sending it in.... saw on a similar thread a guy who replaced his gps - works out its EASY AS! Once your cover is off, its 2 screws, 2 little antenna plugs which stay intact with the sticky tape - and 1 little data plug - so easy -  i bought the original part from my local supplier - plugged in - turned on - all back to normal. SENSOR ERROR AND GPS ERROR are gone and ive just flown 3 batteries. Thought id post incase it helps - i have refresh and i know it was prob under warranty but for $40 USD i couldnt be bothered... As a side note the gps chip antenna basically press against the cover - so for those saying they took the cover off check your plugs first -but im wondering if the pressure of the cover there can bust the chip.. or a light crash could easily put pressure on it. Hope it helps - NICKO PERTH WEST AUSTRALIA!
6-21 01:32
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules