Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 1 Follow Me Mode Issue
3025 9 2015-12-8
Uploading and Loding Picture ...(0/1)
o(^-^)o
jeff_yeager
lvl.1
Flight distance : 459072 ft
  • >>>
United States
Offline

I tried out the new firmware and follow me mode today.  Seemed to be working ok for a minute or two but when I turned around and started walking toward the copter which was hovering about 50 feet up, it freaked out and started to oscillate wildley.  I tried to get control of it but it was only halfway responding to my inputs.  It ended up dumping into a dune with fortunately dune grass and sand which softened the landing.  It then kept trying to fly until I got up to it to power it down.  I'm definitely concerned about using this feature again.  I did a test flight when I got home and all seems to be ok.  Did a complete calibration and compass dance before test flight.  Something ain't right with firmware and flight mode.  I have never had a flight issue in the few years I have owned this.
2015-12-8
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

Hi Jeff,
you are using a GPS enabled device correct?
2015-12-8
Use props
gybo102
First Officer
Flight distance : 2426230 ft
United States
Offline

Not sure of what happened, but some advice, when you are using any of the "auto flight" modes, ALWAYS be ready to switch it back to normal GPS or ATTI mode to kick away the "program" / flight mode its in. for example. After I execute a way point flight, I always have my finger on the switch to change it back just in case something comes up, like it loosing gps or having a compass error. you dont want to rely on the flight controller from deciding what it needs to do when it does not know where it is.
A little drawn out, I know. But in this situation, the moment you noticed you could not control it properly, Im willing to bet if you would had switched it to normal GPS or ATTI, it would not had eaten sand. Not trying to be harsh, but this info need to get out there. you can not always rely on the flight controller to do the right thing, even when you are in normal gps mode.
Not doubting there may be a bug with "follow me" or what not...  I will possibly try it out this weekend.
2015-12-8
Use props
DJI-Dave
Captain

United States
Offline

Sounds like something other than the follow me mode. But I understand your concern.
You said you did a compass cal and then had a good flight. I would recommend doing a full IMU cal also.
2015-12-8
Use props
jeff_yeager
lvl.1
Flight distance : 459072 ft
  • >>>
United States
Offline

Thanks guys.  After sitting down and recalibrating everything I could of prevented its spiraling down to earth by flipping the switch.  I was just so shocked because I have never experienced anything like it with this craft.  Been really solid for me.  So as soon as I saw it out of control I was afraid to take my eyes off it.  Just tried to ease it down.  I was in GPS mode and I did a full IMU cal and GPS cal before flight.  It was strange.  I guess I can try it again with finger on GPS switch.  One other thing.  Something I have noticed in last two firmware updates is radio signal shows poor but full bars at top of screen next to radio.  It goes back and forth between poor and good.  I deleted the app on my ipad and reinstalled it.  Still no good.  Should I uncheck hardware decode?  rebind radio?

Thanks.
2015-12-8
Use props
patrick.cusack
lvl.1

Australia
Offline

I've seen all sorts of mayhem with various DJIs, MikroKopter, Pixhawk/Arducopter and Multiwii controllers in GPS and/or IOC modes - and (nearly) every time it was turning everything off and flying manual or atti that (eventually) fixed the issue before hitting the scenery.

The causes can be in the environment (microwave interference or mag error from ~somewhere at altitude), or something awry in the vehicle (a short cable loop will spin the compass). It's rarely firmware, but any kind of autonomous flight is pretty spooky/vulnerable once you include apps on this class of OS. A lot can go wrong with all these instruments and software - at any time. On one occasion (very close) fireworks put the altimeter into a coma, and the (MK) vehicle refused to come down!

The Inspire is by far the most tractable vehicle I've flown - but it's just another (expensive) UAV when any of this autonomous control goes awry.
Flying ~manual (tail in with the sticks) - lets you nurse [anything] back when things get weird - for whatever reason.

In the Inspire's case there is no 'manual' but practice just flipping  it to 'atti' - in plenty of space - and get used pulling it into shape - without GPS.
It's harder than it looks, and a bit dirty - because no GPS >2m means *no brakes* - but AFAIK DJI FC can't/don't trap GPS errors in mag storms, and that alone can pitch everything ~100m in a few seconds..

* Your options in situations like this are prayer, or turn off all the ~dirty inputs and just fly with sticks.
* There's no way I'd use any of this ~autonomous stuff (particularly third party apps) without exploring this 'escape' option first. It can be a life saver :-)

I've no idea why 'Follow Me' (gimbal) would disrupt the flight controller's role with vehicle stability, but FWIW I've heard there are some 'undocumented features' in the latest Inspire Pro firmware V1.2.0.50 and we should go back to 1.1.0.40 until this is sorted out. This release came out on 2015-12-9 - the day you discovered this quirk?

HTH-
Pat.
2015-12-12
Use props
Ionut
New

Romania
Offline

I updated today my I1 to FW 1.6. I tried FOLLOW ME. I have Android Lenovo A3500-H. I have 3G network. When I enter in Follow me and I press Aply, it says this:
”No sensor is found on the mobile device. Cannot integrate IMU data.”
And it doesn't follow me when I walk. Can anybody help?
2016-1-1
Use props
tbleeker
New

Netherlands
Offline

Ionut Posted at 2016-1-1 22:42
I updated today my I1 to FW 1.6. I tried FOLLOW ME. I have Android Lenovo A3500-H. I have 3G network ...

Same problem here but using iPad air, latest iOS, latest DJI Go app and  latest versions on both controller and Inspire. After hitting Apply nothing happens.
2016-5-8
Use props
str1776
lvl.4
Flight distance : 22530 ft
  • >>>
United States
Offline

Ionut Posted at 2016-1-1 13:42
I updated today my I1 to FW 1.6. I tried FOLLOW ME. I have Android Lenovo A3500-H. I have 3G network ...

Hi I'm curios can you do point of interest this will tell you a couple of things.
I had same issue could not get follow me mode to work but the other modes did like orbit mode
I'm made a call you have to have Gps it only worked on my IPhone. I could set the RC Down and put the phone in my pocket and it will follow me. Not so for the ipad I have no phone service on the ipad.
2016-5-9
Use props
fovetekuz
lvl.1

India
Offline

Ionut Posted at 2016-1-1 12:42
I updated today my I1 to FW 1.6. I tried FOLLOW ME. I have Android Lenovo A3500-H. I have 3G network. When I enter in Follow me and I press Aply, it says this:
”No sensor is found on the mobile device. Cannot integrate IMU data.”
And it doesn't follow me when I walk. Can anybody help?

Make sure your phone should be compatible with app. To make it compatible you have to check regular updates and download them. Check update for application. Clear cached app data. Also if possible then upgrade your phone to  new firmware. For more troubleshooting hacks check Lenovo A7-50 Tablet (A3500) Manual.
2017-3-21
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules