Please select Into the mobile phone version | Continue to access the computer ver.
Inspire 1 Pro New Firmware V1.2.0.50
12Next >
5748 72 2015-12-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
DJI-Tim
DJI team

Hong Kong
Offline

The latest Inspire 1 Pro firmware has been released. Download the firmware update package from the product page on the official DJI website http://www.dji.com/product/inspire-1-pro-and-raw/download
ip.JPG

Overview:
1.      Upgrade the firmware to v1.2.0.50.
2.      Upgrade the DJI GO app iOS to v2.4.2.
3.      Upgrade the DJI GO app Android to v2.4.2.

MajorUpdates
1.      Fixed issue of battery level fluctuation.
2.      Fixed issue of flicking lines in night scenes.
3.      Fixed issue of flicking dots in dark areas.
4.      Reduced noise for photos and video.
5.      Decreased the sharpness settings for D-LOG and D-Cinelike.
6.      Fine-tuned the tone curve for photos and video.
7.      Tuned down 3D denoising for night scenes.

Note:
1.      This release includes a battery firmware upgrade. Be sure to upgrade all your batteries.
2.      The firmware is intended for the Zenmuse X5 camera only. DO NOT mount the ZenmuseX3 for this upgrade.
3.      The firmware can be downgraded to v1.0.0.30 or later only.


============================================================================
12/10/2015
For  the issue with 'Version 1.4.00.10+' is fixed. Please download the firmware again and upgrade.

2015-12-9
Use props
gboivin
First Officer
Flight distance : 1544416 ft
  • >>>
United States
Offline

DJI-Tim Thanks for the clarification!
2015-12-9
Use props
drone vision
lvl.1

United Kingdom
Offline

gboivin@msn.com Posted at 2015-12-9 11:56
DJI-Tim Thanks for the clarification!

Hi DJI Tim, thanks for the update information.   I realise my next question may seem basic to some, but when I do the update do I just do it once?. Then remove the .bin file if its been successful.   or do I have to keep doing a restart with the FW .bin file on the SD card for each battery  - or - do the batteries automatically update when I put them in prior to flight/
2015-12-9
Use props
airymok
lvl.4
Flight distance : 2623652 ft
Hong Kong
Offline

drone vision Posted at 2015-12-9 20:12
Hi DJI Tim, thanks for the update information.   I realise my next question may seem basic to some ...

keep the firmware in SD card to upgrade all your batteries.
2015-12-9
Use props
avia.arm
lvl.1

Armenia
Offline

After Upgrade in go App  write the aircraft need update   and show version 1.4.00.10+
2015-12-9
Use props
drone vision
lvl.1

United Kingdom
Offline

airymok Posted at 2015-12-9 12:28
keep the firmware in SD card to upgrade all your batteries.

Hi DJI Tim   some advice please.

I have just carried out the new update on my Inspire Pro.  everything went well. I carried it out three times with a different battery to ensure they were updated.   All went well and the .txt message in each case was success.   

Then am quick test with the RC to ensure all was well and connected.

I m, now getting a message Aircraft State  to tell me  'Update Required.'

the Message in About confirms:

App:         Version 2.4.2
Aircraft    Version 1.4.00.10+
RC            Version  1.5.70
Camera   Version1.2.0.50

Is the message telling me I need further FW update??   or that I need to calibrate  compass etc??
2015-12-9
Use props
Linolens
Second Officer
Flight distance : 501250 ft
Macao
Offline

drone vision Posted at 2015-12-9 21:54
Hi DJI Tim   some advice please.

I have just carried out the new update on my Inspire Pro.  every ...

same here.........
Spent the last hour trying to figure it out.
2015-12-9
Use props
drone vision
lvl.1

United Kingdom
Offline

drone vision Posted at 2015-12-9 13:54
Hi DJI Tim   some advice please.

I have just carried out the new update on my Inspire Pro.  every ...

Is it relevant that updating to V1.2.0.50 has also changed my Aircraft version from V1.2.1.06+  to 1.4.00.10+
Despite original advice should I now be updating to the Verson 1.5   that We were advised was only for Inspire 1 with X3 camera


2015-12-9
Use props
Linolens
Second Officer
Flight distance : 501250 ft
Macao
Offline

drone vision Posted at 2015-12-9 22:27
Is it relevant that updating to V1.2.0.50 has also changed my Aircraft version from V1.2.1.06+  to ...

i think the issue is the App telling you that the aircraft needs an update, after the update has been successfully done. Or so I assume...
2015-12-9
Use props
Dragonflyin
lvl.4
Flight distance : 16562 ft
  • >>>
United States
Offline

So there is no 'follow me' feature or RC upgrade included in this Inspie Pro FW upgrade?
2015-12-9
Use props
Linolens
Second Officer
Flight distance : 501250 ft
Macao
Offline

Dragonflyin Posted at 2015-12-9 22:35
So there is no 'follow me' feature or RC upgrade included in this Inspie Pro FW upgrade?

camera FW upgrade only
2015-12-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

if you have an Inspire1 then the latest update is 1.5.0.3 that was released on Dec 7th.
If you have an Inspire Pro then the latest release is 1.2.0.50 that was released this morning.
Users with the Pro were seeing the "Upgrade Required" but they should have only seen it with the Inspire1. So this mornings update for the Pro will fix that.

2015-12-9
Use props
marc.aries-serv
lvl.1

United Kingdom
Offline

Ken, have updated the firmware for my Inspire Pro with this mornings release but still have the message "aircraft requires upgrade"

Firmware info as follows on my Inspire Pro

App =     Version    2.4.2
Aircraft  =  Version 1.5.00.30
RC =            Version 1.5.70
Camera =   Version 1.2.0.50
2015-12-9
Use props
marc.aries-serv
lvl.1

United Kingdom
Offline

Follow up from my previous post, formatted my sd card for the X5 and when checking firmware info on the DJI Go app, my aircraft now says  Version 1.1.4.00.10+ !!!!

Whats going on DJI ??
2015-12-9
Use props
HEJM
lvl.2
Flight distance : 872362 ft
Germany
Offline

Same here, getting an "Upgrade Required" warning after the Inspire 1 Pro upgrade V1.2.0.50
I have an Inspire 1 Pro (not Inspire 1 with additional Zenmuse x5)

App        2.4.2
Aircraft  1.4.00.10+
RC          1.5.70
Camera 1.2.0.50
2015-12-9
Use props
ardian
lvl.4
Flight distance : 455197 ft
  • >>>
United States
Offline

noticing some flaws on firmware update
with inspire 1 pro X5,updating success however now i don't have a signal
app 2.4.2
aircraft 1.4.00.10+ (even though i downloaded 1.2.0.50)
RC 1.5.70
this my dear friends is typical DJI.....
2015-12-9
Use props
ardian
lvl.4
Flight distance : 455197 ft
  • >>>
United States
Offline

ardian Posted at 2015-12-9 10:27
noticing some flaws on firmware update
with inspire 1 pro X5,updating success however now i don't h ...

just spoke to customer service and they are waiting for a response from headquarters
apparently I'm not the only one with this issue.With that being said upgrade F/W if you want
HOWEVER consider yourself warned!!!
2015-12-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

marc.aries-serv Posted at 2015-12-9 23:59
Ken, have updated the firmware for my Inspire Pro with this mornings release but still have the mess ...

Mi Marc,
It seems some other customers are also having an issue.
They are working on it now and should have a solution soon.
2015-12-9
Use props
drone vision
lvl.1

United Kingdom
Offline

DJI-Ken Posted at 2015-12-9 15:22
if you have an Inspire1 then the latest update is 1.5.0.3 that was released on Dec 7th.
If you have  ...

hi Ken   I think you'll see from all of the posts on this thread that people are surprised that they have updated to V1.2.0.50  which has worked and updated the camera but has also changed the FW version of the  Aircraft. in my and other peoples case this has been to 1.40.00.10+.

Annoyingly now being told update required even though the.txt file shows it a success.   This mornings update didn't cure anything but caused a new problem!!!

Any response on action to take??
2015-12-9
Use props
drone vision
lvl.1

United Kingdom
Offline

DJI-Ken Posted at 2015-12-9 15:22
if you have an Inspire1 then the latest update is 1.5.0.3 that was released on Dec 7th.
If you have  ...

hi Ken   I think you'll see from all of the posts on this thread that people are surprised that they have updated to V1.2.0.50  which has worked and updated the camera but has also changed the FW version of the  Aircraft. in my and other peoples case this has been to 1.40.00.10+.

Annoyingly now being told update required even though the.txt file shows it a success.   This mornings update didn't cure anything but caused a new problem!!!

Any response on action to take??
2015-12-9
Use props
emulsiondown
lvl.1

United States
Offline

Tim - the link you provided brings up this page...

404

SORRY,THAT PAGE DOESN’T EXIST
OR IS UNAVAILABLE.

GO BACK TO DJI.COM

OR CONTACT US ABOUT A PROBLEM.
2015-12-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

X5 Pro users, for now please downgrade the firmware back to 1.1.0.40 then you should be working as before.
A solution will be found soon. It seems there's a glitch in the 1.2.0.50 firmware.
2015-12-9
Use props
Ryan Gordon
lvl.3
Flight distance : 2186250 ft
  • >>>
United States
Offline

Do we have to downgrade each of our batteries as well that were updated this morning?
2015-12-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

Ryan Gordon Posted at 2015-12-10 01:57
Do we have to downgrade each of our batteries as well that were updated this morning?

The updates for the battery are fine so there is no reason to downgrade each battery. But downgrading will remove the battery fixes on 1.2.0.50, so when you downgrade to 1.0.40 the battery used will also downgrade.
That one battery will just act as it did before the downgrade. And if you absolutely have to the the battery fluctuation issue fixed, then i suggest not using that battery until there's a solution to the 1.2.0.50 update.
2015-12-9
Use props
coyut.riot
Second Officer
Flight distance : 2559222 ft
  • >>>
Switzerland
Offline

DJI-Ken Posted at 2015-12-9 19:17
The updates for the battery are fine so there is no reason to downgrade each battery. But downgrad ...

The 1.2.0.50 firmware is still up at the DJI site.  It's available for download.
Is it already fixed? If not why is it still up?

I updated just about an hour ago or so but also get the "Aircraft requires upgrade" Information. (Aircraft 1.4.00.10+)
Will the next fixed update run over the 1.2.0.50?
I don't want to downgrade, as .40 was just a mess and not usable for customer work!

DJI should really better test their upgrades prior publishing them !
2015-12-9
Use props
Rob W
Captain
Flight distance : 94390 ft
  • >>>
Sweden
Offline

DJI-Ken Posted at 2015-12-9 19:17
The updates for the battery are fine so there is no reason to downgrade each battery. But downgrad ...

@ DJI:
While fixing this firmware, please incorporate the increased bitrate for PAL. Somehow that slipped, and only NTSC got the update. See the thread "Increased bitrates in new firmware, WTH?!" here on the forum.
2015-12-9
Use props
Ryan Gordon
lvl.3
Flight distance : 2186250 ft
  • >>>
United States
Offline

Does this update make the drone unsafe to use? Has the update made the drone unusable or is it just that the app tells you to upgrade?
2015-12-9
Use props
ianw79
lvl.1
Flight distance : 275856 ft
  • >>>
United Kingdom
Offline

I think DJI's Firmware Programmers went out for a particularly hardcore xmas party at the weekend!
2015-12-9
Use props
ianw79
lvl.1
Flight distance : 275856 ft
  • >>>
United Kingdom
Offline

My inspire 1 PRO aircraft firmware was already on V1.4.00.10+. This firmware needs to upgrade the aircrafts firmware to V1.5.0.30. The aircraft firmware on the I1Pro and the I1 should be the same as they are the same craft. It's only the camera firmware that should be different. DJI just put the wrong aircraft firmware in the update.
2015-12-9
Use props
ianw79
lvl.1
Flight distance : 275856 ft
  • >>>
United Kingdom
Offline

DJI-Ken Posted at 2015-12-9 17:55
X5 Pro users, for now please downgrade the firmware back to 1.1.0.40 then you should be working as b ...

Working as before but it will still tell us an upgrade is required because you need to include the aircraft firmware V1.5.0.30 in the package.
2015-12-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

ianw79@mac.com Posted at 2015-12-10 05:44
Working as before but it will still tell us an upgrade is required because you need to include the ...

Yes, they will get that solved hopefully by tomorrow.
2015-12-9
Use props
DJI.Terry
DJI team

Hong Kong
Offline

emulsiondown Posted at 2015-12-10 01:38
Tim - the link you provided brings up this page...

404

Fixed. Thanks.
2015-12-9
Use props
flightstick
lvl.1

South Africa
Offline


when is this new update going to be released
2015-12-9
Use props
DJI-Tim
DJI team

Hong Kong
Offline

avia.arm@gmail. Posted at 2015-12-9 21:33
After Upgrade in go App  write the aircraft need update   and show version 1.4.00.10+

For the first time you have to have the internet connection so see a  new FW version
2015-12-9
Use props
airymok
lvl.4
Flight distance : 2623652 ft
Hong Kong
Offline

flightstick Posted at 2015-12-10 14:05
when is this new update going to be released

Download the firmware again, it should fix. I can see a new update in dji website, v1.2.0.50. The release date is the today.
2015-12-9
Use props
DJI-Tim
DJI team

Hong Kong
Offline

Linolens Posted at 2015-12-9 22:29
i think the issue is the App telling you that the aircraft needs an update, after the update has b ...

Right, if your update sucseed , it's just an application that shows the old version
2015-12-9
Use props
DJI-Tim
DJI team

Hong Kong
Offline

Rob W Posted at 2015-12-10 02:59
@ DJI:
While fixing this firmware, please incorporate the increased bitrate for PAL. Somehow that s ...

Thanks for your solution again! it's been  already reported to our engineers
2015-12-9
Use props
DJI-Terry
lvl.3

Hong Kong
Offline

Hi, All
'Version 1.4.00.10+' is fixed. Please download the firmware again and upgrade.
2015-12-9
Use props
Linolens
Second Officer
Flight distance : 501250 ft
Macao
Offline

DJI-Tim Posted at 2015-12-10 14:24
Right, if your update sucseed , it's just an application that shows the old version

Another bit of info:
Only the Android app is accusing the need for update.
iOS is fine

tks Tim
2015-12-9
Use props
oncan.ozgur
lvl.1

Turkey
Offline

Hi All,

I have a inspire 1 ( normal ) but additional X5
I think that I just follow inspire Pro updates but my motors is not 3510h. That is why, should i change any gain settings ? or do anything ? after install inspire pro filmware
thanks
ozgur
2015-12-9
Use props
12Next >
Advanced
You need to log in before you can reply Login | Register now

Credit Rules