Please select Into the mobile phone version | Continue to access the computer ver.
Firmware won't upgrade
739 8 2016-1-29
Uploading and Loding Picture ...(0/1)
o(^-^)o
SpaceBass
lvl.2
United States
Offline

Hey folks,

I've got a brand new P3A - fresh out of the Amazon box. It's got 1.4.x on the drone and the software tells me I need to upgrade.

I've followed the instructions closely and have called support 2x (not the world's greatest experience... was first told to go buy an andrioid phone and then told to go to best but and get another SD card [bestbut is 30 minutes away on a good day]).

I've tried:

* format card in Go app --> mount on Mac with a card reader --> Copy 1.5 firmware --> insert into drone --> power on drone (keep RC power off)
* format card in Go app --> mount on Mac with a card reader --> Copy 1.6 firmware --> insert into drone --> power on drone (keep RC power off)
* mount on Mac with a card reader --> Format as MS-DOS (FAT) -->  Copy 1.5 firmware --> insert into drone --> power on drone (keep RC power off)
* mount on Mac with a card reader --> Format as MS-DOS (FAT) -->  Copy 1.6 firmware --> insert into drone --> power on drone (keep RC power off)
* mount on Mac with a card reader --> Format as MS-DOS (FAT) -->  Copy 1.5 firmware --> insert into drone --> power on drone (keep RC power off)
* Plug gimbal into mac --> Copy 1.5 firmware -->power on drone (keep RC power off)
* Plug gimbal into mac --> Copy 1.6 firmware -->power on drone (keep RC power off)
* Renstall firmware (link from DJI support main page: HOW TO: Reinstall a Phantom 3 firmware. )

When the P3A boots, the gimbal light blinks green quickly and just stays green. It never flashes green to red. I never hear any diferent tones. And I never get a "success" file on the drive.

I'm pretty fustrated ... excerbated by the fact that apparently I live close enough to DC that, regardless of FAA regulations and being a licensed pilot, DJI has determined I shouldn be allowed to use their product even indoors. (Not intending to start a debate, I know it's a hot topic...but it doesnt help the fustration level).

Anyone have any tips before I pack this thing up and send it back? It was a replacement for a Beebop that I lost in our recent snow storm...thinking I'll go back to the beebpo.

(sorry for the negitive tone...just flusterd with an expensive purchase)



2016-1-29
Use props
JaxBchFlyer
lvl.2

United States
Offline

Did you unzip the file and copy only the .bin file to the root directory of the card? seems like it is not detecting a .bin file .
2016-1-29
Use props
z5.zonefive
lvl.2
Flight distance : 24298 ft
United States
Offline

I can't tell you if  the Mac has anything to do with it or not.(PC/android)  What I can say, is that if you have 1.4 on the bird, that you have no reason to upgrade to 1.6.  You get all the features with 1.4 .

With that said, you shouldn't have had to do anything to the card.  Just as JaxBch said, unzip the file, and but the BIN only file in the root of the SD card.  turn the phantom on and it does the rest.  Look at the files on the card and see if there is a txt file on it.  If there is, it will tell you why it didn't upload.  If there isn't then you don't have the BIN file in the root directory.  If not, format the card with the Go App, and copy the unzipped file to it and put it in the Quad.  turn the battery on and watch the light flash red/green till its done.

Or just leave 1.4 on it and go fly.  :-)
2016-1-29
Use props
SpaceBass
lvl.2
United States
Offline

Thanks everyone! I'm certain I have the .bin file only. I wouldn't think using a Mac would be the issue but I'm not above trying it with Linux. (I don't have a Windows machine).
2016-1-30
Use props
SpaceBass
lvl.2
United States
Offline

I was hoping 1.6 would give me geo fencing over ride - is the true? Otherwise I'll never be able to use a dji product apparently
2016-1-30
Use props
SpaceBass
lvl.2
United States
Offline

SpaceBass Posted at 2016-1-30 08:15
I was hoping 1.6 would give me geo fencing over ride - is the true? Otherwise I'll never be able to  ...

Thought I'd report back - downloading and copying the file over on Linux worked perfectly. There's something going on with either the unzip or the copy on OS X 10.11 that seems to be problematic
2016-1-31
Use props
sygriffin
New

United States
Offline

SpaceBass Posted at 2016-2-1 04:24
Thought I'd report back - downloading and copying the file over on Linux worked perfectly. There's ...

I have had the exact same problem and frustration with Mac. Any ideas other than through a Linux OS?
2016-2-13
Use props
sygriffin
New

United States
Offline

SpaceBass Posted at 2016-2-1 04:24
Thought I'd report back - downloading and copying the file over on Linux worked perfectly. There's ...

I have had the exact same problem and frustration with Mac. Any ideas other than through a Linux OS?
2016-2-13
Use props
SpaceBass
lvl.2
United States
Offline

sygriffin Posted at 2016-2-14 00:53
I have had the exact same problem and frustration with Mac. Any ideas other than through a Linux O ...

I haven't had time to delve into what's happening with 10.11.x to see why it isn't working but I have a few thoughts...

First, OS X's copy may have changed and it might be adding some attributes or permissions which DJI's boot loader doesn't like.

It might also be a shadow file ( PAfimrware.1.6.x.bin vs .pafirmware.... )

Things to try, if you are nerdy, might be to use scp in a terminal (I used cp, which works just like the Finder's copy... No dice) ... One might also try rsync -avz
2016-2-16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules