Please select Into the mobile phone version | Continue to access the computer ver.
Pan Drift: solved. Rebalance!
2167 4 2015-1-7
Uploading and Loding Picture ...(0/1)
o(^-^)o
kevin
lvl.1

United States
Offline

Just updated to the latest software, and I'm having really extreme pan drift.  Not sure what software version I had before this, but I had none of this pan drift.  Was having intermittent stuttering in remote control while using the S.Bus port, so I updated the firmware- now it drifs almost at 1rpm.

Tried system calibration 5+ times, with the USB plugged in, via bluetooth, with the S.Bus receiver removed, with the radio off- no luck.  Still spins like a clock.

Any guesses?

-Kevin
EDIT:  gimbal was not fully balanced.  During calibration mode, if your gimbal is making noises, re-balance first!


2015-1-7
Use props
steelej80
lvl.3
United Kingdom
Offline

I'm having this issue too, I've tracked it down to the smoothtrack pan deadband setting, if I set to 0 it won't drift if I set to something like 10 it will drift round to 10 degrees. I also see the issue during startup, the ronin won't centre, it stops at the deadband setting. DJI say they know about the startup issue but didn't mention the drift. Looks like pan deadband is pretty broken in v2.3.

Can you try setting your smoothtrack pan deadband to 0 and report back if it still drifts?

Thanks.

John
2015-1-8
Use props
steelej80
lvl.3
United Kingdom
Offline

steelej80@googl Posted at 2015-1-8 17:01
I'm having this issue too, I've tracked it down to the smoothtrack pan deadband setting, if I set to ...


Just re-read and maybe my issue is different, it doesn't just spin around, it only goes to the deadband setting.

John
2015-1-8
Use props
DJI-Dboy
lvl.4

China
Offline

Hi, Kevin,
Before calibration ronin shall be horizontal and stable.
Calibration the RC with RC assistant software.
Or adjust the Pan motro's trim in software
2015-1-9
Use props
kevin
lvl.1

United States
Offline

I tried the trim function, but it did not seem to have any affect on drift.  It would change the static "center" position, but would not stop drift.

After a few more calibration attempts, I've greatly reduced the drift (from about 360 degrees per minute to 10 degrees per minute.  I'll try centering it, initiating motor kill, then leveling everything and calibrating again.
2015-1-9
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules