Please select Into the mobile phone version | Continue to access the computer ver.
OSMO not powering on
1174 7 2016-3-9
Uploading and Loding Picture ...(0/1)
o(^-^)o
AerialVid
lvl.2
Flight distance : 1398428 ft
  • >>>
Offline

[size=14.6667px]Update: it magically decided to start working again... :/ same battery was in and and i tried again after a rest. This happen back in the Fall once also....I will be using it today and this week to see if this happens again. Very strange DJI

[size=14.6667px][size=14.6667px]

Took OSMO out of case this morning for some action and it won't turn on... No lights, no sounds, nothing. I have tried the button combos mentioned in this thread, power + trigger + shutter + record and no change? Anyone else have this problem and get it to work? I have re-charged 1 battery and have another on the charger now, but they were all 100% 2-3 days ago... I hope a dead battery is my issue but I don't think thats the problem...


[size=14.6667px]*3 batteries have now been tried at full charge, no change
2016-3-9
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

What do you mean by not powering on, do you get no lights at all or do you get lights and the gimbal doesn't move at all?
And when it happened last fall, did you send it in for repair?
2016-3-9
Use props
AerialVid
lvl.2
Flight distance : 1398428 ft
  • >>>
Offline

DJI-Ken Posted at 2016-3-10 05:57
What do you mean by not powering on, do you get no lights at all or do you get lights and the gimbal ...

Ken. no the gimbal started working again. All is good. Very strange.... I have no idea how to explain it other than.. it wouldn't turn on batteries full charged. I kept changing packs and then it started working after a couple hours, all has been good again. So trying to explain this to a tech/repair agent would be non existent. I will hope this was a weird connection point or something and all continues working 100%.
2016-3-19
Use props
blindfat
lvl.1
Australia
Offline

Mine is also intermittently not powering on also. Is in for assessment 2 weeks now, will post on outcome
2016-3-19
Use props
DJI-Adela
DJI team

Hong Kong
Offline

AerialVid Posted at 2016-3-20 15:12
Ken. no the gimbal started working again. All is good. Very strange.... I have no idea how to expl ...

Well, congratulations!
it might be just the bad weather? Did you drop it before or was there any misuse?
If you have any problem, let us know.
2016-3-21
Use props
DJI-Adela
DJI team

Hong Kong
Offline

blindfat Posted at 2016-3-20 15:27
Mine is also intermittently not powering on also. Is in for assessment 2 weeks now, will post on out ...

We would look forward the outcome.
2016-3-21
Use props
blindfat
lvl.1
Australia
Offline


2016-5-16
Use props
DJI-Adela
DJI team

Hong Kong
Offline


Hi,
I can't see your picture, could you please upload it again.
Thanks.
2016-5-16
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules