Please select Into the mobile phone version | Continue to access the computer ver.
App not recognizing correct Phantom model...
2890 14 2016-3-12
Uploading and Loding Picture ...(0/1)
o(^-^)o
nickpatrick50
New

United States
Offline

Hello,

I couldn't find my particular issue online, so I figured I would try posting here. I have been using the DJI GO app for a few months now with no problems. However, just recently I tried connecting to the camera view, as usual, and it [the app] thinks my model is the Professional. I have the Advanced. Is there anyway to fix this?

I can still connect to the drone, but I cannot control, or see, the cameras view. It just says "No signal" at the top.

Thanks

2016-3-12
Use props
DJI-Ken
DJI team
Flight distance : 1515312 ft
  • >>>
United States
Offline

Try deleting the app and reinstalling it, also try a relink as well.
Do all the features work?
Have you done an update?
Manual linking Pro-Adv.jpg
2016-3-12
Use props
nickpatrick50
New

United States
Offline

DJI-Ken Posted at 2016-3-12 14:33
Try deleting the app and reinstalling it, also try a relink as well.
Do all the features work?
Have  ...

Thanks for the reply. I tried all the steps you mentioned and it still detects my phantom advanced as a professional.

When I go to view the camera it says "no signal" at the top. It also says gimbal is disconnected.

When I first got the phantom I updated to the latest (1.6).
2016-3-12
Use props
nickpatrick50
New

United States
Offline

nickpatrick50@y Posted at 2016-3-12 14:47
Thanks for the reply. I tried all the steps you mentioned and it still detects my phantom advanced ...

Also, when I start up the drone the gimbal moves around, but then shuts off and is not active anymore.

When I press the button to power off the drone, the red LED blinks really fast (the LED in the button) and it takes longer than usual to turn off.
2016-3-12
Use props
ovidijus9311
lvl.1

United Kingdom
Offline

Ive git exact same peoblem , can you turn your motors on ? Try bringing both sticks down and face each other see what app says?
2016-3-12
Use props
nickpatrick50
New

United States
Offline

ovidijus9311 Posted at 2016-3-12 16:07
Ive git exact same peoblem , can you turn your motors on ? Try bringing both sticks down and face ea ...

Yes, that does turn the motors on.
2016-3-12
Use props
ovidijus9311
lvl.1

United Kingdom
Offline

nickpatrick50@y Posted at 2016-3-12 21:11
Yes, that does turn the motors on.

Oh so you can at least fly it as mine is not activated plus has same problem as yours ... Paid 700 pounds and cant fly it out of box . Great isnt it ...
2016-3-12
Use props
Miamiceez
lvl.1

Offline

This seems to be such a big problem.. Is there no solution to this?  DJI please answer to this...........   
2016-3-12
Use props
nickpatrick50
New

United States
Offline

I tried with other devices (iPad, android phone) and it still detected the wrong phantom model. Does anyone know the manufacturers warranty for the drone?
2016-3-13
Use props
ovidijus9311
lvl.1

United Kingdom
Offline

I think they have one year after activation.
2016-3-13
Use props
Anton_Zda
lvl.1

United States
Offline

Have any of you been able to solve this issue? Same thing is happening to me and I've been troubleshooting for hours with no luck.

I've updated to the latest firmware on both my RC and my drone. When connecting my phone to my controller, the DJI GO app detects a Phantom 3 Professional model instead of a Phantom 3 Advanced. App is not connecting to my drone at all.

Any help would be greatly appreciated.
2017-9-16
Use props
Geebax
Captain
Australia
Offline

Try swiping the page sideways on the app to change to a different model.
2017-9-16
Use props
Dale 68
Captain
Flight distance : 9409 ft
United Kingdom
Offline

Mine keeps thinking its an Inspire. Just swipe across to find the right model, it's a  pain but it works for me.
2017-9-17
Use props
Flysuzu
lvl.2
Flight distance : 89311 ft
Australia
Offline

Anton_Zda Posted at 2017-9-16 17:22
Have any of you been able to solve this issue? Same thing is happening to me and I've been troubleshooting for hours with no luck.

I've updated to the latest firmware on both my RC and my drone. When connecting my phone to my controller, the DJI GO app detects a Phantom 3 Professional model instead of a Phantom 3 Advanced. App is not connecting to my drone at all.

G'day Anton

I had exactly that issue when I first got the P3A. I followed the steps above - manually relinking the RC and drone then redownloaded the app - seemed to work for me. Make sure when you relink that it makes the right sounds and the right lights  so you know it's worked ok.
2017-9-17
Use props
Anton_Zda
lvl.1

United States
Offline

Thanks for the feedback, guys! The problem for me was that after the app detected my drone (it detected the P3 Professional instead of the Advanced model), I was no longer able to swipe through different models within the app. The app basically locked onto the incorrect model and wouldn't let me adjust it after that point.

I was able to choose the "Camera" option as if I was about to connect to the drone, but the app would not fully connect (no data for the drone was displayed and the camera view was not present). After many hours of troubleshooting (including following the steps above), the solution was:

1. Open the DJI GO app.
2. After the app detects the drone (which was the wrong model in this case), choose the "Camera" option to try to connect to the bird. The app opened the flight mode view but again, no drone data was visible which means that the app was not fully connected to the drone.
3. Once the app opened the flight mode view, I went into the settings and under the controller tab, I found the option to "Link your controller".

After I chose this option, the problem was solved. The app started detecting the correct drone model and the app started displaying the drone data in the main flight mode view.

Thanks again, everyone!
2017-9-18
Use props
Advanced
You need to log in before you can reply Login | Register now

Credit Rules